7.7 Загрузка писем из MS Outlook в 1С

Тема в разделе "Обмен данными в "1С:Предприятие 7.7"", создана пользователем Kirya, 30 май 2008.

  1. TopicStarter Overlay
    Kirya
    Offline

    Kirya Опытный в 1С

    Регистрация:
    3 авг 2006
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26
    Кто-нибудь делал такое:
    Из 1с нужно подцепится к MS Outlook и загрузить письма с определенной темой?
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    только обратный процесс делал...
  3. Frosja
    Offline

    Frosja

    Регистрация:
    3 июн 2008
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    В глобальном модуле прописывала.
    Создала справочник спрЗаявки- куда все письма записывала.
    Тему по которой фильтровать можно указать - Если Тема=Хелп Тогда.....
    Код:
    //===================================================================
    //Процедура Приёма писем с ящика
    //===================================================================
    Процедура ЗакачкаПисем()
    Сообщить("Сработал Таймер");
    спрЗаявки = СоздатьОбъект ("Справочник.Заявки");
    Если ЗагрузитьВнешнююКомпоненту("ROM-Mail.dll")=0 Тогда
    Статус ="Не загружен ROM-Mail.dll";
    Иначе
    Попытка
    ВК = СоздатьОбъект("AddIn.AddInMail");
    Исключение
    Сообщить("Ошибка инициализации E-Mail");
    КонецПопытки;   
    ВК.СерверПриема = "сервер приема"; 
    ВК.ПортПриема = "110";
    ВК.Логин ="Логин";
    ВК.Пароль = "Пароль";
    ВК.ОставлятьНаСервере = 0;
    ВК.ПоказыватьПредупреждения = 0;
    Состояние("Подключаемся к серверу для приёма ..."+ТекущееВремя());
    Если ВК.Подключиться("Прием")=0 Тогда
    Предупреждение("Не удалось подключиться к серверу!");
    Возврат;
    КонецЕсли;
    Состояние("На сервере найденно "+ВК.КоличествоСообщений()+" заявок(а).");
    Для Индекс=1 По ВК.КоличествоСообщений() Цикл
    ВК.ПолучитьСообщение(индекс);  
    Отправитель = ВК.ИмяОтправителя;
    Адрес = ВК.АдресОтправителя;
    Тема = ВК.Тема;
    Тело = СокрЛП(ВК.Тело);
    ДатаП = ВК.ДатаОтправки;
    Размер = ВК.Размер;
    Сообщить("Пришло письмо:");
    Сообщить("----------------------------------------");
    Сообщить("От: "+Адрес);
    Сообщить("Тема: "+Тема);  
    Сообщить("Тело: "+Тело);     // проба тела сообщения
    Сообщить("Дата: "+ДатаП);
    Сообщить("Размер: "+Окр((Размер/1024),2,1)+" кб");
    Сообщить("----------------------------------------"); 
    
    спрЗаявки.<span style='cursor: pointer; color:red' Onclick="window.open('http://www.1c-pro.ru/wiki/index.php/новый')">Новый();</span>
    спрЗаявки.Емайл = ВК.АдресОтправителя;    
    спрЗаявки.ИмяОтправителя = ВК.ИмяОтправителя;   
    спрЗаявки.ТемаЗаявки =ВК.Тема;
    спрЗаявки.Заявка = СокрЛП(ВК.Тело);
    спрЗаявки.Дата = ВК.ДатаОтправки;
    спрЗаявки.Записать();			
    КонецЦикла;     
    КонецЕсли;  
    КонецПроцедуры
    
    
    
    Процедура ПриНачалеРаботыСистемы() 
    ЗакачкаПисем()	
    КонецПроцедуры // ПриНачалеРаботыСистемы()
    
    ОбработкаОжидания("ЗакачкаПисем",1);
    
    
Похожие темы
  1. Vlados18
    Ответов:
    7
    Просмотров:
    2.505
  2. Vlados
    Ответов:
    1
    Просмотров:
    922
  3. OXED
    Ответов:
    3
    Просмотров:
    516
Загрузка...

Поделиться этой страницей