8.х Загрузка накладной из Exsel в УТ

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем PavelBaryshev, 28 ноя 2008.

  1. TopicStarter Overlay
    PavelBaryshev
    Offline

    PavelBaryshev Опытный в 1С

    Регистрация:
    9 сен 2008
    Сообщения:
    316
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, скажите есть ли такая обработка для загрузки накладных из exsel в Управление торговлей (Базовая)? Спасибо
  2. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    Смотрю взлся основательно за заполнение базы)))
    Есть пример загрузки из Excel на диски ИТС.. если нет Диска то могу прислать..., вообще штатных методов нет.. т.к. структура читаемого файла может быть какая угодно и содержать что угодно..... а вообще сейчас найду ...
    кстати на этом диске есть и конвертация)
    .... нет на работе осталось... могу только в понедельник...

    нашел код)))
    Код:
    	// Проверим файл на его наличие
    ФайлНаДиске = Новый Файл(ПутьКБД+"\"+ "DATA.XLS");
    Если не ФайлНаДиске Тогда
    Сообщить("Файл не существует");
    Возврат;
    КонецЕсли; 
    ExcelПриложение = Новый COMОбъект("Excel.Application");
    ИмяФайла = "DATA.XLS";
    ExcelФайл = ExcelПриложение.WorkBooks.Open(ПутьКБД+"\"+ИмяФайла);
    // Записать
    Если Запись Тогда
    Состояние("Обработка файла Microsoft Excel...");
    ExcelЛист = ExcelФайл.Sheets(1);
    xlCellTypeLastCell = 11;
    ExcelПоследняяСтрока = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Row;
    ExcelПоследняяКолонка = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Column;
    Для Строка = 1 По ExcelПоследняяСтрока Цикл
    
    Для Колонка = 1 По ExcelПоследняяКолонка Цикл
    
    Состояние("Обработка файла Microsoft Excel : "
    + "строка " + Строка + " из " + ExcelПоследняяСтрока
    + ", колонка " + Колонка + " из " + ExcelПоследняяКолонка);
    ExcelЯчейка = ExcelЛист.Cells(Строка, Колонка);
    ЭлементыФормы.Таблица.Область(Строка, Колонка, Строка, Колонка).Текст = ExcelЯчейка.Value;
    
    КонецЦикла;
    
    КонецЦикла;
    
    
    
    Иначе
    
    
    
    // Считать
    Попытка
    Состояние("Обработка файла Microsoft Excel...");
    ExcelЛист = ExcelФайл.Sheets(1);
    xlCellTypeLastCell = 11;
    ExcelПоследняяСтрока = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Row;
    ExcelПоследняяКолонка = ExcelЛист.Cells.SpecialCells(xlCellTypeLastCell).Column;
    
    ЭлементыФормы.Таблица.Очистить();
    Для Строка = 1 По ExcelПоследняяСтрока Цикл
    
    Для Колонка = 1 По ExcelПоследняяКолонка Цикл
    
    Состояние("Обработка файла Microsoft Excel : "
    + "строка " + Строка + " из " + ExcelПоследняяСтрока
    + ", колонка " + Колонка + " из " + ExcelПоследняяКолонка);
    ExcelЯчейка = ExcelЛист.Cells(Строка, Колонка);
    ЭлементыФормы.Таблица.Область(Строка, Колонка, Строка, Колонка).Текст = ExcelЯчейка.Value;
    
    КонецЦикла;
    
    КонецЦикла;
    
    Исключение
    
    Сообщить("Ошибка при открытии/чтении файла " + ИмяФайла + "." + Символы.ПС + ОписаниеОшибки(), СтатусСообщения.Внимание);
    
    КонецПопытки;
    
    
    
    КонецЕсли; 
    
    ExcelПриложение.Quit();
    
    
    
    

Поделиться этой страницей