8.х загрузка контрагентов

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем mazza, 30 дек 2010.

  1. TopicStarter Overlay
    mazza
    Offline

    mazza Опытный в 1С

    Регистрация:
    4 фев 2009
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    Помогите с загрузкой Контрагентов из Accessa в 1С 8.1 Как загрузить другие реквизиты Юр. адрес, фактический адрес, телефон?Если можно пример. Конфигурация БП 1.6.25.9
    Код:
    Процедура КнопкаВыполнитьНажатие(Кнопка) //ЗАГРУЗКА 
    Если ЭлементыФормы.ПутьКФайлу.Значение = ""  Тогда        
    Предупреждение("Не выбрана база данных");       
    Возврат;       
    КонецЕсли;         
    MBD = Новый COMОбъект("ADODB.CONNECTION");       
    Попытка       
    MBD.Open("Driver={Microsoft Access Driver (*.mdb)};Dbq="+ЭлементыФормы.ПутьКФайлу.Значение+";Uid=Admin;Pwd=");   
    Исключение        Сообщить(ОписаниеОшибки());       
    Возврат;   
    КонецПопытки;       
    ТекстСелект = "SELECT * FROM Запрос4";   
    НаборЗаписей = Новый COMОбъект("ADODB.RecordSet");      
    Попытка       
    НаборЗаписей=MBD.Execute(ТекстСелект);   
    Исключение        Сообщить(ОписаниеОшибки());   
    КонецПопытки;       
    Попытка        НаборЗаписей.MoveFirst();  
    Исключение //табилца пустая     
    Сообщить(ОписаниеОшибки());      
    НаборЗаписей.Close();        
    Возврат;  
    КонецПопытки;      
    Пока НаборЗаписей.EOF()=0 Цикл      
    КодКлиента = Строка(НаборЗаписей.Fields("КодКлиента").Value);      
    ИННКлиента = Строка(НаборЗаписей.Fields("ИННКлиента").Value);       
    КППКлиента = Строка(НаборЗаписей.Fields("КППКлиента").Value);       
    Название = Строка(НаборЗаписей.Fields("Название").Value);
    ПолноеНазвание = Строка(НаборЗаписей.Fields("ПолноеНазвание").Value);
    Форма = Строка(НаборЗаписей.Fields("Форма").Value);
    НаборЗаписей.MoveNext();   
    Код = КодКлиента;
    //Контрагент = Справочники.Контрагенты.ПустаяСсылка();
    Контрагент = Справочники.Контрагенты.ПустаяСсылка();
    
    КонтргаентСсылка = Справочники.Контрагенты.НайтиПоКоду(Код);
    
    Если КонтргаентСсылка.Пустая() Тогда
    // элемент не нашли - создаем его
    Контрагент = Справочники.Контрагенты.СоздатьЭлемент();
    Иначе
    // получим существующий
    Контрагент =  Справочники.Контрагенты.НайтиПоКоду(Код).ПолучитьОбъект();
    КонецЕсли;
    // заполнение реквизитов
    
    Контрагент.Наименование = Название+" "+Форма;//+" "+"''"+Название+"''";
    Контрагент.Код = КодКлиента;
    Контрагент.КПП = КППКлиента;
    Контрагент.ИНН = ИННКлиента;
    Контрагент.НаименованиеПолное = ПолноеНазвание;
    
    
    Контрагент.Записать();		  
    
    КонецЦикла;
    Сообщить("ЗАГРУЗКА КОНТРАГЕНТОВ ЗАВЕРШЕНА");
    
    КонецПроцедуры
    
    
  2. x_under
    Offline

    x_under Модераторы Команда форума Модератор

    Регистрация:
    25 апр 2007
    Сообщения:
    2.576
    Симпатии:
    13
    Баллы:
    29
    Ну так а в чем проблема? Контактная информация хранится в регистре сведений. Создавайте в нем записи и пишите туда данные из access. Единственно, вы скорее всего не сможете адреса структурировать и придется одной строкой вносить.

Поделиться этой страницей