8.х загрузка из Excel в 1С

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем reno, 29 дек 2007.

  1. TopicStarter Overlay
    reno
    Offline

    reno

    Регистрация:
    29 дек 2007
    Сообщения:
    13
    Симпатии:
    0
    Баллы:
    1
    Привет, не подскажите как реализовать задуманное?
    Делаю загрузку из Экселя в 1с счет-фактуры.
    считал наименование номенклатуры, теперь нужно проверить есть ли такая в базе и если нет, то предложить ее ввести.
    написал цикл:

    Код:
    Для Каждого эл Из МассивТоварБаза Цикл 
    Если эл = Строка.Номенклатура Тогда
    Сообщить(Строка(Строка.Номенклатура)
    КонецЕсли;
    КонецЦикла;
    

    Строка.Номенклатура - строка таблицы значений в которую выгружены данные из файла.
    как правильно этот цикл написать?

    Используйте тэг
    Код:
    [/color]
  2. fedor40
    Offline

    fedor40 Опытный в 1С

    Регистрация:
    15 дек 2007
    Сообщения:
    117
    Симпатии:
    0
    Баллы:
    26
    Код:
    КодСпр = ЛистExcel.Cells(СтрокаExcel,1).Value;
    Если НЕ ЗначениеЗаполнено(КодСпр) Тогда
    Продолжить; //если это группа или для элемента не указан код
    КонецЕсли;
    
    Товар = Справочники.Номенклатура.НайтиПоКоду(КодСпр);
    Если Товар = Справочники.Номенклатура.ПустаяСсылка() Тогда
    Сообщить("Строка НЕ ЗАГРУЖЕНА. Код Номенклатуры "+КодСпр+" не    найден в справочнике. Строка Excel "+СтрокаExcel);
    Продолжить;
    КонецЕсли;
    

    Используйте тэг
    Код:
    [/color]

    Вложения:

Похожие темы
  1. Snickbw
    Ответов:
    2
    Просмотров:
    806
  2. Ivan2014
    Ответов:
    12
    Просмотров:
    1.930
Загрузка...

Поделиться этой страницей