8.х Загрузка из эксель с иереархией

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Мариночка, 10 дек 2015.

  1. TopicStarter Overlay
    Мариночка
    Offline

    Мариночка

    Регистрация:
    24 фев 2014
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Прошу помощи. Загружаю данные из эксель. В экселе все иерархично:
    Подразделение
    Мол
    Группа1
    Группа2
    Номенклатура1
    Номенклатура2
    Группа3
    Номенклатура3
    мне нужно вытащить материально-ответственное лицо и номенклатуру на нем вот так:

    Мол | Номенклатура |

    Мол смогла вытащить, о номенклатуру не могу никак.... то выводит все подряд - и все группы и остальные МОЛ, то ничего.
    Код:
    WorkSheet = Excel.WorkSheets (1);
    Count = WorkSheet.UsedRange.Rows.Count;
    i=8;
    Пока i <> Неопределено Цикл
    //Для i=0  По Count Цикл
    ОбработкаПрерыванияПользователя();
    ЭтоГруппа = ложь;
    //УровеньТекущейСтроки = WorkSheet.Rows(i).OutlineLevel;
    
    Если Excel.Worksheets(1).Rows(i).OutlineLevel=3 Тогда
    ЭтоГруппа=Истина;
    //ТекРодитель=Справочники.Номенклатура.НайтиПоКоду(Excel.Cells(Сч,1).Value);
    Строка = Таблица.Добавить();
    Строка.МатериальноОтветственноеЛицо = СокрЛП(ExcelЛист.Cells(i, 1).Value);
    МОЛ=Строка.МатериальноОтветственноеЛицо;
    //Для каждого МОЛ из Count цикл
    n=20;
    //Пока МОЛ <> Неопределено Цикл
    
    Если Excel.Worksheets(1).Rows(i).OutlineLevel="" Тогда
       
    Строка = Таблица.Добавить();
    Строка.Номенклатура = СокрЛП(ExcelЛист.Cells(n, 1).Value);
    Строка.ИнвентарныйНомер = СокрЛП(ExcelЛист.Cells(n, 3).Value);
        //Строка.МатериальноОтветственноеЛицо = СокрЛП(ExcelЛист.Cells(ТекущаяСтрока, Объект.МОЛ).Value);
    Строка.ДатаПринятияКУчету = СокрЛП(ExcelЛист.Cells(n, 5).Value);
    Строка.НачальнаяСтоимость = СокрЛП(ExcelЛист.Cells(n, 4).Value);
    Строка.КонечнаяСтоимость = СокрЛП(ExcelЛист.Cells(n, 14).Value);
    n=n+1;
    КонецЕсли;
    //КонецЦикла;
    КонецЕсли;
    i=i+1;
    КонецЦикла; 

    Вложения:

Поделиться этой страницей