8.х ОБМЕН Загрузка из DBF

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем newman379, 14 авг 2011.

  1. TopicStarter Overlay
    newman379
    Offline

    newman379

    Регистрация:
    9 мар 2010
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Ребята помогите. Загружаю данные из файла dbf в 1с. Грузиться нормально, но только с 3 строки, а нужно со второй. В чем причина?
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    код показывайте
  3. TopicStarter Overlay
    newman379
    Offline

    newman379

    Регистрация:
    9 мар 2010
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Если ПутьКФайлу = "" Тогда
    Сообщить("Не указан файл");
    Возврат;
    КонецЕсли;

    ТЧ.Очистить();
    БД = Новый XBase;
    БД.ОткрытьФайл(ПутьКФайлу);

    Если БД.Открыта()=0 Тогда
    БД.Первая();

    //предупреждение
    Предупреждение("Закройте пожалуйста файл DBF",10,"Внимание");
    Возврат;
    КонецЕсли;

    Счетчик = 0;
    Для й = 1 По БД.КоличествоЗаписей() Цикл

    Пока Истина Цикл

    Если Не БД.Следующая() Тогда
    Прервать;

    КонецЕсли;
    Строчка = ТЧ.Добавить();
    ....
    ....
    ....
    КонецЦикла;
    //счётчик
    Счетчик=Счетчик+1;

    КонецЦикла;
    БД.ЗакрытьФайл();
    Предупреждение("Импортировано строк: "+Счетчик);
    КонецПроцедуры
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.549
    Симпатии:
    716
    Баллы:
    204
    Уберите.

    зачем так много вложенных циклов? хватит и

    Пока НЕ БД.ВКонце() Цикл

    КонецЦикла;
  5. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    У меня вот так реализован обход в файле:
    Код:
    Таб = Новый XBase;
    Таб.ОткрытьФайл(ПутьКФайлу);
    Таб.Первая();
    Пока НЕ Таб.ВКонце() Цикл
    ..........................
    Таб.Следующая();
    КонецЦикла;
    
  6. TopicStarter Overlay
    newman379
    Offline

    newman379

    Регистрация:
    9 мар 2010
    Сообщения:
    11
    Симпатии:
    0
    Баллы:
    1
    Спасибо за помощь

Поделиться этой страницей