8.х Загрузка документов в Торговлю 10.3

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Snegur, 3 авг 2016.

  1. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    121
    Симпатии:
    0
    Баллы:
    26
    Добрый день
    Добрый день
    делаю загрузку через дбв из бух3 в торговлю 10.3
    пытаюсь загрузить ПлатежноеПоручениеВходящее выдает ошибку индекс находится за пределами массива и не совпадают сумма документа и ее расшифровка. при загрузке
    Получается документ можно создать с табличкой (расшифровкой) либо общая просто сумма я так понимаю по умолчанию он создает с расшифровкой как сделать без ? не могу понять, что за реквизит это
    думал в документе найду ответ ,а там просто объект данные список и все ,как изменить на без расшифровки не понятно
    Код:
    Процедура ЗагрузкаПоручениеВХ()
        Поручение = Новый XBase;
        Поручение.ОткрытьФайл(ПапкаОбмена + "PoSchet.dbf",,1);
        прНомер = "";
        Док = "" ;
        Пока не Поручение.ВКонце() Цикл
            Если прНомер <> СокрЛП(Поручение.NOMER) тогда          
                Док = документы.ПлатежноеПоручениеВходящее.СоздатьДокумент();
            КонецЕсли;
            Док.ВалютаДокумента = справочники.Валюты.НайтиПоКоду("643");
            ВидОперации = СокрЛП(Поручение.VID) ;
            Если ВидОперации =  "Оплата от покупателя"  тогда
                Док.ВидОперации = перечисления.ВидыОперацийПоступлениеБезналичныхДенежныхСредств.ОплатаПокупателя
            Иначе
                Док.ВидОперации = перечисления.ВидыОперацийПоступлениеБезналичныхДенежныхСредств.ПрочиеРасчетыСКонтрагентами
            КонецЕсли;
            Док.Дата = СокрЛП(Поручение.DATA) ;
            Док.Номер = СокрЛП(Поручение.NOMER) ;
            Док.ДатаВходящегоДокумента = СокрЛП(Поручение.VHDATA) ;
            Док.НомерВходящегоДокумента = СокрЛП(Поручение.VHNOMER) ;
            Док.Организация = справочники.Организации.НайтиПоКоду(СокрЛП(Поручение.ORG));
            Док.ДоговорКонтрагента = справочники.ДоговорыКонтрагентов.НайтиПоКоду(СокрЛП(Поручение.DOGOVOR));
            Док.Контрагент  = справочники.Контрагенты.НайтиПоКоду(СокрЛП(Поручение.KONTR));
            Док.СтатьяДвиженияДенежныхСредств = справочники.СтатьиДвиженияДенежныхСредств.НайтиПоКоду(СокрЛП(Поручение.DDS));
            Док.СуммаДокумента  = Поручение.SUMMA;
            Док.СчетКонтрагента  = справочники.БанковскиеСчета.НайтиПоКоду(СокрЛП(Поручение.CHETKONTR));
            Док.СчетОрганизации = справочники.БанковскиеСчета.НайтиПоКоду(СокрЛП(Поручение.CHETORG));
            Док.НазначениеПлатежа = СокрЛП(Поручение.NAZ);
            Док.ОтражатьВБухгалтерскомУчете = Истина ;
            Док.ОтражатьВНалоговомУчете = Истина ;
            Док.ОтраженоВОперУчете = Истина ;
            Док.КурсДокумента = 1 ;
            Док.Комментарий = "загрузка" ;
        //  Док.
            прНомер = СокрЛП(Поручение.NOMER) ;
            Попытка                
                Док.Записать();
                Док.Записать(РежимЗаписиДокумента.Проведение);
            Исключение
                //Сообщить(ОписаниеОшибки(),СтатусСообщения.Важное);   
            КонецПопытки;
            Поручение.Следующая();
        КонецЦикла 
    КонецПроцедуры
    [​IMG] [​IMG] [​IMG]
  2. TopicStarter Overlay
    Snegur
    Offline

    Snegur Опытный в 1С

    Регистрация:
    20 июн 2016
    Сообщения:
    121
    Симпатии:
    0
    Баллы:
    26
    Док.ПолучитьФорму("ФормаДокумента",,);
    Док.ПолучитьФорму("ФормаДокумента",,).Список = ложь ;
    через получить форму сделал ,но там и так ложь стоит , блин уже нету вариантов (((

Поделиться этой страницей