8.х Загрузка данных из EXCEL колонки и строки

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем julia_nik, 25 мар 2014.

  1. TopicStarter Overlay
    julia_nik
    Offline

    julia_nik

    Регистрация:
    29 окт 2013
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    Добрый день! Нужна помощь при загрузке данных из эксель необходимо получать данные как по строкам, так и по колонкам. Может у кого есть пример..... Во вложении файл эксель с которого делаю загрузку. Данные в ТЗ уже выгрузила, а вот как цикл правильно запустить не соображу. Заранее спасибо.

    Вложения:

  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    не поняла, если вы в тз уже выгрузили, то что вам еще надо? какой такой цикл
  3. Draco
    Offline

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.628
    Симпатии:
    946
    Баллы:
    204
    Задачу конкретнее поставьте
  4. TopicStarter Overlay
    julia_nik
    Offline

    julia_nik

    Регистрация:
    29 окт 2013
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    В эксель файле есть строки и колонки которые подлежат загрузку, сам эксель файл я вложила. Вот смотрите мне необходимо получить контрагента, который находится в строке экселе, а потом перейти к колонкам и запустить цикл по ним собрать товары и кол-во по данному контрагенту в строке. Выкладываю код на чем остановилась
    --- Объединение сообщений, 25 мар 2014 ---
    Excel = Новый COMОбъект("Excel.Application");
    Excel.WorkBooks.Open(ИмяФайла);
    Лист = Excel.WorkBooks(Excel.WorkBooks.Count).WorkSheets(ИмяЛиста);


    //обход по колонкам
    ВсегоСтрок = Лист.Cells.SpecialCells(11).Row; //-кол-во строк всего
    ВсегоКолонок = Лист.Cells.SpecialCells(11).Column; //-кол-во колонок всего

    ТЗ = Новый ТаблицаЗначений;

    Для Счетчик = 1 По ВсегоКолонок Цикл
    ТЗ.Колонки.Добавить("Колонка" + Счетчик);
    КонецЦикла;

    Для Счетчик = 1 По ВсегоСтрок Цикл
    НоваяСтрока = ТЗ.Добавить();
    КонецЦикла;

    MassItem = Новый Массив;
    MassMain = Новый Массив;
    MassIMEI = Новый Массив;

    Область = Лист.Range(Лист.Cells(1,1), Лист.Cells(ВсегоСтрок,ВсегоКолонок));
    Данные = Область.Value.Выгрузить();

    Для Счетчик = 0 По ВсегоСтрок-1 Цикл
    Попытка
    ТЗ.ЗагрузитьКолонку(Данные[Счетчик],Счетчик);
    Исключение
    Прервать;
    КонецПопытки;
    КонецЦикла;
  5. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    Код:
    Excel = Новый COMОбъект("Excel.Application");
    Excel.WorkBooks.Open(ИмяФайла);
    Лист = Excel.WorkBooks(Excel.WorkBooks.Count).WorkSheets(ИмяЛиста);
    
    
    //обход по колонкам
    ВсегоСтрок = Лист.Cells.SpecialCells(11).Row; //-кол-во строк всего
    ВсегоКолонок = Лист.Cells.SpecialCells(11).Column; //-кол-во колонок всего
    
    ТЗ = Новый ТаблицаЗначений;
    
    Для Счетчик = 1 По ВсегоКолонок Цикл
    ТЗ.Колонки.Добавить("Колонка" + Счетчик);
    КонецЦикла;
    
    Для Счетчик = 1 По ВсегоСтрок Цикл
    нс = тз.Добавить();
    //тут заполняете эту строку данными из екселя по типу
    Для сч = 1 по ВсегоКолонок Цикл
    нс["Колонка"+Строка(сч)] = Лист.Cells(Счетчик, сч);
    Конеццикла;
    Конеццикла;
    --- Объединение сообщений, 25 мар 2014 ---
    ну это так на коленке набросано....

    З.Ы. оформляйте код тегом!!!!
  6. TopicStarter Overlay
    julia_nik
    Offline

    julia_nik

    Регистрация:
    29 окт 2013
    Сообщения:
    30
    Симпатии:
    0
    Баллы:
    1
    Извините :) Сейчас попробую. Спасибо

Поделиться этой страницей