[РЕШЕНО] Загрузка данных из документа в справочник

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ls600, 10 окт 2014.

  1. TopicStarter Overlay
    ls600
    Offline

    ls600 Опытный в 1С

    Регистрация:
    14 май 2012
    Сообщения:
    132
    Симпатии:
    0
    Баллы:
    26
    Доброго времени суток. Возможно ли реализовать такую задачу.
    Сразу скажу база не типовая, склад. обычное приложение.
    Сделал документ Анализ движения заявок на закупку. У этого документа есть реквизит Номер Заявки (Тип Строка). Получается создается документ Анализ движения заявок. Заполняется данными. Далее в справочнике Номенклатура добавил реквизит СсылкаНаЗаявку(рис). т.е при выборе выбирается нужный документ и автоматически заполняется в справочнике номер заявки, который указывался в документе.
    Проблема вот в чем при повторном открытии Номенклатуры поле со ссылкой на документ пустое.(рис2)
    Подскажите что добавить что бы ссылка на документ оставалась после записи.

    Код:
    Функция СформироватьНомерЗаявки()
        Запрос = Новый запрос;
        Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
                       |    АнализДвиженияЗаявок.НомерЗаявки
                       |ИЗ
                       |    РегистрНакопления.АнализДвиженияЗаявок КАК АнализДвиженияЗаявок
                       |ГДЕ
                       |    АнализДвиженияЗаявок.Регистратор.Ссылка = &Ссылка";
        запрос.УстановитьПараметр("Ссылка",ЭлементыФормы.СсылкаНаЗаявку.Значение);
        Результат = Запрос.Выполнить().Выбрать();
        Если Результат.Следующий() Тогда
            Возврат Результат.НомерЗаявки;
        Иначе
            Возврат 0;
        КонецЕсли;
               
    КонецФункции
    
    Процедура СсылкаНаЗаявкуПриИзменении(Элемент)
        Номер = СформироватьНомерЗаявки();
        ЭлементыФормы.НомерЗаявки.Значение = Номер;
    КонецПроцедуры
    

    Вложения:

    • рис.JPG
      рис.JPG
      Размер файла:
      187,6 КБ
      Просмотров:
      8
    • рис 2.JPG
      рис 2.JPG
      Размер файла:
      48 КБ
      Просмотров:
      8
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.782
    Симпатии:
    509
    Баллы:
    204
    Сделайте реквизит объекта, а не формы.
    ls600 нравится это.
  3. TopicStarter Overlay
    ls600
    Offline

    ls600 Опытный в 1С

    Регистрация:
    14 май 2012
    Сообщения:
    132
    Симпатии:
    0
    Баллы:
    26
    Благодарю!!!!

Поделиться этой страницей