Курилка загрузит занные из txt

Тема в разделе "Курилка", создана пользователем MAXWAIT, 17 янв 2009.

  1. TopicStarter Overlay
    MAXWAIT
    Offline

    MAXWAIT

    Регистрация:
    17 янв 2009
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Пишу диплом на 1С v8 и вот хочу из файла text.txt загрузить данные в справочник. в Справочнике только имеются колонки Код и Наименование Дисциплины
    Структура данный в файле (text.txt) такова:
    1
    английский
    2
    немецкий
    .... и т.д.

    Помогите !!!!
  2. sergey
    Offline

    sergey Курильщик

    Регистрация:
    13 апр 2006
    Сообщения:
    365
    Симпатии:
    0
    Баллы:
    26
    Навскидку:
    Код:
    Процедура ЗагрузкаДанных()
    Текст = Новый ТекстовыйДокумент;
    Текст.Прочитать("C:\text.txt");
    н=1;
    Пока н <= Текст.КоличествоСтрок() Цикл
    Дисц = Справочники.Дисциплины.СоздатьЭлемент();
    Дисц.Код = Текст.ПолучитьСтроку(н);
    н=н+1;
    Дисц.Наименование = Текст.ПолучитьСтроку(н);
    н=н+1;
    Если Справочники.Дисциплины.НайтиПоКоду(Дисц.Код).Пустая() Тогда
    Дисц.Записать();
    Сообщить("Создан элемент "+СокрЛП(Дисц)+" справочника Дисциплины.");
    Иначе
    Сообщить("Элемент с кодом"+СокрЛП(Дисц.Код)+" уже существует");
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    
    
Похожие темы
  1. BOJI4APA
    Ответов:
    20
    Просмотров:
    988
Загрузка...

Поделиться этой страницей