7.7 Задваивается вид расчета в расчетке..Помогите..

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем bushka86, 10 авг 2011.

  1. TopicStarter Overlay
    bushka86
    Offline

    bushka86 Опытный в 1С

    Регистрация:
    10 авг 2011
    Сообщения:
    72
    Симпатии:
    0
    Баллы:
    26
    В расчетном листке задваивается вид расчета, вводимый документом "Приказ о работе в праздничные и выходные дни" в Зарплате и Кадрах. где поискать причину, ошибку? В самом документе? или начислении? или вообще в расчете з/п?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Какой тип оплаты у сотрудника?
    В приказе как поставили - отработан весь день или отработано часов?
  3. TopicStarter Overlay
    bushka86
    Offline

    bushka86 Опытный в 1С

    Регистрация:
    10 авг 2011
    Сообщения:
    72
    Симпатии:
    0
    Баллы:
    26
    Отработана часов..

    Задваивается в 2 разных видах: оплата ппраздничных и выходных дней и доплата за праздничные..
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Извините - немного не так выразился. Я имел ввиду СИСТЕМА оплату у сотрудников какая? Задваивается у всех или только частично?
  5. TopicStarter Overlay
    bushka86
    Offline

    bushka86 Опытный в 1С

    Регистрация:
    10 авг 2011
    Сообщения:
    72
    Симпатии:
    0
    Баллы:
    26
    Задваивается у всех, и почасовиков и окладников.. именно по этому документу..
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не удалось съэмулировать подобную ситуацию (если только документов несколько и сотрудники дублируются - тогда да).

    Могу глянуть удаленно. Если есть желание - стучите в аську
  7. TopicStarter Overlay
    bushka86
    Offline

    bushka86 Опытный в 1С

    Регистрация:
    10 авг 2011
    Сообщения:
    72
    Симпатии:
    0
    Баллы:
    26
    В процедуре проведения устанавливается 2 вида расчета:

    Процедура ОбработкаПроведения(ОбработчикСообщений)

    // если документ содержит ошибки или проведен в прошлом периоде, то не проводим
    Если Проверка(ОбработчикСообщений) = 0 Тогда
    СтатусВозврата(0); Возврат
    КонецЕсли;

    глСторнироватьДокумент(КорректируемыйДокумент, ТекущийДокумент());

    ЖурналРасчетовЗарплата = СоздатьОбъект("ЖурналРасчетов.Зарплата");
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    ЖурналРасчетовЗарплата.УстановитьРеквизит("НомерСтрокиДокумента", НомерСтроки);
    ЖурналРасчетовЗарплата.ВвестиРасчет(Сотрудник,ВидРасчета.ОплатаПраздничных,ДатаРаботы,ДатаРаботы);
    ЖурналРасчетовЗарплата.УстановитьРеквизит("НомерСтрокиДокумента", НомерСтроки);
    ЖурналРасчетовЗарплата.ВвестиРасчет(Сотрудник,ВидРасчета.ДоплатаЗаПраздничные,ДатаРаботы,ДатаРаботы);
    КонецЦикла;

    КонецПроцедуры // ОбработкаПроведения

    Может быть причина в настройке вытеснения данных видов расчета?
    сейчас настраивала, вроде ушел один из видов с расчетки...
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Хм.... Так их и должно быть ДВА. Идет же в ДВОЙНОМ размере
  9. TopicStarter Overlay
    bushka86
    Offline

    bushka86 Опытный в 1С

    Регистрация:
    10 авг 2011
    Сообщения:
    72
    Симпатии:
    0
    Баллы:
    26
    В прошлых месяцах 1 раз стоят... возможно, это связано с тем, что данные часы в табеле проставляются, и они 1-ый раз в оклад входят. в этом месяце их в табель не вносили..
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Совершенно верно. 1с видит что оплата в праздничный день есть поэтому ставит только ДОПЛАТУ. Когда же оплата отсутствует ставится как оплата так и доплата (должен же идти ДВОЙНОЙ размер)
  11. TopicStarter Overlay
    bushka86
    Offline

    bushka86 Опытный в 1С

    Регистрация:
    10 авг 2011
    Сообщения:
    72
    Симпатии:
    0
    Баллы:
    26

    Точно.. Ой, спасибки огромное за помощь.. :D Ковырялась бы до вечера :angry:

Поделиться этой страницей