Курилка Задачка. Десятый класс

Тема в разделе "Курилка", создана пользователем Бухгалтерский угодник, 14 ноя 2013.

  1. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    ;))))

    а у меня агат с дисководом был!

    я его рукой раскручивал, когда он диск не мог начать читать...
  2. kotlovD
    Offline

    kotlovD Опытный в 1С

    Регистрация:
    16 фев 2011
    Сообщения:
    718
    Симпатии:
    0
    Баллы:
    26
    Решение с циклом:
    Код:
    //на входе точка которую надо проверить
    Функция ПроверитьТочку(Точка)
    //любой член геометрической прогрессии может быть вычислен по формуле
    //bn=b1*q^(n-1)
    //в нашем случае b1 = 1, q = 2, bn = Точка
    Степень = 1;
    Пока Истина Цикл
    Если pow(2, Степень) = Точка Тогда
    Возврат Истина;
    ИначеЕсли pow(2, Степень) > Точка Тогда
    Возврат Ложь;
    КонецЕсли;
    
    Степень = Степень + 1; 
    КонецЦикла;
    Возврат Ложь;
    КонецФункции
  3. Vertex
    Offline

    Vertex Опытный в 1С

    Регистрация:
    14 июн 2011
    Сообщения:
    468
    Симпатии:
    4
    Баллы:
    29
    А как бы вы решили эту задачу чтобы выводился путь, а не просто значение? ?

Поделиться этой страницей