8.х Задача №1 (1С: Специалист по конфигурированию и внедрению бухгалтерской подсистемы в прикладных реше

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем mialord, 9 июл 2013.

Статус темы:
Закрыта.
  1. TopicStarter Overlay
    mialord
    Offline

    mialord Модераторы Команда форума Модератор

    Регистрация:
    31 июл 2009
    Сообщения:
    5.398
    Симпатии:
    40
    Баллы:
    54
    [topic='51755']Рубрикатор задач[/topic]
    В данной теме отвечать запрещено отписываться [topic='51757']по ссылке[/topic]
    Поскольку, по условию задачи, мы выпускаем полуфабрикаты силами сторонней организации, наша задача будет рассмотрена с позиции Заказчика.
    Основа методологии учета давальческого сырья подробно описан на ИТС http://its.1c.ru/db/hoosn#content:48:1
    По условию задачи нам необходимо обеспечить реализацию хозяйственных операций перечисленных в задаче, рассмотрим подробнее
    1. Закупка сырья - операция ни чем не отличается от обычной операции приобретения сырья для последующей переработки, просто закупаем материалы.
    http://its.1c.ru/db/hoosn#content:42:1
    2. Передача сырья в переработку сторонней организации.
    http://its.1c.ru/db/...t:48:3:BUH30_t1
    3. Получение полуфабрикатов
    http://its.1c.ru/db/...t:48:3:BUH30_t2
    4. Выпуск готовой продукции. Для примера необходимо отразить выпуск продукции из собственных материалов и полуфабрикатов полученных от переработчика.
    http://its.1c.ru/db/hoosn#content:81:3
    5. Продажа готовой продукции
    http://its.1c.ru/db/hoosn#content:83:3
    Все операции пока не выходят из пределов типовой конфигурации и для их реализации доработка программного обеспечения не нужна.

    Основные условия:
    Далее, по условию задачи нам необходимо осуществлять передачу давальческого сырья в переработку по договорам передачи в котором должно быть зафиксировано
    1. Передаваемое переработчику сырье
    2. Количество сырья
    3. Стоимость услуг по переработке сырья
    4. Полуфабрикат
    5. Количество полуфабриката
    6. Дата исполнения договора
    Из условия задачи: по одному договору может передаваться несколько видов сырья, но всегда получается только один вид полуфабриката. Данное замечание очень важно для нашей задачи, оно определяет структуру метаданных нашего договора. В нашем случае в договоре необходимо зарегистрировать различное сырье Материал1- 5 шт., Материал2- 3 шт и один вид полуфабриката Полуфабрикат1- 2 шт. Таким образом мы будем знать сколько по договору должно быть выпущено полуфабриката с учетом переданных материалов.
    Еще одно важное условие, по одному контрагенту может в переработке одновременно находиться сырья по разным договорам при этом стандартные отчеты должны показывать количество материалов и аналитику по договорам без внесения в них изменений.
    Добавить отчет по форме из книги.

    Рассуждаем:
    Первое что нужно сделать - разобраться как ведется учет давальческого производства в типовой конфигурации, все ссылки для этого я уже дал, просто попробуйте самостоятельно выпустить продукцию.
    Настроить учетную политику.
    В качестве договора на переработку сырья можно использовать типовой договор с контрагентом, однако по условию задачи необходимо добавить несколько реквизитов
    Посмотреть вложение 15360 Посмотреть вложение 15361
    Основным условием для нас в этой задаче, не вписывающимся в постановку задачи оказалось требование получать аналитику в разрезе договоров материалов переданных в переработку. Самый оптимальный вариант - добавить новый забалансовый счет в программу.
    Посмотреть вложение 15359
    Для проведения по забалансовому счету необходимо добавить обработчик проведения документа "Поступление из переработки" вызов собственной процедуры
    Код:
    // Задание №1 +
    СформироватьДвиженияПоПереработке();
    // Задание №1 -
    и описать обработчик
    Код:
    // Задание №1
    //
    Процедура СформироватьДвиженияПоПереработке()
    
    Для Каждого СтрТовары из ИспользованныеМатериалы Цикл
    
    Движение = Движения.Хозрасчетный.Добавить();
    
    Движение.Период = Дата;
    Движение.Организация = Организация;
    Движение.Содержание = "Списано переработчиком";
    Движение.СчетКт = ПланыСчетов.Хозрасчетный.СырьеВПереработке;
    БухгалтерскийУчет.УстановитьСубконто(Движение.СчетКт, Движение.СубконтоКт, "Контрагенты", Контрагент);
    БухгалтерскийУчет.УстановитьСубконто(Движение.СчетКт, Движение.СубконтоКт, "Договоры", ДоговорКонтрагента);
    БухгалтерскийУчет.УстановитьСубконто(Движение.СчетКт, Движение.СубконтоКт, "Номенклатура", СтрТовары.Номенклатура);
    Движение.КоличествоКт = СтрТовары.Количество;
    
    КонецЦикла;
    
    Для каждого СтрТовары из ВозвращенныеМатериалы Цикл
    
    Движение = Движения.Хозрасчетный.Добавить();
    
    Движение.Период = Дата;
    Движение.Организация = Организация;
    Движение.Содержание = "Возвращено переработчиком";
    Движение.СчетДт = ПланыСчетов.Хозрасчетный.СырьеВПереработке;
    БухгалтерскийУчет.УстановитьСубконто(Движение.СчетДт, Движение.СубконтоДт, "Контрагенты", Контрагент);
    БухгалтерскийУчет.УстановитьСубконто(Движение.СчетДт, Движение.СубконтоДт, "Договоры", ДоговорКонтрагента);
    БухгалтерскийУчет.УстановитьСубконто(Движение.СчетДт, Движение.СубконтоДт, "Номенклатура", СтрТовары.Номенклатура);
    Движение.КоличествоДт = -1 * СтрТовары.Количество;
    
    КонецЦикла;
    
    КонецПроцедуры
    Стоит учесть что материалы могут быть переданы документом "Передача товара", а значит и его проведение мы должны скорректировать
    Код:
    // Задание №1
    //
    Процедура СформироватьДвиженияПоПереработке()
    
    Для каждого СтрТовар из Товары Цикл
    Движение = Движения.Хозрасчетный.Добавить();
    Движение.Период = Дата;
    Движение.Организация = Организация;
    Движение.Содержание = "Переданы материалы в переработку";
    Движение.СчетДт = ПланыСчетов.Хозрасчетный.СырьеВПереработке;
    БухгалтерскийУчет.УстановитьСубконто(Движение.СчетДт, Движение.СубконтоДт,
    "Контрагенты", Контрагент);
    БухгалтерскийУчет.УстановитьСубконто(Движение.СчетДт, Движение.СубконтоДт,
    "Договоры", ДоговорКонтрагента);
    БухгалтерскийУчет.УстановитьСубконто(Движение.СчетДт, Движение.СубконтоДт,
    "Номенклатура", СтрТовар.Номенклатура);
    Движение.КоличествоДт = СтрТовар.Количество;
    КонецЦикла;
    
    КонецПроцедуры
    Стоит учесть что хоть в 3.0 и появилась возможность закрытия 20-го счета по разным номенклатурным группам, я бы рекомендовал для корректного расчета стоимости полуфабрикатов своё производство и производство переработчика разнести по разным номенклатурным группам.
    В моем случае в мае был выпущен полуфабрикат, но основное производство не работало, как мы видим из рисунка ниже, работы по переработке закрыты, а основное производство осталось в незавершенке
    Посмотреть вложение 15362
    В июне из майского полуфабриката и моего сырья
    Посмотреть вложение 15363
    начинается выпуск продукции
    Посмотреть вложение 15364
    и при закрытии месяца 20-ый счет закрывается
    Посмотреть вложение 15365
    А также стандартные отчеты показывают нужную мне информацию о переданном сырье
    Посмотреть вложение 15366
    Ну и конечно же отчет по задаче Вам нужно написать самостоятельно, я же выкладываю скрин своего отчета
    Посмотреть вложение 15367
    Все условия задачи выполнены!
    PS: Обратите внимание что в задаче не сказано ничего о контроле передачи сырья сверхнормы договора, посему не вижу смысла прописывать то чего в задаче нет.
    PS: Данное решение мое ИМХО, если есть варианты интереснее с удовольствием выслушаю аргументированный ответ, а так же вопросы по теме
    В данной теме отвечать запрещено отписываться [topic='51757']по ссылке[/topic]
    [topic='51755']Рубрикатор задач[/topic]

    Вложения:

    • 1.png
      1.png
      Размер файла:
      19 КБ
      Просмотров:
      48
    • 2.png
      2.png
      Размер файла:
      10,4 КБ
      Просмотров:
      44
    • 3.png
      3.png
      Размер файла:
      15,8 КБ
      Просмотров:
      53
    • 11.png
      11.png
      Размер файла:
      33,2 КБ
      Просмотров:
      46
    • 12.png
      12.png
      Размер файла:
      21,8 КБ
      Просмотров:
      44
    • 13.png
      13.png
      Размер файла:
      24,8 КБ
      Просмотров:
      35
    • 14.png
      14.png
      Размер файла:
      26,8 КБ
      Просмотров:
      28
    • 15.png
      15.png
      Размер файла:
      25,5 КБ
      Просмотров:
      28
    • 16.png
      16.png
      Размер файла:
      15,3 КБ
      Просмотров:
      29
Статус темы:
Закрыта.

Поделиться этой страницей