7.7 Зачет оплаты

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем karabas123, 7 апр 2012.

  1. TopicStarter Overlay
    karabas123
    Offline

    karabas123

    Регистрация:
    2 фев 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Подскажите - никак не могу разобратся. Программа зачетает оплату по непонятному мне алгоритму.
    Как сделать так чтобы оплата зачеталась именно по документу основанию?
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Что имеется ввиду? Озвучте конфигурацию...
    Учимся грамотно задавать вопросы.
  3. TopicStarter Overlay
    karabas123
    Offline

    karabas123

    Регистрация:
    2 фев 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Прошу прощения. Конфигурация Торгвля и Склад 9.2. Просто пытаюсь написать отчет по закрытию долгов. Обращаюсь к регистрам и вижу что зачитается совсем не тот документ который выбран в основании платежа.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    А последовательность у вас восстановлена?
    Да. В типовом алгоритме ТиС предусмотрено именно закрытие 1го документа по которому есть долг.
    Если нужно зачетать долги по документу основанию придется править конфу
  5. TopicStarter Overlay
    karabas123
    Offline

    karabas123

    Регистрация:
    2 фев 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Прошу прощения, а причем здесь последовательность?
  6. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Последовательность необходима для правильного распределения оплат в хронологическом порядке + ситуация когда у вас есть авансы...
  7. TopicStarter Overlay
    karabas123
    Offline

    karabas123

    Регистрация:
    2 фев 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Понятно. Так как все-таки сделать чтобы зачетались долги по документу выбранному в основании?
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Смотри процедуру ГМ глДвижениеДолгов
  9. TopicStarter Overlay
    karabas123
    Offline

    karabas123

    Регистрация:
    2 фев 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Есть такая... А не подскажите что в ней поправить?
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    В процедуре после установки всех фильтров есть расчет итогов с последующей выгрузкой из в ТаблицуЗначений

    Код:
     
    ВремВзаим.ВыгрузитьИтоги(ТаблИтогов,1,1);
    ТаблИтогов.Сортировать("+КредДокумент",1); // погашаем долги по ФИФО 
    //Вот она... наша причина засора... Гаят по ФИФО, а мы это поправим...
    
    Если  глЕстьРеквизитШапки("ДокОснование", Конт.Вид()) <> 0
    Тогда //проверяем есть ли реквизит "ДокОснование"
    Если  Конт.ДокОснование.Выбран() <> 0
    Тогда //проверяем указано ли основание
    поз = 0;
    Если  ТаблИтогов.НайтиЗначение(Конт.ДокОснование,поз,"КредДокумент") > 0
    Тогда //по документу-основанию есть непогашенный долг
    Если  поз > 1
    Тогда //основание где-то в глубине, стоит в общей очереди
    ТаблИтогов.СдвинутьСтроку(1-поз,поз);
    КонецЕсли; //сдвиг основания вверх
    КонецЕсли;
    КонецЕсли; //выбрано основание
    КонецЕсли; //по реквизиту шапки
    
    Я применяю данный код с дополнительной проверкой... Т.е. чтобы сумма документа оплаты не превышала суммы долга по документу иначе возникнут авансы.
  11. TopicStarter Overlay
    karabas123
    Offline

    karabas123

    Регистрация:
    2 фев 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Понял!!!! Все оказывается довольно просто.... ОГРОМНОЕ спасибо!!!!!!!!!!!!
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Конечно просто... Когда решение обозначено)))))))))

    Не за что... Обращайтесь
  13. TopicStarter Overlay
    karabas123
    Offline

    karabas123

    Регистрация:
    2 фев 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Еще раз спасибо... Т.е. как я понимаю после внесенных изменений мне нужно перепровести все документы?
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Совершенно верно.
    Только тогда ваш отчет (я так понимаю - "дебеторка" по долгам) покажет реальную картину
  15. TopicStarter Overlay
    karabas123
    Offline

    karabas123

    Регистрация:
    2 фев 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    Да. Вы правы. Нужен отчет по долгам, а зачетаются не те документы которые должны.... Т.е. есть документы с отсрочкой платежа, а зачетается все подряд.
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    там (в регистре) есть измерение КредДокумент... Это как раз ваша реализация. В шапке документа есть реквизит ДатаОплаты.... Дальше продолжать?
  17. TopicStarter Overlay
    karabas123
    Offline

    karabas123

    Регистрация:
    2 фев 2012
    Сообщения:
    29
    Симпатии:
    0
    Баллы:
    1
    УРАААААААА!!!! Я все понял!!! Добавляем новый реквизит в таблицу значений и по нему сортируем...
    Бухгалтерский угодник - спасибо вам огромное... Сам бы не допер
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ))))
    Не за что... Обращайтесь

Поделиться этой страницей