7.7 XML-файл - помогите, пожалуйста

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Samouchka, 13 сен 2014.

  1. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Всех приветствую! С xml работаю в 1с недавно. Поэтому сразу возник вопрос. Нужно прийти к следующему xml-файлу:
    Код:
    <?xml version="1.0" encoding="Windows-1251"?>
    <ФайлПФР>
      <ИмяФайла>PFR-700-Y-2014-ORG-036-019-000423-DCK-00024-DPT-000000-DCK-00000.XML</ИмяФайла>
    </ФайлПФР>
    Пишу для этого код:
    Код:
    Процедура ВыгрузитьПФР()
        ВыборКаталВыгруз=КаталогОтчетов;
        ВыбКаталВыгруз=ФС.ВыбратьКаталог(ВыборКаталВыгруз,"Выберите папку для выгрузки отчета",);
        Если ВыбКаталВыгруз=1 Тогда
            //Процесс создания, заполнения и записи XML-файла
            //Процесс создания, заполнения и записи XML-файла
            Если ЗагрузитьВнешнююКомпоненту(КаталогИБ()+"v7plus.dll") <> 1 Тогда
                   Предупреждение("Компонента v7plus.dll не найдена!");
                   Возврат; //прервать выполнение процедуры
            КонецЕсли;
            Анализатор = СоздатьОбъект("AddIn.XMLParser");
            xml=Анализатор.СоздатьДокумент();
            ФайлПФР=xml.СоздатьПодчиненныйЭлемент("ФайлПФР");
            ФайлПФР.УстановитьАтрибут("ИмяФайла","PFR-700-Y-2014-ORG-036-019-000423-DCK-00024-DPT-000000-DCK-00000.XML");
           
            Инфо=СоздатьОбъект("AddIn.V7SysInfo");
            ФайлИмя=Инфо.СоздатьGUID();
            ФайлХвост=".xml";
            ФайлВыгруза=ВыборКаталВыгруз+"\"+ФайлИмя+ФайлХвост;
            xml.Записать(ФайлВыгруза);
            xml.Проверить();
        КонецЕсли;
    КонецПроцедуры
    И получаю вот что:
    Код:
    <?xml version="1.0" encoding="windows-1251"?>
    <ФайлПФР ИмяФайла="PFR-700-Y-2014-ORG-036-019-000423-DCK-00024-DPT-000000-DCK-00000.XML"/>
    Сравнение. Во-первых, не закрываются теги ФайлПФР и ИмяФайла. Во-вторых, знак равенства после ИмяФайла не нужен. Хотя XML-схемы обоих файлов одинаковые. Помогите разобраться с моим неправильным кодом, пожалуйста.
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    xmlАнализатор = СоздатьОбъект("AddIn.XMLParser");
    xmlФайлВыгрузки = xmlАнализатор.СоздатьДокумент();
    xmlКорень = xmlФайлВыгрузки.СоздатьПодчиненныйЭлемент("ФайлПФР");

    xmlУзел0 = xmlФайлВыгрузки.СоздатьУзел("element", "ИмяФайла");
    xmlУзел0.Значение = "Тут нужное вам значение";
    xmlКорень.ДобавитьПодчиненный(xmlУзел0);
    xmlФайлВыгрузки.Записать("Имя файла");
    Samouchka нравится это.
  3. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    :)Премного благодарен! Сам бы я не разобрался.
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104

Поделиться этой страницей