7.7 Хелп, не могу вывести код товара в ценник из обработки "ПечатьЦенников"

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем merkuloff17, 26 сен 2019.

  1. TopicStarter Overlay
    merkuloff17
    Offline

    merkuloff17

    Регистрация:
    19 сен 2019
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    //******************************************************************************
    // ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)
    //
    // Параметры:
    // Таб - таблица, в которую выполняется вывод ценника
    // ПечНаименование - наименование товара
    // ПечЕдиница - единица измерения товара
    // ПечРозн - цена товара
    // Столбик - номер столбика.
    // Ряд - номер ряда
    //
    // Возвращаемое значение:
    // Нет.
    //
    // Описание:
    // Добавляет ценник в таблицу.
    //
    Процедура ДобавитьЦенник(Таб, ПечФирма, ПечНаименование, ПечЕдиница, ПечРозн, Столбик, Ряд)

    Столбик = ?(Столбик = 3, 0, Столбик + 1);
    Ряд = ?(Столбик = 0, Ряд + 1, Ряд);

    Если Ряд > 4 Тогда
    Таб.НоваяСтраница();
    Ряд = 1;
    КонецЕсли;

    Если Столбик = 0 Тогда
    Таб.ВывестиСекцию("Товар|Ценник");
    Иначе
    Таб.ПрисоединитьСекцию("Товар|Ценник");
    КонецЕсли;

    КонецПроцедуры // ДобавитьЦенник()

    //******************************************************************************
    // Сформировать(ТаблицаТоваров, ПечФирма)
    //
    // Параметры:
    // ТаблицаТоваров - таблица значений, содержащая информацию о цене товара
    // ПечФирма - наименование фирмы, которое будет выводиться вверху ценника
    //
    // Возвращаемое значение:
    // Нет.
    //
    // Описание:
    // Формирует таблицу с ценниками.
    //
    Процедура Сформировать(ТаблицаТоваров,ПечФирма)

    // Создание Таблицы для выходного отчета
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");

    Столбик = 3;
    Ряд = 0;

    ТаблицаТоваров.ВыбратьСтроки();
    Пока ТаблицаТоваров.ПолучитьСтроку() = 1 Цикл
    ПечРозн = глФРМ(ТаблицаТоваров.Цена, ТаблицаТоваров.Валюта);
    ПечНаименование = ТаблицаТоваров.Товар;
    ДобавитьЦенник(Таб, ПечФирма, ТаблицаТоваров.Товар, ТаблицаТоваров.Единица, ПечРозн, Столбик, Ряд);
    глОживить(1);
    КонецЦикла;

    //Вызов выходного отчета в окно просмотра и редактирования.
    Таб.Опции(0,0,0,0,"ПечатьЦенников","ПечатьЦенников");
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Товарные ценники","");

    КонецПроцедуры

    //******************************************************************************
    // Предопределенная процедура
    //
    Процедура ПриОткрытии()

    СтатусВозврата(0);
    ДанныеДляПечати = Форма.Параметр;

    Если ТипЗначенияСтр(ДанныеДляПечати) <> "СписокЗначений" Тогда
    Возврат;
    КонецЕсли;

    ПечФирма = ДанныеДляПечати.Получить("Фирма");
    ТаблицаТоваров = ДанныеДляПечати.Получить("Таблица");

    Сформировать(ТаблицаТоваров, ПечФирма);

    КонецПроцедуры // ПриОткрытии()