8.х ОБМЕН XDTO Поле объекта недоступно для записи

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем Oleg2510, 21 авг 2013.

  1. TopicStarter Overlay
    Oleg2510
    Offline

    Oleg2510

    Регистрация:
    21 авг 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Вот такой код

    Код:
    объектТип = ФабрикаXDTO.Тип("http://localhost:8090/TEST_Accor/", "Contacts");
    Объект = фабрикаXDTO.Создать(объектТип);
    
    Объект.FIO = "Блабла";  // В этом месте всегда один и тот же баг  - FIO Поле объекта недоступно для записи
    Возврат Объект;
    Импорт xml схемы XDTO пакета

    <xs:schema xmlns:tns="http://localhost:8090/TEST_Accor/" xmlns:xs="http://www.w3.org/2001/XMLSchema" targetNamespace="http://localhost:8090/TEST_Accor/" attributeFormDefault="unqualified" elementFormDefault="qualified">
    <xs:complexType name="Contacts">
    <xs:choice>
    <xs:element name="FIO" type="xs:string" nillable="true" minOccurs="0" maxOccurs="unbounded"/>
    <xs:element name="phone" type="xs:string" nillable="true" minOccurs="0" maxOccurs="unbounded"/>
    <xs:any namespace="##any" processContents="lax" minOccurs="0" maxOccurs="unbounded"/>
    </xs:choice>
    <xs:anyAttribute namespace="##any" processContents="lax"/>
    </xs:complexType>
    </xs:schema>


    а вот например код ниже прекрасно работает:

    Код:
    ТипСтрока=ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema","string")
    Артикул=ФабрикаXDTO.Создать(ТипСтрока,"000000");
    ПОМОГИТЕ плиз! можно даже за вознаграждение
  2. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Доброго всем,
    Читаем в синтаксис помощнике
    Вы уже созданному объекту хотите присвоить значение, поэтому он сопротивляется
  3. TopicStarter Overlay
    Oleg2510
    Offline

    Oleg2510

    Регистрация:
    21 авг 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    а как тогда нужно? Я ведь все пошагово делал, согласно инструкциям которые в сети нашел - я просто не 1С программер, я веб программист.
    В отладчике на точке останова в табло опредилил что,
    Объект.FIO
    FIO - тут это списокXDTO .. затем синтаксис помощник + джедайские усилия и витоге я все равно не понял как мне теперь запихнуть значение в FIO )))
  4. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    Какая цель ? Что нужно сделать ?
  5. TopicStarter Overlay
    Oleg2510
    Offline

    Oleg2510

    Регистрация:
    21 авг 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Уважаемый Юрий, если от меня нужна финасовая стимуляция я готов обсудить этот момент. Нужно объяснить мне как использовать XDTO пакет в веб сервисе

    Ниже код моего веб сервиса с первым методом GetParam() я отлично разобрался. А вот как мне теперь с XDTO работать - только пожалуйста не отправляйте меня покупать ИТС с демками или серфить инет в поисках статей про xdto и веб сервисы :) Я руководствовался вот этим примером и этим

    Код:
    Функция  GetParam(getSTR)
    Возврат "привет " + getSTR;
    КонецФункции
    Функция GetComplex()
    объектТип = ФабрикаXDTO.Тип("http://localhost:8090/TEST_Accor/", "Contacts");
    Объект = фабрикаXDTO.Создать(объектТип);
    Объект.FIO = "blabla";
    
    
    
    //ТипСтрока=ФабрикаXDTO.Тип("http://www.w3.org/2001/XMLSchema","string");
    //Артикул=ФабрикаXDTO.Создать(ТипСтрока,"000000");
    
    
    //Выборка = Справочники.СотрудникиОрганизаций.Выбрать();
    //Массив = Новый Массив;
    //Пока Выборка.Следующий()  Цикл
    // Массив.Добавить(Выборка.Наименование);
    //КонецЦикла;
    //Для каждого Элемент из Массив Цикл
    //Сообщить(Элемент);
    //КОнецЦикла
    Возврат Объект;
    КонецФункции
    Так же можно обсудить возможность удаленного подключения к моему компу через TeamViewer
  6. TopicStarter Overlay
    Oleg2510
    Offline

    Oleg2510

    Регистрация:
    21 авг 2013
    Сообщения:
    4
    Симпатии:
    0
    Баллы:
    1
    Чуваки с http://www.forum.mista.ru помогли оказывается нужно просто

    вот так сделать

    Код:
    Объект.FIO.Добавить("blabla");

Поделиться этой страницей