8.х WEB Web-клиент, ошибка в браузере

Тема в разделе ""1C:Web-Сервер"", создана пользователем GRUV, 27 авг 2010.

  1. TopicStarter Overlay
    GRUV
    Offline

    GRUV Опытный в 1С

    Регистрация:
    7 ноя 2007
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, подскажите в чем дело ...
    В IE не открывается элемент справочника Номенклатура если в нем установлено Фото. Пишет - Исключение брошено и не поймано. В других браузерах такой проблемы нет. IE версия 6.0. Выполнение скриптов разрешено, блокировка всплывающих окон снята, запросы и сценарии элементов ActiveX тоже разешены. В google ничего не нашел. На других компьютерах пробывал - такая же ошибка. Даже не знаю где еще искать ...
  2. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Какая у вас версия платформы?
  3. BabySG
    Offline

    BabySG Администраторы Команда форума Администратор

    Регистрация:
    10 июн 2007
    Сообщения:
    11.853
    Симпатии:
    12
    Баллы:
    29
    ИЕ 6.0 - вот где проблема. Пробуйте на 7 или 8...
  4. TopicStarter Overlay
    GRUV
    Offline

    GRUV Опытный в 1С

    Регистрация:
    7 ноя 2007
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26
    платформа 8.2.11.236
  5. TopicStarter Overlay
    GRUV
    Offline

    GRUV Опытный в 1С

    Регистрация:
    7 ноя 2007
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26
    да, скорее всего IE как-то криво исполняет скрипты, хотя разработчики говорят, что работает на IE версии 6 и выше. На опере и мозилле работает без проблем, но хотелось бы чтоб любой пользователь мог подключится к серверу (IE все еще достаточно распрастраненный браузер)
  6. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.409
    Симпатии:
    316
    Баллы:
    104
    Это да, но уже ведь пошла волна отказа от него.
    Да, платформа уже вышла 8.2.12.80 - может попробуете обновиться. Чего не бывает, вдруг поможет.
  7. TopicStarter Overlay
    GRUV
    Offline

    GRUV Опытный в 1С

    Регистрация:
    7 ноя 2007
    Сообщения:
    106
    Симпатии:
    0
    Баллы:
    26
    Решил проблему таким способом:

    заполнение картинки было на сервере

    Код:
    &НаСервере
    Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    
    АдресКартинки = ПолучитьНавигационнуюСсылку(ЭтотОбъект.ФайлКартинки,"Хранилище");
    
    КонецПроцедуры
    
    я заполнение перенес на клиент

    Код:
    &НаКлиенте
    Процедура УстановитьКартинку()
    АдресКартинки = ПолучитьАдрес();
    КонецПроцедуры
    
    Код:
    &НаСервере
    Процедура ПолучитьАдрес()
    Возврат ПолучитьНавигационнуюСсылку(ЭтотОбъект.ФайлКартинки,"Хранилище");
    КонецПроцедуры
    

Поделиться этой страницей