8.х вызвать один отчет из другого

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем juliab85, 31 мар 2011.

  1. TopicStarter Overlay
    juliab85
    Offline

    juliab85 Опытный в 1С

    Регистрация:
    18 фев 2011
    Сообщения:
    80
    Симпатии:
    0
    Баллы:
    26
    здравствуйте, подскажите пожалуйста, как сделать такую вещь. есть один отчет, сформированный с помощью построителя. и другой отчет - сделанный при помощи универсального. так вот мне надо при расшифровке ячейки первого отчета вызывать второй с необходимыми параметрами. открыть я его могу, но не понимаю, как передать параметры моего построителя в универсальный отчет и чем заполнить структуру, которую я передаю в качестве расшифровки ячейки.
  2. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Может подойдет?
    Пример открытия универсального отчета с предопределенными настройками:

    Код:
    ОтчетОбъект = Отчеты.Продажи.Создать();
    
    ФормаОтчета = ОтчетОбъект.ПолучитьФорму();
    Попытка
    ФормаОтчета.СпособОтображенияОкна = ВариантСпособаОтображенияОкна.Максимизированное;
    Исключение        
    КонецПопытки;
    ФормаОтчета.УниверсальныйОтчет.ВариантОформления = СтандартноеОформление.Интерфейс;
    
    ОтчетОбъект.УстановитьНачальныеНастройки();
    ОтчетОбъект.УниверсальныйОтчет.мВосстанавливатьНастройкиПриОткрытии = Ложь;
    
    ФормаОтчета.Открыть();    
    Отбор = ФормаОтчета.ЭтотОбъект.УниверсальныйОтчет.ПостроительОтчета.Отбор;
    Сч=0;
    Пока Сч<Отбор.Количество() Цикл
    Отбор[Сч].Использование=Ложь;
    Сч=Сч+1;
    КонецЦикла;
    
    //Включаем только нужные показатели    
    Для каждого СтрокаПоказателей из ФормаОтчета.УниверсальныйОтчет.Показатели.Строки Цикл
    Если  СтрокаПоказателей.Имя = "СтоимостьОборот" тогда
    СтрокаПоказателей.Использование = истина;
    Иначе
    СтрокаПоказателей.Использование = Ложь;
    КонецЕсли;    
    КонецЦикла;    
    //Выбираем период отчета    
    ФормаОтчета.УниверсальныйОтчет.ДатаНач = НачалоМесяца(ТекущаяДата());
    ФормаОтчета.УниверсальныйОтчет.ДатаКон = КонецМесяца(ТекущаяДата());
    //Еще настройки
    ФормаОтчета.УниверсальныйОтчет.ОтрицательноеКрасным    = Истина;
    ФормаОтчета.УниверсальныйОтчет.ВыводитьДетальныеЗаписи = Ложь;
    
    ПостроительОтчета = ФормаОтчета.УниверсальныйОтчет.ПостроительОтчета;
    ПостроительОтчета.ВыбранныеПоля.Очистить();
    ПостроительОтчета.Порядок.Очистить();
    //Добавим группировку колонок
    ПостроительОтчета.ИзмеренияКолонки.Очистить();
    ПостроительОтчета.ИзмеренияКолонки.Добавить("ПериодНеделя");
    //Добавим группировку строк
    ПостроительОтчета.ИзмеренияСтроки.Очистить();
    ПостроительОтчета.ИзмеренияСтроки.Добавить(ПостроительОтчета.ДоступныеПоля.Контрагент.ПутьКДанным,,ТипИзмеренияПостроителяОтчета.Элементы);
    ПостроительОтчета.ИзмеренияСтроки.Добавить(ПостроительОтчета.ДоступныеПоля.Номенклатура.ПутьКДанным,,ТипИзмеренияПостроителяОтчета.Элементы);
    
    //Добавим отбор по номенклатуре
    
    Если ПостроительОтчета.Отбор.Найти("Номенклатура") = Неопределено тогда
    ПостроительОтчета.Отбор.Добавить(ПостроительОтчета.ДоступныеПоля.номенклатура.ПутьКДанным);
    КонецЕсли;
    СписокНоменклатуры = Новый СписокЗначений;
    СписокНоменклатуры.Добавить(Справочники.Номенклатура.НайтиПоНаименованию("Товар"));
    СписокНоменклатуры.Добавить(Справочники.Номенклатура.НайтиПоНаименованию("Еще товар"));
    
    ПостроительОтчета.Отбор.Номенклатура.Использование = Истина;
    ПостроительОтчета.Отбор.Номенклатура.ВидСравнения  = ВидСравнения.ВСписке;
    ПостроительОтчета.Отбор.Номенклатура.Значение      = СписокНоменклатуры;
    
    //Формируем отчет                
    ФормаОтчета.ОбновитьОтчет();
    
    
    
  3. TopicStarter Overlay
    juliab85
    Offline

    juliab85 Опытный в 1С

    Регистрация:
    18 фев 2011
    Сообщения:
    80
    Симпатии:
    0
    Баллы:
    26
    Получается сделать через Построитель.НастроитьРасшифровку на основании Расшифровки условия необходимым образом настраиваются. но вот ести в моем отчете установлены какие-то группировки и я выбираю какую-то итоговую запись, то уже не понятно, что передавать в параметр расшифровки.

Поделиться этой страницей