8.х Вызов процедуры из Модуля Объекта в Форме Списка

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем ESP Forest GT, 18 июл 2010.

  1. TopicStarter Overlay
    ESP Forest GT
    Offline

    ESP Forest GT

    Регистрация:
    18 июл 2010
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Процедура Печать() Экспорт определена в Модуля Объекта. Ее надо вызвать в Форме Списка Справочника.
    Т.к. Форма списка не является объектом справочника, то она не видит модуль объекта. Читал, что надо получить объект, а потом вызывать. Но я не могу понять, что надо сделать конкретно.
    Объясните пожалуйста.
  2. TopicStarter Overlay
    ESP Forest GT
    Offline

    ESP Forest GT

    Регистрация:
    18 июл 2010
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Если определить процедуру Печать() Экспорт в Общем Глобальном Модуле, то она успешно вызывается и Формы Списка Справочника.
    Но как обойтись без Общего Модуля?
  3. shurikvz
    Offline

    shurikvz Модераторы Команда форума Модератор

    Регистрация:
    1 окт 2009
    Сообщения:
    8.410
    Симпатии:
    316
    Баллы:
    104
    Что-то вроде:
    Код:
    Процедура ДействияФормыДействиеПечать(Кнопка)
    
    Если ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока = Неопределено тогда
    Возврат;
    КонецЕсли;
    
    Объект = ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока.ПолучитьОбъект();
    Если Объект = Неопределено Тогда
    Возврат;
    КонецЕсли;
    
    Объект.Печать(<здесь параметры>);
    
    КонецПроцедуры 
    
    
    
    либо если у вас типовая, посмотрите как там сделано:
    Код:
    //  Процедура печатает выбранный документ 
    // Печатается та форма, которая была отпечатана при нажатии в документе кнопки
    // печати по умолчанию
    //
    Процедура ДействияФормыДействиеПечать(Кнопка)
    
    Если ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока = Неопределено тогда
    Возврат
    КонецЕсли;
    
    УниверсальныеМеханизмы.НапечататьДокументИзФормыСписка(ЭтаФорма.ЭлементыФормы.Список.ТекущаяСтрока.ПолучитьОбъект());
    
    КонецПроцедуры // ДействиеПечать()
    
    
    
  4. TopicStarter Overlay
    ESP Forest GT
    Offline

    ESP Forest GT

    Регистрация:
    18 июл 2010
    Сообщения:
    17
    Симпатии:
    0
    Баллы:
    1
    Спасибо. Заработало.

Поделиться этой страницей