7.7 Выходные дни

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Samouchka, 1 сен 2014.

  1. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Всем здравствуйте. Есть дата Дата1. Нужно определить является ли
    Дата1 выходным днём по календарю 1С, который есть изначально в
    конфигурации (открывается Сервис-Календарь). Нужен код типа:
    Код:
    Если Дата1=Выходной Тогда
    Сообщить(Дата1 +" - выходной день");
    КонецЕсли;
    Помогите, пожалуйста.
  2. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    выходным по календарю с учётом праздников? или просто суббота и воскресенье?
    второе - элементарно
    первый - не всё так однозначно
  3. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Просто суббота и воскресенье, без праздников
  4. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    тогда до банального просто, всё штатно
    Код:
    НомерДняНедели(<?>)
    Синтаксис:
    НомерДняНедели(<Дата>)
    Назначение:
    Возвращает порядковый номер дня недели для заданной даты.
    Параметры:
    <Дата> - выражение со значением типа дата.
    Замечание:
    Порядковые номера дней недели: 1 - понедельник, 2 - вторник, ..., 7 - воскресенье.
    то бишь если по быстрому
    Код:
    Если (НомерДняНедели(Дата1)=6) ИЛИ (НомерДняНедели(Дата1)=6) Тогда
    Сообщить(Дата1 +" = выходной день недели");
    КонецЕсли;
    --- Объединение сообщений, 1 сен 2014 ---
    или так
    Код:
    Если НомерДняНедели(Дата1)>5 Тогда  // вариация - Если НомерДняНедели(Дата1)>=6 Тогда
    Сообщить(Дата1 +" = выходной день недели");
    КонецЕсли;
    Samouchka нравится это.
  5. TopicStarter Overlay
    Samouchka
    Offline

    Samouchka Опытный в 1С

    Регистрация:
    20 мар 2013
    Сообщения:
    214
    Симпатии:
    1
    Баллы:
    29
    Спасибо. Не знал, что можно использовать функции работы с датой для этого. Упёрся в календарь...
  6. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.431
    Симпатии:
    372
    Баллы:
    104
    там и день месяца можно получать аналогично

Поделиться этой страницей