7.7 Вывод субконто в отчете

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем AD1986, 9 авг 2012.

  1. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    Добрый день есть отчет по 68. Выводит обороты по всем субсчетам этого счета , появилаь необходимость что бы кроме субсчетов в них же ввыводился субконто ПлатежиВБюджет который принадлежит данному счету(субсчета) Если не сложно подскажите.Счас отчет имеет вид
    68
    68.1
    68.2 и.т.п

    а нужно

    68
    налог
    ПНналог
    68.1
    налог
    ПНналог
    ит.д

    налог и ПНналог это субконто ПлатежиВБюджет
    Код прилагаю .
    Код:
    //*******************************************
    
    Перем ИТОГД,ИтогК,ИТОГДК,ИтогКК;
    Процедура Сформировать_Колонки(Ит, Таб, Стр)
    Таб.ВывестиСекцию(Стр+"|Начало");
    Ит.ВыбратьКорСчета(1, 1);
    Пока Ит.ПолучитьКорСчет() = 1 Цикл
    Таб.ПрисоединитьСекцию(Стр+"|КорСчет_Дт");
    КонецЦикла;
    Таб.ПрисоединитьСекцию(Стр+"|Оборот_Дт");
    Ит.ВыбратьКорСчета(1, 2);
    Пока Ит.ПолучитьКорСчет() = 1 Цикл
    Таб.ПрисоединитьСекцию(Стр+"|КорСчет_Кт");
    КонецЦикла;
    Таб.ПрисоединитьСекцию(Стр+"|Оборот_Кт");
    Таб.ПрисоединитьСекцию(Стр+"|Конец");
    КонецПроцедуры
    Процедура Сформировать()
    Итог=0;
    ИтогД=0;
    Итог1=0;
    ИтогК=0;
    Итог2=0;
    ИтогДК=0;
    Итог3=0;
    ИтогКК=0;
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Ит = СоздатьОбъект("БухгалтерскиеИтоги");
    Ит.ВключатьСубсчета(1, 0);
    Ит.ВыполнитьЗапрос(ВыбНачПериода, ВыбКонПериода, "68",,, 3,, "С");
    Таб.ВывестиСекцию("Заголовок");
    Сформировать_Колонки(Ит, Таб, "Шапка");
    Таб.Опции(0,0,Таб.ВысотаТаблицы(),0);
    Ит.ВыбратьСчета();
    Пока Ит.ПолучитьСчет() = 1 Цикл
    Если (Ит.Счет<>СчетПоКоду("68"))  Тогда
    Сформировать_Колонки(Ит, Таб, "Счет");
    Итог=Ит.СНД();
    Итог1=Ит.СНК();
    Итог2=Ит.СКД();
    Итог3=Ит.СКК();
    // Если (Ит.Счет<>СчетПоКоду("68.6")) Тогда
    ИтогД=ИтогД+Итог;
    ИтогК=ИтогК+Итог1;
    ИтогДК=ИтогДК+Итог2;
    ИтогКК=ИтогКК+Итог3;
    КонецЕсли;
    //  КонецЕсли;
    КонецЦикла;
    Сформировать_Колонки(Ит, Таб, "Подвал");
    ИтогД=ИтогД+Итог;
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать","");
    КонецПроцедуры
    //}}БУХГАЛТЕРСКИЙ ЗАПРОС
    
    Процедура ПриОткрытии()
    КонецПроцедуры
    
    

Поделиться этой страницей