8.х Вывод строки!

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Romik, 16 апр 2009.

  1. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Не получается сделать правильный вывод строк.
    В циклсе ищется по наименование вид адреса Если Фактически..выводится в список и в строку Вид ставится Фактический адрес и соответсенно у Юридического так же.

    Код:
    Пока ВыборкаВидов.Следующий() Цикл
    Если Найти(ВыборкаВидов.Наименование, "Фактический адрес контрагента")		 
    ИЛИ Найти(ВыборкаВидов.Наименование, "Юридический адрес контрагента") Тогда 
    СписокВидов.Добавить(ВыборкаВидов.Ссылка);  
    КонецЕсли;	
    
    Код:
    Если Найти(ВыборкаВидов.Наименование, "Фактический адрес контрагента") Тогда
    ОбластьДетальныхЗаписей.Параметры.Вид = "Фактический адрес";
    Если Найти(ВыборкаВидов.Наименование, "Юридический адрес контрагента") Тогда
    ОбластьДетальныхЗаписей.Параметры.Вид = "Юридический адрес";
    КонецЕсли;
    КонецЕсли;
    
  2. lazy
    Offline

    lazy Модераторы Команда форума Модератор

    Регистрация:
    1 сен 2007
    Сообщения:
    2.127
    Симпатии:
    4
    Баллы:
    29
    Перечитал пять раз. Либо это конец дня, либо тема составлена не корректно. Дайте полный код, описание того, что вы хотите получить, и того, что не получается.
  3. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    В большинстве случаев у контрагента заполнено оба адреса и вывести нужно оба адреса...
    На данный момент он выводит адреса, но обзывает их все Фактическими..

    Код:
    Пока ВыборкаВидов.Следующий() Цикл
    
    Факт = Найти(ВыборкаВидов.Наименование, "Фактический адрес контрагента");
    Юр   = Найти(ВыборкаВидов.Наименование, "Юридический адрес контрагента");
    
    Если Факт Тогда
    ОбластьДетальныхЗаписей.Параметры.Вид = "Фактический адрес";
    СписокВидов.Добавить(ВыборкаВидов.Ссылка);
    Если Юр Тогда
    ОбластьДетальныхЗаписей.Параметры.Вид = "Юридический адрес";
    СписокВидов.Добавить(ВыборкаВидов.Ссылка);
    КонецЕсли;
    КонецЕсли;	
    КонецЦикла;
    
  4. tirk
    Offline

    tirk Опытный в 1С

    Регистрация:
    1 сен 2008
    Сообщения:
    1.142
    Симпатии:
    0
    Баллы:
    26
    Ромик.. привает!)) А что то не видно где ты выводишь в макет.. т.е. уже выводишь область... типа табДок.Вывести() ))
    И зачес тебе условие внутри условия? Если тебе надо выводить оба.... выводи последовательно их друг для друга
    что то типа --
    Код:
    Пока выборка.Следующий() Цикл
    
    
    Если Найти(ВыборкаВидов.Наименование, "Фактический адрес контрагента") Тогда
    ОбластьДетальныхЗаписей.Параметры.Вид = "Фактический адрес";
    
    КонецЕсли;
    ТабДок.Вывести(ОбластьДетальныхЗаписей);
    Если Найти(ВыборкаВидов.Наименование, "Юридический адрес контрагента") Тогда
    ОбластьДетальныхЗаписей.Параметры.Вид = "Юридический адрес";
    КонецЕсли;
    ТабДок.Вывести(ОбластьДетальныхЗаписей);
    
    КонецЦикла;
    
    
    Хотябы так...
  5. TopicStarter Overlay
    Romik
    Offline

    Romik Опытный в 1С

    Регистрация:
    27 июн 2008
    Сообщения:
    238
    Симпатии:
    0
    Баллы:
    26
    Здарова) Тебя что в аське не видно?))) :unsure:

    Попробавал так...Адреса то выводит нормально и факт и Юр...но ОбластьДетальныхЗаписей.Параметры.Вид заполняет только Юридическим.

    Код:
    Пока ВыборкаВидов.Следующий() Цикл
    Если Найти(ВыборкаВидов.Наименование, "Фактический адрес контрагента") Тогда
    СписокВидов.Добавить(ВыборкаВидов.Ссылка);
    ОбластьДетальныхЗаписей.Параметры.Вид = "Фактический адрес";	
    КонецЕсли;
    ТабДок.Вывести(ОбластьДетальныхЗаписей);
    Если Найти(ВыборкаВидов.Наименование, "Юридический адрес контрагента") Тогда
    СписокВидов.Добавить(ВыборкаВидов.Ссылка);
    ОбластьДетальныхЗаписей.Параметры.Вид = "Юридический адрес";
    КонецЕсли;
    ТабДок.Вывести(ОбластьДетальныхЗаписей);	
    КонецЦикла;
    

Поделиться этой страницей