7.7 Вывод строк из таблицы в секцию

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Margo, 19 авг 2013.

  1. TopicStarter Overlay
    Margo
    Offline

    Margo

    Регистрация:
    31 май 2010
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Помогите реализовать вывод строк другой секции. Дело в чем: в табличной части есть несколько строк, как в таблицу добавить эти строки, так чтоб строки основной секции не повторялись?

    Код:
     Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Макет");
    
    Таб.ВывестиСекцию("Лист1");
    // Таб.ВывестиСекцию("Шапка2");
    
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если НомерСтроки=1 Тогда
    Отъезд=Отъезд;
    Приезд = Приезд
    Иначе
    Отъезд="";
    Приезд="";
    КонецЕсли;
    Таб.ВывестиСекцию("Лист1|Строка");
    КонецЦикла;
    Таб.ВывестиСекцию("Подвал2");
    
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,0,0,0);
    Таб.Показать("");

    Вложения:

    • Макет.jpg
      Макет.jpg
      Размер файла:
      14,8 КБ
      Просмотров:
      16
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Код:
     Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Макет");
    
    Таб.ВывестиСекцию("заголовок");
    
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Если НомерСтроки=1 Тогда
    Отъезд=Отъезд;
    Приезд = Приезд
    Иначе
    Отъезд="";
    Приезд="";
    КонецЕсли;
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    Таб.ВывестиСекцию("Подвал");
    
    Таб.ТолькоПросмотр(1);
    Таб.Опции(0,0,0,0);
    Таб.Показать("");
    Посмотреть вложение 15946

    Вложения:

Поделиться этой страницей