8.х Вывод Списка

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Panchos, 2 фев 2007.

  1. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Написал запрос, дошол до последнего, самогог главного, вывода списка а вот что дальше делать незнаю.

    Код:
    Запрос=Новый Запрос("
    |Выбрать
    |   РеализацияТоваровУслуг.Договор,
    |    РеализацияТоваровУслуг.Номер,
    |    РеализацияТоваровУслуг.Дата
    |ИЗ
    |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |Где
    |   РеализацияТоваровУслуг.Договор ПОДОБНО &Владелец И РеализацияТоваровУслуг.Дата < ДатаВремя(ТекущаяДата) ");
    
    Запрос.УстановитьПараметр("Владелец","Контрагент");
    Выборка=Запрос.Выполнить().Выбрать();  
    
    Заранее спаисбо
  2. Coder1C
    Offline

    Coder1C Слуга форума Команда форума Администратор

    Регистрация:
    10 фев 2006
    Сообщения:
    506
    Симпатии:
    31
    Баллы:
    54
    Код:
    Запрос=Новый Запрос("
    |Выбрать
    |   РеализацияТоваровУслуг.Договор,
    |    РеализацияТоваровУслуг.Номер,
    |    РеализацияТоваровУслуг.Дата
    |ИЗ
    |    Документ.РеализацияТоваровУслуг КАК РеализацияТоваровУслуг
    |Где
    |   РеализацияТоваровУслуг.Договор ПОДОБНО &Владелец И РеализацияТоваровУслуг.Дата < ДатаВремя(ТекущаяДата) ");
    
    Запрос.УстановитьПараметр("Владелец","Контрагент");
    Выборка=Запрос.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() Цикл
    Сообщить("-----------------------------------------------------------------------------------");
    Сообщить(Выборка.РеализацияТоваровУслуг.Дата);
    Сообщить(Выборка.РеализацияТоваровУслуг.Номер);
    Сообщить(Выборка.РеализацияТоваровУслуг.Договор);
    КонецЦикла;
    
  3. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Как в этом цикле подчинить справочник договоров справочнику контрагентов. Просто я в этом деле новичёк.

    Код:
    Договоры=Справочники.ДоговорыКонтрагентов.ПолучитьФормуВыбора().ОткрытьМодально();
    
    ДокВыборка = Документы.РеализацияТоваровУслуг.НайтиПоРеквизиту(Справочники.ДоговорыКонтрагентов);
    
    Пока ДокВыборка.Следующий() Цикл
    Сообщить("Догвор:" +ДокВыборка.ДоговорКонтрагента.ВидДоговора+ "Контрагент:" +ДокВыборка.Контрагент);
    ОбработкаПрерыванияПользователя();
    
    КонецЦикла;
    
  4. Deosfen
    Offline

    Deosfen Опытный в 1С

    Регистрация:
    6 фев 2007
    Сообщения:
    67
    Симпатии:
    0
    Баллы:
    26
    Назначьте в справочнике договоры владельца ссылка на справочник контрагент.
    Я так понимаю что в док-те у тебя договор и контрагент отдельно и не связан.

    Запрос = Новый Запрос() ;
    Запрос = "ВЫБРАТЬ Услуги.Договор, Услуги.Контрагент
    ИЗ Документ.РеализацияТоваровУслуг КАК Услуги
    ГДЕ ..... {условия}" ;
    Запрос.УстнановитьПараметр("....

    Результат = Запрос.Выполнить().Выбрать() ;
    Пока Результат.Следующий() Цикл
    лОбъектДоговор = Результат.Договор.ПолучитьОбъект() ;
    лОбъектДоговор.Владелец = Результат.Контрагент ;
    лОбъектДоговор.Записать() ;
    КонецЦикла ;

    Примерно так.
  5. TopicStarter Overlay
    Panchos
    Offline

    Panchos Опытный в 1С

    Регистрация:
    27 окт 2006
    Сообщения:
    101
    Симпатии:
    0
    Баллы:
    26
    Спасибо все получилось

Поделиться этой страницей