7.7 вывод сотрудника в у которого первая буква не А

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем nestov, 14 ноя 2011.

  1. TopicStarter Overlay
    nestov
    Offline

    nestov Опытный в 1С

    Регистрация:
    25 апр 2011
    Сообщения:
    65
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте.
    Подскажите пожалуйста, как написать в коде, что бы сотрудник, у которого первая буква "А" не показывался, не выводился в процедуре "Сообщить", вот в этом коде:
    (нужно что-то наподобии: вывести всех, кроме того, у кого первая буква в имени "А")

    Код:
    Состояние("Просмотр справочника Сотрудники...");
    СпрСотрудники = СоздатьОбъект("Справочник.Сотрудники");
    СпрСотрудники.ИспользоватьДату(РабочаяДата());
    СпрСотрудники.ВыбратьЭлементы();
    ВС = СоздатьОбъект("Справочник.ВнутренниеСовместители");
    ВС.ИспользоватьДату(РабочаяДата());
    Пока СпрСотрудники.ПолучитьЭлемент() = 1 Цикл
    Если (СпрСотрудники.ЭтоГруппа() = 0) И (РаботаетНаДату(СпрСотрудники.ТекущийЭлемент(), РабочаяДата()) = 1) Тогда
    Если СпрСотрудники.Ставка = 0 Тогда
    [B][I]//вот что-то видимо здесь нужно написать.......[/I][/B]
    [B]	Сообщить("Неверное значение 'Ставка' сотрудника " + СпрСотрудники.Наименование);[/B]
    КонецЕсли;
    ШР.НайтиЭлемент(СпрСотрудники.МестоРаботы);
    Если ШР.Выбран() = 1 Тогда
    ШР.Занято = ШР.Занято + СпрСотрудники.Ставка;
    ШР.Записать();
    КонецЕсли;
    КонецЕсли;
    
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Если СпрСотрудники.Ставка = 0 Тогда
    //вот это условие добавьте
    Если ВРЕГ(Лев(СпрСотрудники.Наименование,1))<>"А" Тогда
    Сообщить("Неверное значение 'Ставка' сотрудника " + СпрСотрудники.Наименование);
    КонецЕсли;
    КонецЕсли;
    
    

Поделиться этой страницей