8.х Вывод сообщения

Тема в разделе "Общие вопросы "1С:Предприятие 8"", создана пользователем Svetlanka, 27 авг 2013.

  1. TopicStarter Overlay
    Svetlanka
    Offline

    Svetlanka

    Регистрация:
    16 июл 2013
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    Здравствуйте. Как можно вывести все данные в одном сообщении?
    Пока Выборка.Следующий() Цикл

    ТекстПредупреждения=(" " + строка(Выборка.ЗаказПокупателя)+" " +строка( Выборка.Номенклатура)+" "+ Строка( Выборка.Произведено)+ "произведено из"+" "+Строка(Выборка.ДолжныПроизвести)+"");

    Если Выборка.ДолжныПроизвести тогда

    Предупреждение(ТекстПредупреждения,,"ЗаказыПокупателей")


    КонецЕсли;
    КонецЦикла;
  2. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    особо не вчитывалась, но я бы вот так попробовала
    Код:
    ТекстПредупреждения = "";
    Пока Выборка.Следующий() Цикл
    Если Выборка.ДолжныПроизвести тогда
    ТекстПредупреждения = ?(ТекстПредупреждения = "", "", ТекстПредупреждения + Символы.ПС) + строка(Выборка.ЗаказПокупателя)+" " +строка( Выборка.Номенклатура)+" "+ Строка( Выборка.Произведено)+ "произведено из"+" "+Строка(Выборка.ДолжныПроизвести)+"";
    КонецЕсли;
    КонецЦикла;
    Если не ТекстПредупреждения = "" Тогда
    Предупреждение(ТекстПредупреждения,,"ЗаказыПокупателей");
    КонецЕсли;
  3. TopicStarter Overlay
    Svetlanka
    Offline

    Svetlanka

    Регистрация:
    16 июл 2013
    Сообщения:
    34
    Симпатии:
    0
    Баллы:
    1
    Спасибо, получилось!
Похожие темы
  1. by_ht
    Ответов:
    22
    Просмотров:
    1.023
  2. Svetlanka
    Ответов:
    21
    Просмотров:
    1.165
Загрузка...

Поделиться этой страницей