7.7 Вывод реквизита справочника в табличную часть документа

Тема в разделе "Общие вопросы "1С:Предприятие 7.7"", создана пользователем doniel, 17 сен 2010.

  1. TopicStarter Overlay
    doniel
    Offline

    doniel Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    89
    Симпатии:
    0
    Баллы:
    26
    Пожалуйста читайте внимательно
    Попробую объяснить.
    1.Справочник Номенклатура.
    2. Вводим новую номенклатуру.
    3. В номенклатуре есть закладки Основная и Цены.
    4. Выбираем Цены. Где есть наименование, Таблица Тип цены, внизу таблицы- Дабавить цену, Изменить цену и т.д.
    5. В таблице Тип цен указываются какие цены и валюта.
    6.По кнопке Добавить цену выходит форма Сведения о цене, где выбирается Тип цен, сама цена(реквизит Цена) и "Цена указа": в валюте или рублях.
    7. Вот в этой форме я и дабавил Артикул (реквизит Артикул.)
    И надо, чтобы этот Артикул выводился на печать в строке вместе с Наименованием
  2. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    с этим ясно, как ты в документе выбираешь артикул?
  3. TopicStarter Overlay
    doniel
    Offline

    doniel Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    89
    Симпатии:
    0
    Баллы:
    26
    При выборе типа цен
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    очень внимательно читаем...

    Вы добавили в форму, а реквизит в самом справочнике создали????
    И если создали, то в каком? (номенклатура или цены)
    Если реквизит есть в спр. цен то можно так:
    Код:
    Функция ВернутьАртикул(Товар,ТипЦен)
    Артикул="";
    Спр=СоздатьОбъект("Справочник.Цены");
    Спр.ИспользоватьВладельца(Товар);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ТипЦен=ТипЦен Тогда
    Артикул=Спр.Артикул;
    Прервать;
    КонецЕсли;
    КонецЦикла;
    Возврат Артикул;
    КонецФункции
    
    
  5. TopicStarter Overlay
    doniel
    Offline

    doniel Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    89
    Симпатии:
    0
    Баллы:
    26
    Да, я создал в справочнике Цены реквизит Артикул.(Справочник Цены подчинен справочнику Номенклатура)

    В форме модуля справочник.Номенклатура прописал:
    Процедура ЗаполнитьТаблицуЦен()
    ТабЦен = СоздатьОбъект("ТаблицаЗначений");
    ТабЦен.Очистить();
    ТабЦен.НоваяКолонка("Цена");
    ...
    ТабЦен.НоваяКолонка("Артикул");
    ....
    КонецЕсли
    ТабЦен.НоваяСтрока()
    ТабЦен.Цена = СпрЦены.Цена;
    ТабЦен.Артикул = СпрЦены.Артикул;
    .....

    Теперь, при открытии номенклатуры в справочнике Номенклатура, в закладке Цены в табличной части видна цена, валюта и Артикул.

    Спасибо. Эту функцию я понимаю надо вставить в модуль формы Документ.РасходнаяНакладная.
  6. TopicStarter Overlay
    doniel
    Offline

    doniel Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    89
    Симпатии:
    0
    Баллы:
    26
    Выше указанное прописал в модуль форма-Документ.РасходнаяНакладная.
    В таблице ТТН на печать, в ячейке Наименование товара вместо <МЦ> прописал <МЦ+",арт"+Артикул>
    При выводе документа ячейка <МЦ+",арт"+Артикул> пустая, а все данные номенклатуры (цена,НДС и т.д) выводятся. В чем проблема?
  7. TopicStarter Overlay
    doniel
    Offline

    doniel Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    89
    Симпатии:
    0
    Баллы:
    26
    А строчка "Артикул = Спр.Артикул; " правильная или нет.
    Что-то Артикул не выводится
  8. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    в процедуре Печать() в цикле по строкам вставь Артикул = ВернутьАртикул(Товар,ТипЦен);
  9. TopicStarter Overlay
    doniel
    Offline

    doniel Опытный в 1С

    Регистрация:
    29 июл 2010
    Сообщения:
    89
    Симпатии:
    0
    Баллы:
    26
    Огромное СПАСИБО ВСЕМ. Все заработало. Очень благодарен.

Поделиться этой страницей