8.х Вывод панели настроек в печатной форме документа

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем vidoomka, 26 дек 2013.

  1. TopicStarter Overlay
    vidoomka
    Offline

    vidoomka

    Регистрация:
    24 дек 2013
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    При создании печатной формы у меня не выходит панель настроек. Форма документа отображается как таблица , а не как табличный документ.
  2. TopicStarter Overlay
    vidoomka
    Offline

    vidoomka

    Регистрация:
    24 дек 2013
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    вывела печатную форму, но оно выходит как таблица, а надо как табличный документ что бы появилась панель настроек.
    привожу код

    Код:
    //функция формирует табличный документ с печатной формой листа приемки
    Функция ВывестиПечатнуюФормуЛистаПриемки(Выборка)Экспорт
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    
    Если КатегорияЗакупа.Наименование="А" Тогда
    Макет = Документы.ЗаказПоставщику.ПолучитьМакет("Печать11");
    ИначеЕсли  КатегорияЗакупа.Наименование="А1"  Тогда
    Макет = Документы.ЗаказПоставщику.ПолучитьМакет("Печать11");
    ИначеЕсли  КатегорияЗакупа.Наименование="Б1"  Тогда
    Макет =Документы.ЗаказПоставщику.ПолучитьМакет("Печать11");
    ИначеЕсли  КатегорияЗакупа.Наименование="В"  Тогда
    Макет = Документы.ЗаказПоставщику.ПолучитьМакет("Печать11");
    ИначеЕсли  КатегорияЗакупа.Наименование="Д"  Тогда
    Макет = Документы.ЗаказПоставщику.ПолучитьМакет("Печать11");
    ИначеЕсли КатегорияЗакупа.Наименование="Б2" Тогда
    Макет = Документы.ЗаказПоставщику.ПолучитьМакет("Печать13");
    Иначе
    Макет = Документы.ЗаказПоставщику.ПолучитьМакет("Печать12");
    КонецЕсли;
    Индекс = 0;
    
    //Заголовок
    Область = Макет.ПолучитьОбласть("Заголовок");
    ТабличныйДокумент.Вывести(Область);
    //Шапка   
    Шапка = Макет.ПолучитьОбласть("Шапка");
    Шапка.Параметры.Заполнить(ЭтотОбъект);
    Шапка.Параметры.Склад=Выборка.Склад;
    ТабличныйДокумент.Вывести(Шапка);
    //ТоварыШапка
    ТоварыШапка=Макет.ПолучитьОбласть("ТоварыШапка");
    ТоварыШапка.Параметры.Заполнить(ЭтотОбъект);
    ТабличныйДокумент.Вывести(ТоварыШапка);
    //Товар
    Товар = Макет.ПолучитьОбласть("Товар");
    Индекс = Индекс + 1;
    Товар.Параметры.НомерСтроки= Индекс;
    Товар.Параметры.НомерВЕвфрате = Выборка.НомерВЕвфрате;
    Товар.Параметры.Номер = Выборка.Номер;
    Товар.Параметры.Номенклатура = Выборка.Номенклатура;
    Товар.Параметры.ЕдиницаИзмерения = Выборка.ЕдиницаИзмерения;
    Товар.Параметры.Количество = Выборка.Количество;
    ТабличныйДокумент.Вывести(Товар);
    //Подвал
    Подвал=Макет.ПолучитьОбласть("Подвал");
    Подвал.Параметры.Заполнить(ЭтотОбъект);
    ТабличныйДокумент.Вывести(Подвал);
    
    ТабличныйДокумент.ОтображатьСетку = Ложь;
    ТабличныйДокумент.Защита = Ложь;
    ТабличныйДокумент.ТолькоПросмотр = Ложь;
    ТабличныйДокумент.ОтображатьЗаголовки = Ложь;
    ТабличныйДокумент.Показать();
    
    Возврат ТабличныйДокумент;
    
    КонецФункции   
    //печатает лист приемки
    Функция ПечатьЛистаПриемки(Тип)
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("ТекущийДокумент", ЭтотОбъект.Ссылка);
    Запрос.Текст ="ВЫБРАТЬ
    |    ЗаказПоставщику.Номер,
    |    ЗаказПоставщику.НомерВЕвфрате,
    |    ЗаказПоставщикуТовары.Номенклатура КАК Номенклатура,
    |    ЗаказПоставщикуТовары.Количество КАК Количество,
    |    ЗаказПоставщикуТовары.ЕдиницаИзмерения,
    |    ЗаказПоставщикуТовары.Склад КАК Склад,
    |    ЗаказПоставщику.Контрагент
    |ИЗ
    |    Документ.ЗаказПоставщику.Товары КАК ЗаказПоставщикуТовары
    |	    ЛЕВОЕ СОЕДИНЕНИЕ Документ.ЗаказПоставщику КАК ЗаказПоставщику
    |	    ПО ЗаказПоставщикуТовары.Ссылка = ЗаказПоставщику.Ссылка
    |ГДЕ
    |    ЗаказПоставщикуТовары.Ссылка = &ТекущийДокумент
    |
    |СГРУППИРОВАТЬ ПО
    |    ЗаказПоставщикуТовары.Склад,
    |    ЗаказПоставщикуТовары.Номенклатура,
    |    ЗаказПоставщику.Контрагент,
    |    ЗаказПоставщику.Номер,
    |    ЗаказПоставщикуТовары.ЕдиницаИзмерения,
    |    ЗаказПоставщику.НомерВЕвфрате,
    |    ЗаказПоставщикуТовары.Количество";
    
    Выборка=Запрос.Выполнить().Выбрать();
    
    Пока Выборка.Следующий() Цикл
    
    ВывестиПечатнуюФормуЛистаПриемки(Выборка);
    
    КонецЦикла;
    
    Возврат ТабличныйДокумент;   
    
    КонецФункции
  3. TopicStarter Overlay
    vidoomka
    Offline

    vidoomka

    Регистрация:
    24 дек 2013
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    В стандартных печатных формах документа есть сверху панель, где команды печать, сохранить копию и т.д.
    У меня выходит печатная форма с заголовком формы как Таблица, без панели. нужна эта панель
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.771
    Симпатии:
    509
    Баллы:
    204
    Вы когда выделяете ячейку, панель появляется ?????????????????????????????
  5. TopicStarter Overlay
    vidoomka
    Offline

    vidoomka

    Регистрация:
    24 дек 2013
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    нет, ее нет
  6. TopicStarter Overlay
    vidoomka
    Offline

    vidoomka

    Регистрация:
    24 дек 2013
    Сообщения:
    15
    Симпатии:
    0
    Баллы:
    1
    у меня все получилось!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Поделиться этой страницей