7.7 Вывод на форму значения свойств

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем andrey-ekt78, 6 авг 2014.

  1. TopicStarter Overlay
    andrey-ekt78
    Offline

    andrey-ekt78

    Регистрация:
    6 авг 2014
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Хочу найти значение свойства ВЛице для выбранного ДоверенногоЛица
    изначально Т+С 9.2

    Структура СпрСФЛ такая же как в стандартных справочниках Свойства Контрагентов и Свойства Номенклатуры
  2. Хряк
    Offline

    Хряк Профессионал в 1С

    Регистрация:
    26 сен 2007
    Сообщения:
    1.447
    Симпатии:
    37
    Баллы:
    54
    //******************************************************************************
    //НВЮ/ Получение Свойства Контрагента
    //
    // Параметры
    // Контрагент (Справочник.Контрагенты) Контрагент для получения свойства
    // ВидСвойства (Текст или Справочник.ВидыСвойств) Получаемый вид свойства
    //
    // Возвращаемое значение:
    // Значение свойства (Текст)
    //
    Функция глПолучениеСвойстваКонтрагента(Контрагент, ВидСвойства) Экспорт
    Если ПустоеЗначение(Контрагент)=1 Тогда
    Возврат "";
    ИначеЕсли ПустоеЗначение(ВидСвойства)=1 Тогда
    Возврат "";
    КонецЕсли;
    Если ТипЗначенияСтр(ВидСвойства)="Строка" Тогда//Требуется подобрать ВидСвойств
    СпрВС = СоздатьОбъект("Справочник.ВидыСвойств");
    Если СпрВС.НайтиПоНаименованию(ВидСвойства,0,1)=0 Тогда
    Возврат "";//нет такого свойства
    КонецЕсли;
    ВидСв = СпрВС.ТекущийЭлемент();
    Иначе
    ВидСв = ВидСвойства;
    КонецЕсли;
    СпрВС = СоздатьОбъект("Справочник.СвойстваКонтрагентов");
    СпрВС.ИспользоватьВладельца(Контрагент);
    Если СпрВС.НайтиПоРеквизиту("ВидСвойства",ВидСв,0)=0 Тогда
    Возврат "";
    КонецЕсли;
    Возврат СокрЛП(СпрВС.ЗначениеСвойства.Наименование);
    КонецФункции// глПолучениеСвойствоКонтрагента(Контрагент, ВидСвойства)
    andrey-ekt78 нравится это.
  3. TopicStarter Overlay
    andrey-ekt78
    Offline

    andrey-ekt78

    Регистрация:
    6 авг 2014
    Сообщения:
    21
    Симпатии:
    0
    Баллы:
    1
    Хряк, ОГРОМНОЕ ВАМ СПАСИБО !!!! Все работает просто замечательно

Поделиться этой страницей