7.7 Вывод картинки в печатную форму

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем X-Man, 23 июн 2008.

  1. TopicStarter Overlay
    X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    439
    Симпатии:
    3
    Баллы:
    29
    Помогите, пожалуйста. Как в форму диалога вывести-знаю, а вот как в печатную форму? :unsure:
  2. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
    тебе какую картинку? меняющеюся? или постоянную?
  3. TopicStarter Overlay
    X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    439
    Симпатии:
    3
    Баллы:
    29
    Меняющуюся. Постоянную я знаю как.
  4. Stado_adama
    Offline

    Stado_adama Модераторы Модератор

    Регистрация:
    27 ноя 2007
    Сообщения:
    1.086
    Симпатии:
    0
    Баллы:
    26
  5. TopicStarter Overlay
    X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    439
    Симпатии:
    3
    Баллы:
    29
    Я конечно все понимаю, но второй день никаких конструктивных предложений ни в эту тему, ни в находящуюся по ссылке выше не поступает. Что, все так сложно?
  6. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    А в типовой нет примера вывода логотипов компании??

    Вот, нашел:
    Пишешь функцию типа
    Код:
    Функция Лого(Карт) Экспорт
    ФайлЛого=СокрЛП(Константа.Лого);
    Если СтрДлина(ФайлЛого)>0  Тогда
    Если ФС.СуществуетФайл(ФайлЛого)=1 Тогда
    Карт.Загрузить(ФайлЛого);
    КонецЕсли;
    КонецЕсли;
    КонецФункции  
    
    
    В печатной форме размещаешь картинку, текст которой
    Код:
    Лого(Таб.ТекущийОбъект)
    
    Т.е. в функцию передаешь саму эту картинку, а там подгружаешь изображение


    "Константа.Лого" - строковая константа, содержащая путь к файлу.
  7. TopicStarter Overlay
    X-Man
    Offline

    X-Man Опытный в 1С

    Регистрация:
    18 май 2007
    Сообщения:
    439
    Симпатии:
    3
    Баллы:
    29
    Спасибо, буду пробовать.

Поделиться этой страницей