7.7 вывод информации

Тема в разделе "Типовые решения "1С:Предприятие 7.7"", создана пользователем AD1986, 25 мар 2011.

  1. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    Проблема у меня такая мне нужно вывести информацию в документ:
    Код:
    стрОценах =+Видд+"Надб." + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";
    
    
    проблема вот в чем если наценка со знаком - тогда должно выводить не Надб. а Оптовая скидка
    Код:
    стрОценах =+Видд+"Оптовая скидка" + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " ";
    
    
    Если со знаком - тогда
    Код:
    стрОценах =+Видд+"Надб." + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";
    
    
    А если Учетная цена = цене реализации тоесть наценка равно 0 тгда
    Код:
    стрОценах =+Видд+"Оптовая надбавка 0%" + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";
    
    
    Вот мой код но я так понимаю это не правильно
    ************************************************************************
    Код:
    Если Процент=<+> Тогда     
    cтрОценах ="Надб." + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";
    Если  Тогда Процент=<-> Тогда cтрОценах ="Оптовая скидка." + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " "; // от учетной цены
    КонецЕсли;
    КонецЕсли;	
    
    
    *************************************************************************

    И еще один небольшой вопрос как в переменную cтрОценах вытащить из наменклатуры данные вид тары. Тоетсь как выгледит синтаксис.
    [warn="Внимание!"]
    Не забываем пользоваться тегами
    [/warn]
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Ваш код
    Код:
    Если Процент>0 Тогда     
    стрОценах =+Видд+"Надб." + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";
    ИначеЕсли Процент<0 Тогда     
    стрОценах =+Видд+"Оптовая скидка" + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " ";
    Иначе
    стрОценах =+Видд+"Оптовая надбавка 0%" + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";
    КонецЕсли;
    
    
    
    
    Что касается второго вопроса - уточните конфигурацию
  3. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    1С 7.7 бухгалтерия ели точно описать что мне нужно


    стрОценах =+Видд+"Оптовая надбавка 0%" + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";

    то в переменную Видд внести из номенклатуры вид тары либо если можно как то сразу что бы выводило
  4. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    Извеняюсь но по первому вопросу пишут ошибку
    Если Процент=<<?>>>0 Тогда
    {C:\PROGRAM FILES\1CV77ИБ\BUHTEHIZOL1\EXTFORMS\PRNFORMS\JU_TTN1P.ERT(241)}: Ожидается логическое выражение
    ИначеЕсли Процент=<<?>><0 Тогда
    {C:\PROGRAM FILES\1CV77ИБ\BUHTEHIZOL1\EXTFORMS\PRNFORMS\JU_TTN1P.ERT(243)}: Ожидается логическое выражение
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вот так правильно
    Код:
    ВидД=""+Номенклатура.ВидНоменклатуры;
    Если Процент>0 Тогда     
    стрОценах =Видд+"Надб." + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";
    ИначеЕсли Процент<0 Тогда     
    стрОценах =Видд+"Оптовая скидка" + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " ";
    Иначе
    стрОценах =Видд+"Оптовая надбавка 0%" + Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";
    КонецЕсли;
    
    
    
    
    
  6. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    Извеняюсь но по первому вопросу пишут ошибку
    Если Процент=<<?>>>0 Тогда
    {C:\PROGRAM FILES\1CV77ИБ\BUHTEHIZOL1\EXTFORMS\PRNFORMS\JU_TTN1P.ERT(241)}: Ожидается логическое выражение
    ИначеЕсли Процент=<<?>><0 Тогда
    {C:\PROGRAM FILES\1CV77ИБ\BUHTEHIZOL1\EXTFORMS\PRNFORMS\JU_TTN1P.ERT(243)}: Ожидается логическое выра
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Читаем код внимательнее... Ошибка исправлена
  8. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Можно вот так, будет нагляднее.
    (если только у Вас меняется одна надпись и параметр ВалютаНакладной во второй строке пропущен случайно)
    Код:
    Если Процент>0 Тогда     
    Надпись = "Надб.";
    ИначеЕсли Процент<0 Тогда     
    Надпись = "Оптовая скидка";
    Иначе
    Надпись = "Оптовая надбавка 0%";
    КонецЕсли;
    стрОценах =Видд+Надпись+ Процент + "%. к цене "+ СокрЛ(Формат(ПерваяЦена, сФормат))+ " " + ВалютаНакладной + " ";
    
    
    
    
  9. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    Нет это я уже понял не эта ошибка а вот какая

    ВидД=""+Номенклатура<<?>>.ВидНоменклатуры;
    {C:\PROGRAM FILES\1CV77ИБ\BUHTEHIZOL1\EXTFORMS\PRNFORMS\JU_TTN1P.ERT(208)}: Переменная не определена (Номенклатура)
    ВидД=""+Номенклатура<<?>>.ВидНоменклатуры;
    {C:\PROGRAM FILES\1CV77ИБ\BUHTEHIZOL1\EXTFORMS\PRNFORMS\JU_TTN1P.ERT(243)}: Переменная не определена (Номенклатура)

    Извеняюсь за столь надоедливость

    В реквизитах тип значания для данной переменной стоит
    Справочник.ЕдиницыИзмерения
  10. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Вы просто не указали ГДЕ вы выводите. Возможно переменная называется ТОВАР
  11. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    ВидД=""+Номенклатура.ВидТары а если указать так почему она не вытягивает с номенклатуры вид тары
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    ВидТары - нет такого стандартного реквизита. У вас нетиповая конфа?
  13. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    Может я неправильно просто изъясняюсь у товара есть единица измерения упаковки банки и т.п. все эти данные хранятся в номенклатуре как мне вытянуть оттуда для определённого товара значения


    и вот еще одна ошибка я вообще ничего понять не могу

    C:\PROGRAM FILES\1CV77ИБ\BUHTEHIZOL1\EXTFORMS\PRNFORMS\JU_TTN1P.ERT(209)}: Операции сравнения на больше-меньше допустимы только над значениями совпадающих базовых типов (число, строка, дата)

    типовая конфа от Юколы
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Я так понимаю белорусия.......
    Есть возможность подключиться удаленно к вам через TreamViewer?
    Что касается второго вопроса - не указали строку с ошибкой, но на 99% там переменной присвоено пустое значение (т.е. не присвоено ничего) и вы сравниваете его с конкретным типом данных
  15. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    удаленно наверное не смогу сделать так как нахожусь пока не на рабочем месте я так понимаю что я не правильно вытаскиваю данные из номенклатуры
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Похоже на то....
    Можете скинуть МДшник с указанием места где вы выводите вашу информацию
  17. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    ок счас скину 5 мин
  18. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    а если я выкину код данного отчета
  19. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Желательно... Но и сама база нужна. Т.к. я не знаком с ее структурой.
  20. TopicStarter Overlay
    AD1986
    Offline

    AD1986 Опытный в 1С

    Регистрация:
    8 фев 2011
    Сообщения:
    138
    Симпатии:
    0
    Баллы:
    26
    Вот код прикреплен и пишет ошибки
    Если Процент>0 Тогда
    {C:\PROGRAM FILES\1CV77ИБ\BUHTEHIZOL1\EXTFORMS\PRNFORMS\JU_TTN1P.ERT(209)}: Операции сравнения на больше-меньше допустимы только над значениями совпадающих базовых типов (число, строка, дата

    Вложения:

    • 123.txt
      Размер файла:
      17,4 КБ
      Просмотров:
      28

Поделиться этой страницей