8.х Вывод данных в управляемой форме

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ratat11, 28 мар 2016.

  1. TopicStarter Overlay
    ratat11
    Offline

    ratat11

    Регистрация:
    22 май 2015
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Подскажите как реализовать. 1С 8.3.7 самописная конфигурация. УФ, тонкий клиент.
    Имеется форма обработки: в ней указывается параметры:
    дата, фирма, пользователь.
    При выборе Фирмы, хотел реализовать, чтобы пользователь брался именно тот, который работает на этой фирме. Данные эти хранятся в периодическом регистре сведений:
    Период,Фирма,Пользователь.
    Т.е. я хотел произвести выборку запросом, указав в качестве параметра фирму и вывести этот список через реквизит пользователь на форме.
    Вопрос как это правильно сделать, возможно есть другой вариант?
    Насколько я понимаю мне надо сделать запрос на стороне сервера, выгрузить его - вопрос какой тип использовать..
    Потом какой тип выбрать у реквизита Пользователь?
    Так же вопрос как правильно передать параметр Фирма в процедуру запроса?
    Текст ф-и запроса:
    Код:
    &НаСервере
    Процедура ЗаполнитьЗаголовкиПоТипу (пФирма)
        //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
        // Данный фрагмент построен конструктором.
        // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
       
        Запрос = Новый Запрос;
        Запрос.Текст =
            "ВЫБРАТЬ РАЗРЕШЕННЫЕ
            |    ПользователиФирмСрезПоследних.Пользователь.Наименование
            |ИЗ
            |    РегистрСведений.ПользователиФирм.СрезПоследних КАК ПользователиФирмСрезПоследних
            |ГДЕ
            |    ПользователиФирмСрезПоследних.Фирма = &Фирма
            |
            |СГРУППИРОВАТЬ ПО
            |    ПользователиФирмСрезПоследних.Пользователь.Наименование";
       
        Запрос.УстановитьПараметр("Фирма", ПФирма);
       
        РезультатЗапроса = Запрос.Выполнить();
       
        ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
       
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        КонецЦикла;    //}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    КонецПроцедуры
    

    Вложения:

    • 1.jpg
      1.jpg
      Размер файла:
      107,1 КБ
      Просмотров:
      11
  2. TopicStarter Overlay
    ratat11
    Offline

    ratat11

    Регистрация:
    22 май 2015
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Код:
    &НаСервере
    Функция ВыборкаСотрудниковПоФирме()
        Фирма = Справочники.Фирмы.НайтиПоНаименованию("Nissan");
        Запрос = Новый Запрос;
        Запрос.Текст =
            "ВЫБРАТЬ
            |    ПользователиФирмСрезПоследних.Фирма,
            |    ПользователиФирмСрезПоследних.Пользователь
            |ИЗ
            |    РегистрСведений.ПользователиФирм.СрезПоследних КАК ПользователиФирмСрезПоследних
            |ГДЕ
            |    ПользователиФирмСрезПоследних.Фирма = &Фирма
            |
            |СГРУППИРОВАТЬ ПО
            |    ПользователиФирмСрезПоследних.Фирма,
            |    ПользователиФирмСрезПоследних.Пользователь";
    
        Запрос.УстановитьПараметр("Фирма", Фирма);
    
        РезультатЗапроса = Запрос.Выполнить();
    
        СписокПользователей = Новый СписокЗначений;
        СписокПользователей.ЗагрузитьЗначения(РезультатЗапроса.Выгрузить().ВыгрузитьКолонку("Пользователь"));
    Возврат СписокПользователей;
    КонецФункции
    
    
    &НаКлиенте
    Процедура ОбъектПользовательНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
        Объект.Пользователь = ВыбратьИзСписка(ВыборкаСотрудниковПоФирме(),Элементы.ОбъектПользователь);
    КонецПроцедуры
    
    Когда я нажимаю выбор пользователей, появляется список пользователей, но выбрать его не получается, так как появляется сгенерированные автоматически пустое окно списка.
    Вопрос:
    как передать данные в него или чтобы подставлялись свои данные.
    Посмотреть вложение 22198 Посмотреть вложение 22199 Посмотреть вложение 22200 Посмотреть вложение 22198

    Вложения:

    • 2.jpg
      2.jpg
      Размер файла:
      65,2 КБ
      Просмотров:
      4
    • 3.jpg
      3.jpg
      Размер файла:
      36,2 КБ
      Просмотров:
      4
    • 4.jpg
      4.jpg
      Размер файла:
      44,3 КБ
      Просмотров:
      4

Поделиться этой страницей