8.х вывод числа и текста в ячейку табличного документа 1с 8.3

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем JediAlex, 25 фев 2015.

  1. TopicStarter Overlay
    JediAlex
    Offline

    JediAlex Опытный в 1С

    Регистрация:
    27 авг 2011
    Сообщения:
    140
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте. Делаю собственную конфигурацию в 1с 8.3. Создал документ и макет табличного документа. Процедуру печати создал конструктором печати и потом немного изменил. вот что в итоге получилось:
    Код:
    Процедура Печать(ТабДок, Ссылка) Экспорт
    //{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
    //Макет = Документы.ОценочнаяВедомость.ПолучитьМакет("Печать");
    Макет = Документы.ОценочнаяВедомость.ПолучитьМакет("ПечатнаяФормаВедомости");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ОценочнаяВедомость.Должность,
    | ОценочнаяВедомость.ИтоговыйПоказательЭффективности,
    | ОценочнаяВедомость.КонецПериода,
    | ОценочнаяВедомость.НачалоПериода,
    | ОценочнаяВедомость.ОценкаРаботы,
    | ОценочнаяВедомость.Подразделение,
    | ОценочнаяВедомость.ПроцентВыполненияРуводителя,
    | ОценочнаяВедомость.Сотрудник,
    | ОценочнаяВедомость.КритерииОценки.(
    | НомерСтроки,
    | Критерий,
    | НольБаллов,
    | ОдинБалл,
    | ДваБалла,
    | ТриБалла,
    | БаллСотрудника,
    | КомментарийСотрудника,
    | БаллРуководителя,
    | КомментарийРуководителя,
    | ВесовойКоэффициент,
    | Итог
    | )
    |ИЗ
    | Документ.ОценочнаяВедомость КАК ОценочнаяВедомость
    |ГДЕ
    | ОценочнаяВедомость.Ссылка В (&Ссылка)";
    Запрос.Параметры.Вставить("Ссылка", Ссылка);
    Выборка = Запрос.Выполнить().Выбрать();
    
    
    //ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    //Шапка = Макет.ПолучитьОбласть("Шапка");
    //ОбластьКритерииОценкиШапка = Макет.ПолучитьОбласть("КритерииОценкиШапка");
    //ОбластьКритерииОценки = Макет.ПолучитьОбласть("КритерииОценки");
    //Подвал = Макет.ПолучитьОбласть("Подвал");
    Заголовок = Макет.ПолучитьОбласть("Заголовок");
    Ведомость = Макет.ПолучитьОбласть("Ведомость");
    ВедомостьШапка = Макет.ПолучитьОбласть("ВедомостьШапка");
    ИтогиВедомости = Макет.ПолучитьОбласть("ИтогиВедомости");
    
    
    ТабДок.Очистить();
    
    
    ВставлятьРазделительСтраниц = Ложь;
    Пока Выборка.Следующий() Цикл
    Если ВставлятьРазделительСтраниц Тогда
    ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЕсли;
    Заголовок.Параметры.Заполнить(Выборка);
    ИтогиВедомости.Параметры.Заполнить(Выборка);
    ТабДок.Вывести(Заголовок, Выборка.Уровень());
    ТабДок.Вывести(ВедомостьШапка);
    //ТабДок.Вывести(Заголовок, Выборка.Уровень());
    //ТабДок.Вывести(ОбластьКритерииОценкиШапка);
    ВыборкаКритерииОценки = Выборка.КритерииОценки.Выбрать();
    ИтогСотрудника=0;
    ИтогРуководителя=0;
    ИтогКоэффициент=0;
    ОбщийИтог=0;
    Пока ВыборкаКритерииОценки.Следующий() Цикл
    //Ведомость.Параметры.Заполнить(ВыборкаКритерииОценки);
    Ведомость.Параметры.НомерСтроки=ВыборкаКритерииОценки.НомерСтроки;
    Ведомость.Параметры.Критерий=ВыборкаКритерииОценки.Критерий;
    Ведомость.Параметры.НольБаллов=ВыборкаКритерииОценки.НольБаллов;
    Ведомость.Параметры.ОдинБалл=ВыборкаКритерииОценки.ОдинБалл;
      Ведомость.Параметры.ДваБалла=ВыборкаКритерииОценки.ДваБалла;
    Ведомость.Параметры.ТриБалла=ВыборкаКритерииОценки.ТриБалла;
      Ведомость.Параметры.БаллСотрудника=ВыборкаКритерииОценки.БаллСотрудника;
    ИтогСотрудника=ИтогСотрудника+ВыборкаКритерииОценки.БаллСотрудника;
    Ведомость.Параметры.КомментарийСотрудника=ВыборкаКритерииОценки.КомментарийСотрудника;
      Ведомость.Параметры.БаллРуководителя=ВыборкаКритерииОценки.БаллРуководителя;
    ИтогРуководителя=ИтогРуководителя+ВыборкаКритерииОценки.БаллРуководителя;
    Ведомость.Параметры.КомментарийРуководителя=ВыборкаКритерииОценки.КомментарийРуководителя;
      Ведомость.Параметры.ВесовойКоэффициент=ВыборкаКритерииОценки.ВесовойКоэффициент*100;
    ИтогКоэффициент=ИтогКоэффициент+Ведомость.Параметры.ВесовойКоэффициент;
    Ведомость.Параметры.Итог=ВыборкаКритерииОценки.Итог;
    ОбщийИтог=ОбщийИтог+ВыборкаКритерииОценки.Итог;
      ТабДок.Вывести(Ведомость, ВыборкаКритерииОценки.Уровень());
    КонецЦикла
    
    ИтогиВдомости.Параметры.ИтогСотрудника=ИтогСотрудника;
    ИтогиВедомости.Параметры.ИтогРуководителя=ИтогРуководителя;
    ИтогиВедомости.Параметры.ИтогКоэффициент=ИтогКоэффициент;
    ИтогиВедомости.Параметры.ОбщийИтог=ОбщийИтог;
    //ИтогиВедомости.Параметры.ПроцентВыполненияРуководителя=Выборка.ППроцентВыполненияРуководителя;
    //ИтогиВедомости.Параметры.ПроцентВыполненияРуководителя=Выборка.ПроцентВыполненияРуководителя;
    //ИтогиВедомости.Параметры.ИтоговыйПоказательЭффективности=Выборка.ИтоговыйПоказательЭффективности;
    ТабДок.Вывести(ИтогиВедомости);
      ТабДок.РазмерСтраницы="A4";
    //ИтогиВедомости.Параметры.Заполнить(Выборка);
    //ТабДок.Вывести(Подвал);
    ВставлятьРазделительСтраниц = Истина;
    КонецЦикла;
    //ТабДок.Напечатать(РежимИспользованияДиалогаПечати.Использовать);
    //}}
    КонецПроцедуры
    Документ печатается ,но не выводится параметр ОценочнаяВедомость.ПроцентВыполненияРуводителя, который выбирается запросом, как и остальные данные. В макете этот параметр должен выводиться в области ИтогиВедомости. Для ячейки макета я задал шаблон вывода: [ПроцентВыполненияРуководителя]%. Аналогичный параметр ИтоговыйПоказательЭффективности выводится как должен...в чем проблема с параметром ОценочнаяВедомость.ПроцентВыполненияРуводителя??? никак не пойму.....выводится только знак % шаблона...помогите пожалуйста
  2. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.639
    Симпатии:
    948
    Баллы:
    204
    У вас в запросе ПроцентВыполненияРуводителя
    А в шаблоне ПроцентВыполненияРуководителя

    буквы К в запросе не хватает
  3. Tiger86
    Offline

    Tiger86 Модераторы Команда форума Модератор

    Регистрация:
    24 мар 2011
    Сообщения:
    6.407
    Симпатии:
    108
    Баллы:
    104
    и буквы о, следом за к.... если писали запрос руками то поправьте, а если такое имя у реквизита, то правьте в шаблоне в чейке
  4. Draco
    Online

    Draco Модераторы Команда форума Модератор

    Регистрация:
    28 окт 2009
    Сообщения:
    13.639
    Симпатии:
    948
    Баллы:
    204
    в общем копипастите лучше

Поделиться этой страницей