7.7 вывести остатки в таблицу

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем Андрей В, 31 май 2007.

  1. TopicStarter Overlay
    Андрей В
    Offline

    Андрей В

    Регистрация:
    31 май 2007
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    Здравствуй..я оч. недавно столкнулся с 1с языком программирования..когда пошел на работу и вот задали задачу..легкую вроде но у меня чтот не получается..

    нужно вывести наименование и количество товара оставшегося на складе к данной (введеной) дате (т.е.сальдо я так понимаю) в таблицу..в первую колонку товар во вторую количество..

    но я пока деже просто товар не могу вывести..

    Код:
    Процедура Сформировать()
    сообщить("дата: " +дата1);
    сообщить("склад: " +склад);
    
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("таблица");                          
    таб.вывестисекцию("шапка");  //тут просто название столбцов            
    таб.вывестисекцию("строка");    //здесь уже сами товары              
    Таб.ТолькоПросмотр(0);
    Таб.Опции(1,1,15,2);
    Таб.Показать();                
    
    бухитоги=СоздатьОбъект("БухгалтерскиеИтоги"); 
    
    бухитог и.использоватьсубконто(видысубконто.Номенклатура,,1);                                   бухитоги.выполнитьзапрос(,дата1,"41",,,,,);                            
    бухитоги.выбратьсубконто();                             
    Пока бухитоги.получитьсубконто()=1 Цикл;
    сообщить(бухитоги.субконто());                    
    КонецЦикла;  
    
    КонецПроцедуры  
    
    
    "дата1" и "склад" выбирается в окне диалога и после нажатия кнопки "сформировать" выводится таблица с итогами. Таблицу я нарисовал. сделал в ней две секции "шапка" и "строки".
    в клеточке секции "строки" я поставил бухитоги.субконто() и тип выражение..но наименование товара будит выводиться ток. в одну клеточку и без цикла пока..с ним не работает.
    Так как мне сделать чтобы после нажатия кнопки "сформировать" выводилась таблица со строками заполниными наименованием оставшегося на данную дату1 товара??
    спасибо.
  2. TopicStarter Overlay
    Андрей В
    Offline

    Андрей В

    Регистрация:
    31 май 2007
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    все разобрался:

    Код:
    //*******************************************
    Процедура Сформировать()
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");                          
    Таб.Вывестисекцию("Шапка");  
    //
    БухИт = СоздатьОбъект("БухгалтерскиеИтоги"); 
    БухИт.ИспользоватьСубконто(ВидыСубконто.Номенклатура,);
    БухИт.ИспользоватьСубконто(ВидыСубконто.МестаХранения,ВыбСклад);
    БухИт.Опции(1,0);
    БухИт.ВыполнитьЗапрос(,Дата1,"41.1");
    БухИт.ВыбратьСубконто(1);
    Пока БухИт.ПолучитьСубконто(1) = 1 Цикл
    БухИт.ВыбратьСубконто(2);
    Пока БухИт.ПолучитьСубконто(2) = 1 Цикл
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    КонецЦикла;
    //
    Таб.ТолькоПросмотр(1);
    Таб.Показать();    
    КонецПроцедуры
    //*******************************************
    Дата1 = РабочаяДата();
    

Поделиться этой страницей