8.х Вывести на печать дерево значений

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем Berezin, 13 фев 2011.

  1. TopicStarter Overlay
    Berezin
    Offline

    Berezin Опытный в 1С

    Регистрация:
    27 сен 2010
    Сообщения:
    78
    Симпатии:
    0
    Баллы:
    26
    Ситуация такая: В табличное поле вывожу дерево значений, появилась необходимость отправлять его на печать, столкнулся с проблемной не могу понять как программно выполнить пункт контекстного меню "ВЫВЕСТИ СПИСОК", заранее спасибо.
  2. Oleg_NSK
    Offline

    Oleg_NSK Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    164
    Симпатии:
    0
    Баллы:
    26
    Никак. Пишите функцию печати вручную.
  3. Oleg_NSK
    Offline

    Oleg_NSK Опытный в 1С

    Регистрация:
    25 окт 2010
    Сообщения:
    164
    Симпатии:
    0
    Баллы:
    26
    Этот код вставляй и будет счастье.
    Код:
    Перем ТабДок, Секция;
    
    Процедура ОсновныеДействияФормыПечать(Кнопка)
    ТабДок = Новый ТабличныйДокумент;
    Секция = ТабДок.ПолучитьОбласть("R1");
    ТабДок.НачатьАвтогруппировкуСтрок();
    ПечатьДерева (Дерево,,Дерево.Колонки);
    ТабДок.ЗакончитьАвтогруппировкуСтрок();
    ТабДок.Показать();
    КонецПроцедуры
    
    
    Процедура ПечатьДерева (СтрокаДерева,Уровень = 0,Колонки)
    Для Каждого стр Из СтрокаДерева.Строки Цикл
    НомерКолонки = 0;
    отступ = "";
    Для н = 1 По Уровень Цикл
    отступ = отступ + " ";
    КонецЦикла;
    Для Каждого КЛ Из Колонки Цикл
    НомерКолонки = НомерКолонки + 1;
    Секция.Область(1, НомерКолонки).Текст = ?(НомерКолонки = 1, отступ+стр[КЛ.Имя], стр[КЛ.Имя]);
    КонецЦикла;
    ТабДок.Вывести(Секция,Уровень+1);
    ПечатьДерева(стр,Уровень+1,Колонки);
    КонецЦикла;
    КонецПроцедуры
    

Поделиться этой страницей