8.х Вывести на макет штрихкод EAN13 и ITF14

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем fenlork, 14 дек 2015.

  1. TopicStarter Overlay
    fenlork
    Offline

    fenlork Опытный в 1С

    Регистрация:
    5 сен 2013
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Доброго времени суток!
    Подскажите настройки штрихкода в Свойствах компаненты 1С: Печать штрихкодов.
    Например у меня есть штрихкод EAN13-"4640019040060"- в 13 знаков(он уже забит в спр номенклатура"
    на коробку нужен штрихкод ITF14-"1"+"4640019040060"="14640019040060"-14 знаков на шаблоне, он обведен-при печати не изменился.
    Безымянный.png Безымянный.png
  2. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    Код вывода ШК в ТабДок покажите.
  3. TopicStarter Overlay
    fenlork
    Offline

    fenlork Опытный в 1С

    Регистрация:
    5 сен 2013
    Сообщения:
    71
    Симпатии:
    0
    Баллы:
    26
    Код:
    ЧислоКоробок=непроверка;
    Штрих=СтрокаИзСписка.Штрихкод;
    штрихкод="1"+штрих;
    Если РаботаСТорговымОборудованием.ТипШтрихкодаITF14ТО(штрихкод) тогда
                    РисунокШтрихкодКоробка.Объект.типкода = 11; 
                    РисунокШтрихкодКоробка.Объект.Сообщение = Штрихкод;
                    РисунокШтрихкодКоробка.Объект.ТекстКода = Штрихкод;
                    РисунокШтрихкодкоробка.Расположить(ОбластьШтрихкодКоробка);
    
                 
                    params.insert("ЦифрыШтрихкода", Штрихкод);
                    params.insert("ДатаОтгрузки", format(ЗаказПокупателя.ДатаОтгрузки, "ДФ=dd.MM.yyyy"));
    Этикеткакоробка.Параметры.Fill(params);
                        Для I=1 по числокоробок цикл
                           
                        Таб.Вывести(Этикеткакоробка); Таб.ВывестиГоризонтальныйРазделительСтраниц();
                        //I=I+1;
                    КонецЦикла;
                    КонецЕсли;
    //---------------------------------------------------------------------
    Поставила проверку штрихкода..не проходит проверку[DOUBLEPOST=1450094457][/DOUBLEPOST]Таб.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ЭтикеткаЛогистическая"+СокрЛП(ИмяКомпьютера());
          ЭтикеткаКоробка = ПолучитьМакет("МакетЭтикеткаПодушка").ПолучитьОбласть("ПодушкаКоробка|ЭтикеткаОбластьВерт");
            ОбластьШтрихкодКоробка         = ЭтикеткаКоробка.Области.ОбластьШтрихкодКоробка;
            РисунокШтрихкодкоробка         = ЭтикеткаКоробка.Рисунки.коробка;
            РисунокШтрихкодкоробка.Объект.ТипКода = 11;
    
          ЭтикеткаИзделие = ПолучитьМакет("МакетЭтикеткаПодушка").ПолучитьОбласть("ПодушкаИзделие|ЭтикеткаОбластьВерт");
            ОбластьШтрихкодизделие         = Этикеткаизделие.Области.ОбластьШтрихкодизделие;
            РисунокШтрихкодизделие         = Этикеткаизделие.Рисунки.изделие;
            РисунокШтрихкодкоробка.Объект.ТипКода = 1;
  4. nomad_irk
    Offline

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.581
    Симпатии:
    717
    Баллы:
    204
    Вот этот код для УПП 100% рабочий:

    Код:
    //Штрих-код
        ШтрихКод = <СтрокаШК>;
       
        ТипШтрихкода = ПланыВидовХарактеристик.ТипыШтрихкодов.Code128;
        ТипКода = УправлениеРозничнойТорговлей.ПолучитьЗначениеТипаШтрихкодаДляЭУ(ТипШтрихкода);
        Если ТипКода = -1 Тогда
            ОбщегоНазначения.СообщитьОбОшибке("Для штрихкода формата """ + ТипШтрихкода
            + """ не существует соответствующего типа в ЭУ ""1С:Печать штрихкодов"".
            | Позиция будет пропущена");
        КонецЕсли;
        Если РаботаСТорговымОборудованием.ПроверитьШтрихКод(ШтрихКод, ТипШтрихкода) Тогда
            Попытка
                ОбластьМакета.Рисунки.Штрихкод.Объект.ТипКода = ТипКода;
                ОбластьМакета.Рисунки.Штрихкод.Объект.Сообщение = ШтрихКод;
            Исключение
                Сообщить("Не установлена компонента 1С: Печать штрих-кодов", СтатусСообщения.Внимание);
            КонецПопытки;
        КонецЕсли;
    
    fenlork нравится это.
  5. LordMaverick
    Offline

    LordMaverick Профессионал в 1С

    Регистрация:
    17 мар 2014
    Сообщения:
    3.443
    Симпатии:
    375
    Баллы:
    104
    вообще-то ITF14 не будет как вот это "1"+"4640019040060"="14640019040060" :))
    а будет как "4640019040060"="x1464001904006k"
    где х - вариант
    а к - контрольное число предыдущих 13 символов, включая вариант


    http://www.gs1ru.org/services/bcguide/7/

Поделиться этой страницей