7.7 Вывести льготы у сотрудников

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем hays23, 18 ноя 2013.

  1. TopicStarter Overlay
    hays23
    Offline

    hays23

    Регистрация:
    13 авг 2012
    Сообщения:
    49
    Симпатии:
    0
    Баллы:
    1
    Добрый день форумчани! Нужна помощь ваша по 7.7 конф. "зарплата+кадры" для Украины. т.к. сам в 8.2 программирую, и с 7.7 первый раз работаю и тяжко дается..

    У нас есть сотрудники, у сотрудников есть льготы и их может быть несколько, нужно выбрать льготу одну по реквезиту ДатаНачалаДействия самое позднюю дату и по этой дате выбираем код.

    Код:
    ДБФ = СоздатьОбъект("XBASE");
    ДБФ.ДобавитьПоле("TabNomer","C",10,0);
    ДБФ.ДобавитьПоле("FIO","S",30,0);
    ДБФ.ДобавитьПоле("INN","N",12,0);
    ДБФ.ДобавитьПоле("BankSheta","N",20,0);
    ДБФ.ДобавитьПоле("lgotu","S",60,0);  //льготы
    ДБФ.КодоваяСтраница(0); // Windows
    ДБФ.СоздатьФайл("c:\export.dbf");
    Выборка = СоздатьОбъект("Справочник.Сотрудники");
    Выборка.ВыбратьЭлементы();
    Пока Выборка.ПолучитьЭлемент()=1 Цикл
    Если ПустоеЗначение(Выборка.ДатаОкончанияДействия) = 1 Тогда  //проверка уволен или нет
    ЛьготыСотр=Создатьобъект("Справочник.ЛьготыСотрудника");
    ЛьготыСотр.ИспользоватьВладельца(Выборка.ТекущийЭлемент());				
    ЛьготыСотр.ВыбратьЭлементы();  
    //вот тут бойда получается и не правильно, как правильно написать,Найти ДатаНачалаДействия самое поздее?
    Пока ЛьготыСотр.ПолучитьЭлемент() > 0 Цикл
    ЛьготыСотр.ОбратныйПорядок();
    ЛьготыСотр.ВыбратьЭлементыПоРеквизиту("ДатаНачалаДействия",,1,0);
    льготы=ЛьготыСотр.льготы.код;
    КонецЦикла;
    
    ДБФ.Добавить();
    ДБФ.TabNOmer=Выборка.код;
    ДБФ.FIO=Выборка.ФизическоеЛицо.Наименование;
    ДБФ.INN=Выборка.ФизическоеЛицо.ИНН;
    ДБФ.BankSheta=Выборка.СчетВБанке;
    ДБФ.lgotu= льготы; //  тут записываем КОД льготы
    
    ДБФ.Записать();
    КонецЕсли;
    КонецЦикла;
    
    ДБФ.ЗакрытьФайл();
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Самое верное выборкой циклом (как у вас) или запросом выгрузить в таблицу значений, отсортировать, результат выгрузить..
    Ну ли добавить условие на максимум. У вас уже почти готовый инструмент

Поделиться этой страницей