8.х Вывести комментарий во внешнюю печатную форму счета

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем Irbison, 24 сен 2013.

  1. TopicStarter Overlay
    Irbison
    Offline

    Irbison

    Регистрация:
    24 сен 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Добрый день, прошу оказать помощь в организации вывода комментария из формы счета на оплату покупателя
    1с предприятие 8.2 (8.2.18.61)
    конфигурация: БП 3.0 (3.0.24.9)

    В печатной форме поле вывел, но не могу сделать запрос на вывод комментария.

    Код:
    Код:
    ////////////////////////////////////////////////////////////////////////////////
    // ПРОГРАММНЫЙ ИНТЕРФЕЙС
    // Возвращает сведения о внешней обработке.
    Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.1.3.1");
    
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма();
    ПараметрыРегистрации.Версия = "1.0";
    ПараметрыРегистрации.БезопасныйРежим = Истина;
    ПараметрыРегистрации.Назначение.Добавить("Документ.СчетНаОплатуПокупателю");
    
    НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    НоваяКоманда.Представление = НСтр("ru = 'Счет на оплату внешний'");
    НоваяКоманда.Идентификатор = "СчетЗаказВн";
    НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    НоваяКоманда.ПоказыватьОповещение = Истина;
    НоваяКоманда.Модификатор = "ПечатьMXL";
    Возврат ПараметрыРегистрации;
    
    КонецФункции
    
    Процедура ВывестиЗаголовокПредупреждение(Организация, ТабличныйДокумент, Макет)
    
    Если Не ЗначениеЗаполнено(Макет.Области.Найти("ЗаголовокПредупреждениеСЛоготипом")) Тогда
    Возврат;
    КонецЕсли;
    
    ДанныеКартинки = РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаИДвоичныеДанные(Организация.ФайлЛоготип);
    Если ЗначениеЗаполнено(ДанныеКартинки.ДвоичныеДанные) Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокПредупреждениеСЛоготипом");
    Попытка
    ОбластьМакета.Рисунки.Логотип.Картинка = Новый Картинка(ДанныеКартинки.ДвоичныеДанные);
    Исключение
    КонецПопытки;
    ТабличныйДокумент.Вывести(ОбластьМакета);
    Иначе
    ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокПредупреждение");
    ТабличныйДокумент.Вывести(ОбластьМакета);
    КонецЕсли;
    КонецПроцедуры
    
    // Формирует и возвращает текст запроса для выборки данных,
    // необходимых для формирования печатной формы
    Функция ПолучитьТекстЗапросаДляФормированияПечатнойФормыСчетаНаОплатуПокупателю()
    
    ЧастьЗапросаДляВыбораСодержанияУслуг = ОбщегоНазначенияБПВызовСервера.ПолучитьЧастьЗапросаДляВыбораСодержанияУслуг("ЗаказПокупателя");
    
    ТекстЗапроса =
    "ВЫБРАТЬ
    | Реквизиты.Ссылка КАК Ссылка,
    | Реквизиты.Номер КАК Номер,
    | Реквизиты.Дата КАК Дата,
    | Реквизиты.ДоговорКонтрагента,
    | Реквизиты.Организация,
    | Реквизиты.ПодразделениеОрганизации,
    | Реквизиты.СтруктурнаяЕдиница,
    | Реквизиты.СтруктурнаяЕдиница.ТекстКорреспондента КАК ТекстКорреспондента,
    | Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов КАК БанкДляРасчетов,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Город
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК НаименованиеБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк
    | КОНЕЦ КАК БанкПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Код
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Код
    | КОНЕЦ КАК БикБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.КоррСчет
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.КоррСчет
    | КОНЕЦ КАК СчетБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Город
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК ГородБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.Банк.КоррСчет
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.НомерСчета
    | КОНЕЦ КАК НомерСчетаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА "" р/с "" + Реквизиты.СтруктурнаяЕдиница.НомерСчета + "" в "" + Реквизиты.СтруктурнаяЕдиница.Банк.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК БанкТекстКорресподента,
    | Реквизиты.Контрагент КАК Покупатель,
    | Реквизиты.Организация КАК Руководители,
    | Реквизиты.Организация КАК Поставщик,
    | Реквизиты.ОрганизацияПолучатель КАК Получатель,
    | Реквизиты.СуммаДокумента,
    | Реквизиты.ВалютаДокумента,
    | Реквизиты.СуммаВключаетНДС,
    | ЗаказПокупателя.Номенклатура КАК Номенклатура,
    | ЗаказПокупателя.Номенклатура.НаименованиеПолное КАК Товар,
    | ВЫБОР
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |   ТОГДА ЗаказПокупателя.Номенклатура.Артикул
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |   ТОГДА ЗаказПокупателя.Номенклатура.Код
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |   ТОГДА """"
    | КОНЕЦ КАК Артикул,
    | ЗаказПокупателя.Количество КАК Количество,
    | ЗаказПокупателя.Номенклатура.ЕдиницаИзмерения.Наименование КАК ЕдиницаИзмерения,
    | ЗаказПокупателя.Цена КАК Цена,
    | ЗаказПокупателя.Сумма КАК Сумма,
    | ЗаказПокупателя.СуммаНДС КАК СуммаНДС,
    | ЗаказПокупателя.НомерСтроки КАК НомерСтроки,
    | 1 КАК ID
    |ИЗ
    | Документ.СчетНаОплатуПокупателю КАК Реквизиты
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.СчетНаОплатуПокупателю.Товары КАК ЗаказПокупателя
    |  ПО (Реквизиты.Ссылка = ЗаказПокупателя.Ссылка)
    |ГДЕ
    | ЗаказПокупателя.Ссылка В(&МассивОбъектов)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    | Реквизиты.Ссылка,
    | Реквизиты.Номер,
    | Реквизиты.Дата,
    | Реквизиты.ДоговорКонтрагента,
    | Реквизиты.Организация,
    | Реквизиты.ПодразделениеОрганизации,
    | Реквизиты.СтруктурнаяЕдиница,
    | Реквизиты.СтруктурнаяЕдиница.ТекстКорреспондента КАК ТекстКорреспондента,
    | Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов КАК БанкДляРасчетов,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Город
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК НаименованиеБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк
    | КОНЕЦ КАК БанкПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Код
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Код
    | КОНЕЦ КАК БикБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.КоррСчет
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.КоррСчет
    | КОНЕЦ КАК СчетБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Город
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК ГородБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.Банк.КоррСчет
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.НомерСчета
    | КОНЕЦ КАК НомерСчетаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА "" р/с "" + Реквизиты.СтруктурнаяЕдиница.НомерСчета + "" в "" + Реквизиты.СтруктурнаяЕдиница.Банк.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК БанкТекстКорресподента,
    | Реквизиты.Контрагент,
    | Реквизиты.Организация,
    | Реквизиты.Организация,
    | Реквизиты.ОрганизацияПолучатель,
    | Реквизиты.СуммаДокумента,
    | Реквизиты.ВалютаДокумента,
    | Реквизиты.СуммаВключаетНДС,
    | "+ ЧастьЗапросаДляВыбораСодержанияУслуг +",
    | "+ ЧастьЗапросаДляВыбораСодержанияУслуг +",
    | ВЫБОР
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |   ТОГДА ЗаказПокупателя.Номенклатура.Артикул
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |   ТОГДА ЗаказПокупателя.Номенклатура.Код
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |   ТОГДА """"
    | КОНЕЦ,
    | ЗаказПокупателя.Количество,
    | ЗаказПокупателя.Номенклатура.ЕдиницаИзмерения.Наименование,
    | ЗаказПокупателя.Цена,
    | ЗаказПокупателя.Сумма,
    | ЗаказПокупателя.СуммаНДС,
    | ЗаказПокупателя.НомерСтроки,
    | 2
    |ИЗ
    | Документ.СчетНаОплатуПокупателю КАК Реквизиты
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.СчетНаОплатуПокупателю.Услуги КАК ЗаказПокупателя
    |  ПО (ЗаказПокупателя.Ссылка = Реквизиты.Ссылка)
    |ГДЕ
    | Реквизиты.Ссылка В(&МассивОбъектов)
    |
    |УПОРЯДОЧИТЬ ПО
    | Дата,
    | Ссылка,
    | ID,
    | НомерСтроки";
    Возврат ТекстЗапроса;
    КонецФункции
    
    Функция ПечатьДокумента(МассивОбъектов, ОбъектыПечати, СПечатью = Ложь)
    Перем ПодразделениеОтветственныхЛиц;
    
    УстановитьПривилегированныйРежим(Истина);
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.АвтоМасштаб   = Истина;
    ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ЗаказПокупателя_СчетЗаказВн";
    
    ДополнительнаяКолонкаПечатныхФормДокументов = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
    Если НЕ ЗначениеЗаполнено(ДополнительнаяКолонкаПечатныхФормДокументов) Тогда
    ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить;
    КонецЕсли;
    ВыводитьКоды = ДополнительнаяКолонкаПечатныхФормДокументов <> Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить;
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
    Запрос.УстановитьПараметр("ДополнительнаяКолонкаПечатныхФормДокументов", ДополнительнаяКолонкаПечатныхФормДокументов);
    Запрос.Текст = ПолучитьТекстЗапросаДляФормированияПечатнойФормыСчетаНаОплатуПокупателю();
    
    Шапка = Запрос.Выполнить().Выбрать();
    
    ПервыйДокумент = Истина;
    
    Пока Шапка.СледующийПоЗначениюПоля("Ссылка") Цикл
    
    //Макет = УправлениеПечатью.ПолучитьМакет("ПФ_MXL_СчетЗаказВн");
    Макет = ПолучитьМакет("ПФ_MXL_СчетЗаказВн");
    Если НЕ ПервыйДокумент Тогда
    ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЕсли;
    
    ПервыйДокумент = Ложь;
    
    // Запомним номер строки, с которой начали выводить текущий документ.
    НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;
    
    // Выводим шапку счета
    ВывестиЗаголовокПредупреждение(Шапка.Получатель, ТабличныйДокумент, Макет);
    СведенияОПолучателе = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Получатель, Шапка.Дата);
    ОбластьМакета	   = Макет.ПолучитьОбласть("ЗаголовокСчета");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    ОбластьМакета.Параметры.ИННПолучателя = СведенияОПолучателе.ИНН;
    ОбластьМакета.Параметры.КПППолучателя = СведенияОПолучателе.КПП;
    Если ТипЗнч(Шапка.СтруктурнаяЕдиница) = Тип("СправочникСсылка.БанковскиеСчета") Тогда
    ОбластьМакета.Параметры.БИКБанкаПолучателя			   = Шапка.БикБанкаПолучателя;
    ОбластьМакета.Параметры.БанкПолучателя				   = Шапка.БанкПолучателя;
    ОбластьМакета.Параметры.БанкПолучателяПредставление	  = СокрЛП(Шапка.НаименованиеБанкаПолучателя);
    ОбластьМакета.Параметры.СчетБанкаПолучателя			  = Шапка.СчетБанкаПолучателя;
    ОбластьМакета.Параметры.СчетБанкаПолучателяПредставление = Шапка.СчетБанкаПолучателя;
    ОбластьМакета.Параметры.СчетПолучателяПредставление	  = Шапка.НомерСчетаПолучателя;
    ОбластьМакета.Параметры.СчетПолучателя				   = Шапка.НомерСчетаПолучателя;
    КонецЕсли;
    
    ТекстКорреспондента = СведенияОПолучателе.НаименованиеДляПечатныхФорм;
    Если ЗначениеЗаполнено(Шапка.БанкДляРасчетов) Тогда
    ТекстКорреспондента = ТекстКорреспондента + Шапка.БанкТекстКорресподента;
    КонецЕсли;
    ОбластьМакета.Параметры.ПредставлениеПолучателя = ТекстКорреспондента;
    
    ТабличныйДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
    ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначенияБПВызовСервера.СформироватьЗаголовокДокумента(Шапка, "Счет на оплату");
    
    ТабличныйДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("Поставщик");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    СведенияОбОрганизации	= БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата);
    ОбластьМакета.Параметры.ПредставлениеПоставщика = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(
    СведенияОбОрганизации, "НаименованиеДляПечатныхФорм,ИНН,КПП,ЮридическийАдрес,Телефоны,");
    ТабличныйДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    СведенияОПокупателе	 = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Покупатель, Шапка.Дата);
    ОбластьМакета.Параметры.ПредставлениеПокупателя = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(
    СведенияОПокупателе, "НаименованиеДляПечатныхФорм,ИНН,КПП,ЮридическийАдрес,Телефоны,");
    
    [color=#ff0000]ОбластьМакета = Макет.ПолучитьОбласть("Комментарий");
    ОбластьМакета.Объект.Комментарий = ОбщегоНазначенияБПВызовСервера.Комментарий;[/color]
    
    ТабличныйДокумент.Вывести(ОбластьМакета);
    ОбластьНомера = Макет.ПолучитьОбласть("ШапкаТаблицы|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("ШапкаТаблицы|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("ШапкаТаблицы|Данные");
    ОбластьСуммы  = Макет.ПолучитьОбласть("ШапкаТаблицы|Сумма");
    ТабличныйДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    Если ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
    ОбластьКодов.Параметры.ИмяКолонкиКодов = "Артикул";
    ИначеЕсли ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Код Тогда
    ОбластьКодов.Параметры.ИмяКолонкиКодов = "Код";
    КонецЕсли;
    ТабличныйДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    ТабличныйДокумент.Присоединить(ОбластьДанных);
    ТабличныйДокумент.Присоединить(ОбластьСуммы);
    ОбластьКолонкаТовар = Макет.Область("Товар");
    Если Не ВыводитьКоды Тогда
    ОбластьКолонкаТовар.ШиринаКолонки = ОбластьКолонкаТовар.ШиринаКолонки + Макет.Область("КолонкаКодов").ШиринаКолонки;
    КонецЕсли;
    ОбластьНомера = Макет.ПолучитьОбласть("Строка|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("Строка|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("Строка|Данные");
    ОбластьСуммы  = Макет.ПолучитьОбласть("Строка|Сумма");
    Сумма	= 0;
    СуммаНДС = 0;
    ВсегоСкидок	= 0;
    ВсегоБезСкидок = 0;
    НомерСтроки	= 0;
    
    Пока Шапка.Следующий() Цикл
    
    Если НЕ ЗначениеЗаполнено(Шапка.Сумма) Тогда
    Продолжить;
    КонецЕсли;
    
    НомерСтроки = НомерСтроки + 1;
    ОбластьНомера.Параметры.НомерСтроки = НомерСтроки;
    ТабличныйДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ОбластьКодов.Параметры.Заполнить(Шапка);
    ТабличныйДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    
    ОбластьДанных.Параметры.Товар			= СокрЛП(Шапка.Товар);
    ОбластьДанных.Параметры.Количество	   = Шапка.Количество;
    ОбластьДанных.Параметры.ЕдиницаИзмерения = Шапка.ЕдиницаИзмерения;
    ОбластьДанных.Параметры.Цена			 = Шапка.Цена;
    
    ТабличныйДокумент.Присоединить(ОбластьДанных);
    
    ОбластьСуммы.Параметры.Сумма = Шапка.Сумма;
    
    ТабличныйДокумент.Присоединить(ОбластьСуммы);
    Сумма	= Сумма	+ Шапка.Сумма;
    СуммаНДС = СуммаНДС + Шапка.СуммаНДС;
    
    КонецЦикла;
    
    // Вывести Итого
    ОбластьНомера = Макет.ПолучитьОбласть("Итого|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("Итого|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("Итого|Данные");
    ОбластьСуммы  = Макет.ПолучитьОбласть("Итого|Сумма");
    ТабличныйДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ТабличныйДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    ТабличныйДокумент.Присоединить(ОбластьДанных);
    ОбластьСуммы.Параметры.Всего = ОбщегоНазначенияБПВызовСервера.ФорматСумм(Сумма);
    ТабличныйДокумент.Присоединить(ОбластьСуммы);
    // Вывести ИтогоНДС
    ОбластьНомера = Макет.ПолучитьОбласть("ИтогоНДС|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("ИтогоНДС|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("ИтогоНДС|Данные");
    ОбластьСуммы  = Макет.ПолучитьОбласть("ИтогоНДС|Сумма");
    
    ТабличныйДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ТабличныйДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    Если СуммаНДС <> 0 Тогда
    ОбластьДанных.Параметры.НДС	 = ?(Шапка.СуммаВключаетНДС, "В том числе НДС:", "Сумма НДС:");
    ОбластьСуммы.Параметры.ВсегоНДС = ОбщегоНазначенияБПВызовСервера.ФорматСумм(СуммаНДС);
    Иначе
    ОбластьДанных.Параметры.НДС	 = "Без налога (НДС)";
    ОбластьСуммы.Параметры.ВсегоНДС = "-";
    КонецЕсли;
    ТабличныйДокумент.Присоединить(ОбластьДанных);
    
    ТабличныйДокумент.Присоединить(ОбластьСуммы);
    
    // Вывести ИтогоКОплате
    ОбластьНомера = Макет.ПолучитьОбласть("ИтогоКОплате|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("ИтогоКОплате|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("ИтогоКОплате|Данные");
    ОбластьСуммы  = Макет.ПолучитьОбласть("ИтогоКОплате|Сумма");
    ТабличныйДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ТабличныйДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    ТабличныйДокумент.Присоединить(ОбластьДанных);
    СуммаКОплате = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
    ОбластьСуммы.Параметры.ИтогоКОплате = ОбщегоНазначенияБПВызовСервера.ФорматСумм(СуммаКОплате);
    ТабличныйДокумент.Присоединить(ОбластьСуммы);
    
    // Вывести Сумму прописью
    ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью");
    СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
    ОбластьМакета.Параметры.ИтоговаяСтрока ="Всего наименований " + НомерСтроки
    + ", на сумму " + ОбщегоНазначенияБПВызовСервера.ФорматСумм(СуммаКПрописи, Шапка.ВалютаДокумента);
    ОбластьМакета.Параметры.СуммаПрописью = ОбщегоНазначенияБПВызовСервера.СформироватьСуммуПрописью(СуммаКПрописи, Шапка.ВалютаДокумента);
    ТабличныйДокумент.Вывести(ОбластьМакета);
    // Вывести подписи
    Если СПечатью Тогда
    ДанныеКартинки = РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаИДвоичныеДанные(Шапка.Получатель.ФайлФаксимильнаяПечать);
    Если ЗначениеЗаполнено(ДанныеКартинки) Тогда
    ДанныеКартинки = ДанныеКартинки.ДвоичныеДанные;
    КонецЕсли;
    Иначе
    ДанныеКартинки = Неопределено;
    КонецЕсли;
    
    Если ЗначениеЗаполнено(ДанныеКартинки)
    И ЗначениеЗаполнено(Макет.Области.Найти("ПодвалСчетаСФаксимильнойПечатью")) Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("ПодвалСчетаСФаксимильнойПечатью");
    ОбластьМакета.Рисунки.ФаксимильнаяПечать.Картинка = Новый Картинка(ДанныеКартинки);
    Иначе
    Если ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Шапка.Получатель, "ЮридическоеФизическоеЛицо")
    = Перечисления.ЮридическоеФизическоеЛицо.ЮридическоеЛицо Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("ПодвалСчета");
    
    ПодразделениеОтветственныхЛиц = Шапка.ПодразделениеОрганизации;
    
    Руководители = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Организация, Шапка.Дата, ПодразделениеОтветственныхЛиц);
    Руководитель = Руководители.РуководительПредставление;
    Бухгалтер	= Руководители.ГлавныйБухгалтерПредставление;
    
    ОбластьМакета.Параметры.ФИОРуководителя = Руководитель;
    ОбластьМакета.Параметры.ФИОБухгалтера   = Бухгалтер;
    
    Иначе
    ОбластьМакета = Макет.ПолучитьОбласть("ПодвалСчетаПредприниматель");
    
    ФЛ = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Шапка.Получатель, "ИндивидуальныйПредприниматель");
    ДанныеФЛ = РегистрыСведений.ФИОФизическихЛиц.СрезПоследних(Шапка.Дата, Новый Структура("ФизическоеЛицо",ФЛ));
    Если ДанныеФЛ.Количество() > 0 Тогда
    Предприниматель = СокрЛП(ДанныеФЛ[0].Фамилия) + " " + Лев(СокрЛП(ДанныеФЛ[0].Имя),1) + ". " + Лев(СокрЛП(ДанныеФЛ[0].Отчество),1) + ".";
    Иначе
    Предприниматель = "";
    КонецЕсли;
    
    ОбластьМакета.Параметры.ФИОПредпринимателя = Предприниматель;
    
    КонецЕсли;
    КонецЕсли;
    ОбластьМакета.Параметры.Заполнить(Шапка);
    ТабличныйДокумент.Вывести(ОбластьМакета);
    
    // В табличном документе зададим имя области, в которую был
    // выведен объект. Нужно для возможности печати покомплектно.
    УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент,
    НомерСтрокиНачало, ОбъектыПечати, Шапка.Ссылка);
    КонецЦикла;
    Возврат ТабличныйДокумент;
    КонецФункции
    
    // Интерфейс для выполнения команд обработки.
    Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "СчетЗаказВн") Тогда
    
    ТабличныйДокумент = ПечатьДокумента(МассивОбъектов, ОбъектыПечати);
    
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
    КоллекцияПечатныхФорм,
    "СчетЗаказВн",
    НСтр("ru = 'Счет на оплату'"),
    ТабличныйДокумент,
    ,
    "ПФ_MXL_СчетЗаказВн"
    );
    КонецЕсли;
    
    
    КонецПроцедуры
    ////////////////////////////////////////////////////////////////////////////////
    // СЛУЖЕБНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ
    

    Вложения:

    • comment.JPG
      comment.JPG
      Размер файла:
      91,3 КБ
      Просмотров:
      100
  2. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Что значит строка в Вашем коде??
    Код:
    ОбластьМакета.Объект.Комментарий = ОбщегоНазначенияБПВызовСервера.Комментарий;
    не хватает строки:
    Код:
    ОбластьМакета.Параметры.Комментарий = ВашЗапрос.Комментарий;///может Шапка.Комментарий... В запросе добавить поле "Комментарий"
  3. Dmitriy_76
    Offline

    Dmitriy_76 Опытный в 1С Команда форума

    Регистрация:
    26 мар 2011
    Сообщения:
    2.175
    Симпатии:
    13
    Баллы:
    29
    а в запросе комментария нет ... так что Шапка.ссылка.комментарий ...
  4. Дмитрий Игоревич
    Offline

    Дмитрий Игоревич Опытный в 1С

    Регистрация:
    11 апр 2013
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    ОбластьМакета.Объект.Комментарий = ЭлементыФормы.Комментарий.Значение;
  5. TopicStarter Overlay
    Irbison
    Offline

    Irbison

    Регистрация:
    24 сен 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    к сожалению вот эту часть и не могу победить, не могу написать запрос на ввывод комментария в форму счета
  6. Дмитрий Игоревич
    Offline

    Дмитрий Игоревич Опытный в 1С

    Регистрация:
    11 апр 2013
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    а где этот комментарий находится?
  7. TopicStarter Overlay
    Irbison
    Offline

    Irbison

    Регистрация:
    24 сен 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    заменил
    Код:
    ОбластьМакета.Объект.Комментарий = ОбщегоНазначенияБПВызовСервера.Комментарий;
    на
    выдает ошибку при установке обработки (см.вложение)

    Вложения:

    • error.JPG
      error.JPG
      Размер файла:
      22 КБ
      Просмотров:
      58
  8. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Вам же написали (см. пост #3)...
    Код:
    ОбластьМакета.Параметры.Комментарий = Шапка.ссылка.комментарий
  9. Дмитрий Игоревич
    Offline

    Дмитрий Игоревич Опытный в 1С

    Регистрация:
    11 апр 2013
    Сообщения:
    152
    Симпатии:
    0
    Баллы:
    26
    написали же короче Пиши как в посте три ставь останову и смотри что выдает в отладчике
  10. TopicStarter Overlay
    Irbison
    Offline

    Irbison

    Регистрация:
    24 сен 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    при подаче счета на печать, выпадает ошибка "Поле объекта не обнаружено(Объект)"
    возможно ошибка тут (см.вложение)
    сам код вот такой
    Код:
    ОбластьМакета = Макет.ПолучитьОбласть("Комментарий");
    ОбластьМакета.Объект.Комментарий = Шапка.Ссылка.Комментарий;
    

    Вложения:

    • 2.JPG
      2.JPG
      Размер файла:
      134,3 КБ
      Просмотров:
      74
  11. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    ОбластьМакета.Объект.Комментарий = Шапка.Ссылка.Комментарий;
    замените строкой:
    Код:
    ОбластьМакета.Параметры.Комментарий = Шапка.Ссылка.Комментарий;
  12. TopicStarter Overlay
    Irbison
    Offline

    Irbison

    Регистрация:
    24 сен 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Всем большое спасибо за потраченное время. Все заработало.
  13. TopicStarter Overlay
    Irbison
    Offline

    Irbison

    Регистрация:
    24 сен 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Дико извиняюсь, раньше времени обрадовался, почему то исчезло поле "Покупатель"
  14. TopicStarter Overlay
    Irbison
    Offline

    Irbison

    Регистрация:
    24 сен 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Возможно поле исчезло из-за Шапка.Ссылка.
  15. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    нет... что-то лишнее удалили... Покажите код, который получился...
  16. TopicStarter Overlay
    Irbison
    Offline

    Irbison

    Регистрация:
    24 сен 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    Вот код
    Код:
    ////////////////////////////////////////////////////////////////////////////////
    // ПРОГРАММНЫЙ ИНТЕРФЕЙС
    // Возвращает сведения о внешней обработке.
    Функция СведенияОВнешнейОбработке() Экспорт
    
    ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("2.1.3.1");
    
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиПечатнаяФорма();
    ПараметрыРегистрации.Версия = "1.0";
    ПараметрыРегистрации.БезопасныйРежим = Истина;
    ПараметрыРегистрации.Назначение.Добавить("Документ.СчетНаОплатуПокупателю");
    
    НоваяКоманда = ПараметрыРегистрации.Команды.Добавить();
    НоваяКоманда.Представление = НСтр("ru = 'Счет на оплату внешний'");
    НоваяКоманда.Идентификатор = "СчетЗаказВн";
    НоваяКоманда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыВызовСерверногоМетода();
    НоваяКоманда.ПоказыватьОповещение = Истина;
    НоваяКоманда.Модификатор = "ПечатьMXL";
    Возврат ПараметрыРегистрации;
    
    КонецФункции
    
    Процедура ВывестиЗаголовокПредупреждение(Организация, ТабличныйДокумент, Макет)
    
    Если Не ЗначениеЗаполнено(Макет.Области.Найти("ЗаголовокПредупреждениеСЛоготипом")) Тогда
    Возврат;
    КонецЕсли;
    
    ДанныеКартинки = РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаИДвоичныеДанные(Организация.ФайлЛоготип);
    Если ЗначениеЗаполнено(ДанныеКартинки.ДвоичныеДанные) Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокПредупреждениеСЛоготипом");
    Попытка
    ОбластьМакета.Рисунки.Логотип.Картинка = Новый Картинка(ДанныеКартинки.ДвоичныеДанные);
    Исключение
    КонецПопытки;
    ТабличныйДокумент.Вывести(ОбластьМакета);
    Иначе
    ОбластьМакета = Макет.ПолучитьОбласть("ЗаголовокПредупреждение");
    ТабличныйДокумент.Вывести(ОбластьМакета);
    КонецЕсли;
    КонецПроцедуры
    
    // Формирует и возвращает текст запроса для выборки данных,
    // необходимых для формирования печатной формы
    Функция ПолучитьТекстЗапросаДляФормированияПечатнойФормыСчетаНаОплатуПокупателю()
    
    ЧастьЗапросаДляВыбораСодержанияУслуг = ОбщегоНазначенияБПВызовСервера.ПолучитьЧастьЗапросаДляВыбораСодержанияУслуг("ЗаказПокупателя");
    
    ТекстЗапроса =
    "ВЫБРАТЬ
    | Реквизиты.Ссылка КАК Ссылка,
    | Реквизиты.Номер КАК Номер,
    | Реквизиты.Дата КАК Дата,
    | Реквизиты.ДоговорКонтрагента,
    | Реквизиты.Организация,
    | Реквизиты.ПодразделениеОрганизации,
    | Реквизиты.СтруктурнаяЕдиница,
    | Реквизиты.СтруктурнаяЕдиница.ТекстКорреспондента КАК ТекстКорреспондента,
    | Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов КАК БанкДляРасчетов,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Город
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК НаименованиеБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк
    | КОНЕЦ КАК БанкПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Код
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Код
    | КОНЕЦ КАК БикБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.КоррСчет
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.КоррСчет
    | КОНЕЦ КАК СчетБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Город
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК ГородБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.Банк.КоррСчет
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.НомерСчета
    | КОНЕЦ КАК НомерСчетаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА "" р/с "" + Реквизиты.СтруктурнаяЕдиница.НомерСчета + "" в "" + Реквизиты.СтруктурнаяЕдиница.Банк.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК БанкТекстКорресподента,
    | Реквизиты.Контрагент КАК Покупатель,
    | Реквизиты.Организация КАК Руководители,
    | Реквизиты.Организация КАК Поставщик,
    | Реквизиты.ОрганизацияПолучатель КАК Получатель,
    | Реквизиты.СуммаДокумента,
    | Реквизиты.ВалютаДокумента,
    | Реквизиты.СуммаВключаетНДС,
    | ЗаказПокупателя.Номенклатура КАК Номенклатура,
    | ЗаказПокупателя.Номенклатура.НаименованиеПолное КАК Товар,
    | ВЫБОР
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |   ТОГДА ЗаказПокупателя.Номенклатура.Артикул
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |   ТОГДА ЗаказПокупателя.Номенклатура.Код
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |   ТОГДА """"
    | КОНЕЦ КАК Артикул,
    | ЗаказПокупателя.Количество КАК Количество,
    | ЗаказПокупателя.Номенклатура.ЕдиницаИзмерения.Наименование КАК ЕдиницаИзмерения,
    | ЗаказПокупателя.Цена КАК Цена,
    | ЗаказПокупателя.Сумма КАК Сумма,
    | ЗаказПокупателя.СуммаНДС КАК СуммаНДС,
    | ЗаказПокупателя.НомерСтроки КАК НомерСтроки,
    | 1 КАК ID
    |ИЗ
    | Документ.СчетНаОплатуПокупателю КАК Реквизиты
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.СчетНаОплатуПокупателю.Товары КАК ЗаказПокупателя
    |  ПО (Реквизиты.Ссылка = ЗаказПокупателя.Ссылка)
    |ГДЕ
    | ЗаказПокупателя.Ссылка В(&МассивОбъектов)
    |
    |ОБЪЕДИНИТЬ ВСЕ
    |
    |ВЫБРАТЬ
    | Реквизиты.Ссылка,
    | Реквизиты.Номер,
    | Реквизиты.Дата,
    | Реквизиты.ДоговорКонтрагента,
    | Реквизиты.Организация,
    | Реквизиты.ПодразделениеОрганизации,
    | Реквизиты.СтруктурнаяЕдиница,
    | Реквизиты.СтруктурнаяЕдиница.ТекстКорреспондента КАК ТекстКорреспондента,
    | Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов КАК БанкДляРасчетов,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Город
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК НаименованиеБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк
    | КОНЕЦ КАК БанкПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Код
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Код
    | КОНЕЦ КАК БикБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.КоррСчет
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.КоррСчет
    | КОНЕЦ КАК СчетБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов.Город
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК ГородБанкаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА Реквизиты.СтруктурнаяЕдиница.Банк.КоррСчет
    |  ИНАЧЕ Реквизиты.СтруктурнаяЕдиница.НомерСчета
    | КОНЕЦ КАК НомерСчетаПолучателя,
    | ВЫБОР
    |  КОГДА Реквизиты.СтруктурнаяЕдиница.БанкДляРасчетов <> ЗНАЧЕНИЕ(Справочник.Банки.ПустаяСсылка)
    |   ТОГДА "" р/с "" + Реквизиты.СтруктурнаяЕдиница.НомерСчета + "" в "" + Реквизиты.СтруктурнаяЕдиница.Банк.Наименование + "" "" + Реквизиты.СтруктурнаяЕдиница.Банк.Город
    | КОНЕЦ КАК БанкТекстКорресподента,
    | Реквизиты.Контрагент,
    | Реквизиты.Организация,
    | Реквизиты.Организация,
    | Реквизиты.ОрганизацияПолучатель,
    | Реквизиты.СуммаДокумента,
    | Реквизиты.ВалютаДокумента,
    | Реквизиты.СуммаВключаетНДС,
    | "+ ЧастьЗапросаДляВыбораСодержанияУслуг +",
    | "+ ЧастьЗапросаДляВыбораСодержанияУслуг +",
    | ВЫБОР
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул)
    |   ТОГДА ЗаказПокупателя.Номенклатура.Артикул
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.Код)
    |   ТОГДА ЗаказПокупателя.Номенклатура.Код
    |  КОГДА &ДополнительнаяКолонкаПечатныхФормДокументов = ЗНАЧЕНИЕ(Перечисление.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить)
    |   ТОГДА """"
    | КОНЕЦ,
    | ЗаказПокупателя.Количество,
    | ЗаказПокупателя.Номенклатура.ЕдиницаИзмерения.Наименование,
    | ЗаказПокупателя.Цена,
    | ЗаказПокупателя.Сумма,
    | ЗаказПокупателя.СуммаНДС,
    | ЗаказПокупателя.НомерСтроки,
    | 2
    |ИЗ
    | Документ.СчетНаОплатуПокупателю КАК Реквизиты
    |  ЛЕВОЕ СОЕДИНЕНИЕ Документ.СчетНаОплатуПокупателю.Услуги КАК ЗаказПокупателя
    |  ПО (ЗаказПокупателя.Ссылка = Реквизиты.Ссылка)
    |ГДЕ
    | Реквизиты.Ссылка В(&МассивОбъектов)
    |
    |УПОРЯДОЧИТЬ ПО
    | Дата,
    | Ссылка,
    | ID,
    | НомерСтроки";
    Возврат ТекстЗапроса;
    КонецФункции
    
    Функция ПечатьДокумента(МассивОбъектов, ОбъектыПечати, СПечатью = Ложь)
    Перем ПодразделениеОтветственныхЛиц;
    
    УстановитьПривилегированныйРежим(Истина);
    
    ТабличныйДокумент = Новый ТабличныйДокумент;
    ТабличныйДокумент.АвтоМасштаб   = Истина;
    ТабличныйДокумент.ОриентацияСтраницы = ОриентацияСтраницы.Портрет;
    ТабличныйДокумент.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_ЗаказПокупателя_СчетЗаказВн";
    
    ДополнительнаяКолонкаПечатныхФормДокументов = Константы.ДополнительнаяКолонкаПечатныхФормДокументов.Получить();
    Если НЕ ЗначениеЗаполнено(ДополнительнаяКолонкаПечатныхФормДокументов) Тогда
    ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить;
    КонецЕсли;
    ВыводитьКоды = ДополнительнаяКолонкаПечатныхФормДокументов <> Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.НеВыводить;
    
    Запрос = Новый Запрос;
    Запрос.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
    Запрос.УстановитьПараметр("ДополнительнаяКолонкаПечатныхФормДокументов", ДополнительнаяКолонкаПечатныхФормДокументов);
    Запрос.Текст = ПолучитьТекстЗапросаДляФормированияПечатнойФормыСчетаНаОплатуПокупателю();
    
    Шапка = Запрос.Выполнить().Выбрать();
    
    ПервыйДокумент = Истина;
    
    Пока Шапка.СледующийПоЗначениюПоля("Ссылка") Цикл
    
    //Макет = УправлениеПечатью.ПолучитьМакет("ПФ_MXL_СчетЗаказВн");
    Макет = ПолучитьМакет("ПФ_MXL_СчетЗаказВн");
    Если НЕ ПервыйДокумент Тогда
    ТабличныйДокумент.ВывестиГоризонтальныйРазделительСтраниц();
    КонецЕсли;
    
    ПервыйДокумент = Ложь;
    
    // Запомним номер строки, с которой начали выводить текущий документ.
    НомерСтрокиНачало = ТабличныйДокумент.ВысотаТаблицы + 1;
    
    // Выводим шапку счета
    ВывестиЗаголовокПредупреждение(Шапка.Получатель, ТабличныйДокумент, Макет);
    СведенияОПолучателе = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Получатель, Шапка.Дата);
    ОбластьМакета	   = Макет.ПолучитьОбласть("ЗаголовокСчета");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    ОбластьМакета.Параметры.ИННПолучателя = СведенияОПолучателе.ИНН;
    ОбластьМакета.Параметры.КПППолучателя = СведенияОПолучателе.КПП;
    Если ТипЗнч(Шапка.СтруктурнаяЕдиница) = Тип("СправочникСсылка.БанковскиеСчета") Тогда
    ОбластьМакета.Параметры.БИКБанкаПолучателя			   = Шапка.БикБанкаПолучателя;
    ОбластьМакета.Параметры.БанкПолучателя				   = Шапка.БанкПолучателя;
    ОбластьМакета.Параметры.БанкПолучателяПредставление	  = СокрЛП(Шапка.НаименованиеБанкаПолучателя);
    ОбластьМакета.Параметры.СчетБанкаПолучателя			  = Шапка.СчетБанкаПолучателя;
    ОбластьМакета.Параметры.СчетБанкаПолучателяПредставление = Шапка.СчетБанкаПолучателя;
    ОбластьМакета.Параметры.СчетПолучателяПредставление	  = Шапка.НомерСчетаПолучателя;
    ОбластьМакета.Параметры.СчетПолучателя				   = Шапка.НомерСчетаПолучателя;
    КонецЕсли;
    
    ТекстКорреспондента = СведенияОПолучателе.НаименованиеДляПечатныхФорм;
    Если ЗначениеЗаполнено(Шапка.БанкДляРасчетов) Тогда
    ТекстКорреспондента = ТекстКорреспондента + Шапка.БанкТекстКорресподента;
    КонецЕсли;
    ОбластьМакета.Параметры.ПредставлениеПолучателя = ТекстКорреспондента;
    
    ТабличныйДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("Заголовок");
    ОбластьМакета.Параметры.ТекстЗаголовка = ОбщегоНазначенияБПВызовСервера.СформироватьЗаголовокДокумента(Шапка, "Счет на оплату");
    
    ТабличныйДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("Поставщик");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    СведенияОбОрганизации	= БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Организация, Шапка.Дата);
    ОбластьМакета.Параметры.ПредставлениеПоставщика = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(
    СведенияОбОрганизации, "НаименованиеДляПечатныхФорм,ИНН,КПП,ЮридическийАдрес,Телефоны,");
    ТабличныйДокумент.Вывести(ОбластьМакета);
    ОбластьМакета = Макет.ПолучитьОбласть("Покупатель");
    ОбластьМакета.Параметры.Заполнить(Шапка);
    СведенияОПокупателе	 = БухгалтерскийУчетПереопределяемый.СведенияОЮрФизЛице(Шапка.Покупатель, Шапка.Дата);
    ОбластьМакета.Параметры.ПредставлениеПокупателя = ОбщегоНазначенияБПВызовСервера.ОписаниеОрганизации(
    СведенияОПокупателе, "НаименованиеДляПечатныхФорм,ИНН,КПП,ЮридическийАдрес,Телефоны,");
    
    ОбластьМакета = Макет.ПолучитьОбласть("Комментарий");
    ОбластьМакета.Параметры.Комментарий = Шапка.Ссылка.Комментарий;
    
    ТабличныйДокумент.Вывести(ОбластьМакета);
    ОбластьНомера = Макет.ПолучитьОбласть("ШапкаТаблицы|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("ШапкаТаблицы|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("ШапкаТаблицы|Данные");
    ОбластьСуммы  = Макет.ПолучитьОбласть("ШапкаТаблицы|Сумма");
    ТабличныйДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    Если ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Артикул Тогда
    ОбластьКодов.Параметры.ИмяКолонкиКодов = "Артикул";
    ИначеЕсли ДополнительнаяКолонкаПечатныхФормДокументов = Перечисления.ДополнительнаяКолонкаПечатныхФормДокументов.Код Тогда
    ОбластьКодов.Параметры.ИмяКолонкиКодов = "Код";
    КонецЕсли;
    ТабличныйДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    ТабличныйДокумент.Присоединить(ОбластьДанных);
    ТабличныйДокумент.Присоединить(ОбластьСуммы);
    ОбластьКолонкаТовар = Макет.Область("Товар");
    Если Не ВыводитьКоды Тогда
    ОбластьКолонкаТовар.ШиринаКолонки = ОбластьКолонкаТовар.ШиринаКолонки + Макет.Область("КолонкаКодов").ШиринаКолонки;
    КонецЕсли;
    ОбластьНомера = Макет.ПолучитьОбласть("Строка|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("Строка|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("Строка|Данные");
    ОбластьСуммы  = Макет.ПолучитьОбласть("Строка|Сумма");
    Сумма	= 0;
    СуммаНДС = 0;
    ВсегоСкидок	= 0;
    ВсегоБезСкидок = 0;
    НомерСтроки	= 0;
    
    Пока Шапка.Следующий() Цикл
    
    Если НЕ ЗначениеЗаполнено(Шапка.Сумма) Тогда
    Продолжить;
    КонецЕсли;
    
    НомерСтроки = НомерСтроки + 1;
    ОбластьНомера.Параметры.НомерСтроки = НомерСтроки;
    ТабличныйДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ОбластьКодов.Параметры.Заполнить(Шапка);
    ТабличныйДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    
    ОбластьДанных.Параметры.Товар			= СокрЛП(Шапка.Товар);
    ОбластьДанных.Параметры.Количество	   = Шапка.Количество;
    ОбластьДанных.Параметры.ЕдиницаИзмерения = Шапка.ЕдиницаИзмерения;
    ОбластьДанных.Параметры.Цена			 = Шапка.Цена;
    
    ТабличныйДокумент.Присоединить(ОбластьДанных);
    
    ОбластьСуммы.Параметры.Сумма = Шапка.Сумма;
    
    ТабличныйДокумент.Присоединить(ОбластьСуммы);
    Сумма	= Сумма	+ Шапка.Сумма;
    СуммаНДС = СуммаНДС + Шапка.СуммаНДС;
    
    КонецЦикла;
    
    // Вывести Итого
    ОбластьНомера = Макет.ПолучитьОбласть("Итого|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("Итого|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("Итого|Данные");
    ОбластьСуммы  = Макет.ПолучитьОбласть("Итого|Сумма");
    ТабличныйДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ТабличныйДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    ТабличныйДокумент.Присоединить(ОбластьДанных);
    ОбластьСуммы.Параметры.Всего = ОбщегоНазначенияБПВызовСервера.ФорматСумм(Сумма);
    ТабличныйДокумент.Присоединить(ОбластьСуммы);
    // Вывести ИтогоНДС
    ОбластьНомера = Макет.ПолучитьОбласть("ИтогоНДС|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("ИтогоНДС|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("ИтогоНДС|Данные");
    ОбластьСуммы  = Макет.ПолучитьОбласть("ИтогоНДС|Сумма");
    
    ТабличныйДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ТабличныйДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    Если СуммаНДС <> 0 Тогда
    ОбластьДанных.Параметры.НДС	 = ?(Шапка.СуммаВключаетНДС, "В том числе НДС:", "Сумма НДС:");
    ОбластьСуммы.Параметры.ВсегоНДС = ОбщегоНазначенияБПВызовСервера.ФорматСумм(СуммаНДС);
    Иначе
    ОбластьДанных.Параметры.НДС	 = "Без налога (НДС)";
    ОбластьСуммы.Параметры.ВсегоНДС = "-";
    КонецЕсли;
    ТабличныйДокумент.Присоединить(ОбластьДанных);
    
    ТабличныйДокумент.Присоединить(ОбластьСуммы);
    
    // Вывести ИтогоКОплате
    ОбластьНомера = Макет.ПолучитьОбласть("ИтогоКОплате|НомерСтроки");
    ОбластьКодов  = Макет.ПолучитьОбласть("ИтогоКОплате|КолонкаКодов");
    ОбластьДанных = Макет.ПолучитьОбласть("ИтогоКОплате|Данные");
    ОбластьСуммы  = Макет.ПолучитьОбласть("ИтогоКОплате|Сумма");
    ТабличныйДокумент.Вывести(ОбластьНомера);
    Если ВыводитьКоды Тогда
    ТабличныйДокумент.Присоединить(ОбластьКодов);
    КонецЕсли;
    ТабличныйДокумент.Присоединить(ОбластьДанных);
    СуммаКОплате = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
    ОбластьСуммы.Параметры.ИтогоКОплате = ОбщегоНазначенияБПВызовСервера.ФорматСумм(СуммаКОплате);
    ТабличныйДокумент.Присоединить(ОбластьСуммы);
    
    // Вывести Сумму прописью
    ОбластьМакета = Макет.ПолучитьОбласть("СуммаПрописью");
    СуммаКПрописи = Сумма + ?(Шапка.СуммаВключаетНДС, 0, СуммаНДС);
    ОбластьМакета.Параметры.ИтоговаяСтрока ="Всего наименований " + НомерСтроки
    + ", на сумму " + ОбщегоНазначенияБПВызовСервера.ФорматСумм(СуммаКПрописи, Шапка.ВалютаДокумента);
    ОбластьМакета.Параметры.СуммаПрописью = ОбщегоНазначенияБПВызовСервера.СформироватьСуммуПрописью(СуммаКПрописи, Шапка.ВалютаДокумента);
    ТабличныйДокумент.Вывести(ОбластьМакета);
    // Вывести подписи
    Если СПечатью Тогда
    ДанныеКартинки = РаботаСФайламиСлужебныйВызовСервера.ПолучитьДанныеФайлаИДвоичныеДанные(Шапка.Получатель.ФайлФаксимильнаяПечать);
    Если ЗначениеЗаполнено(ДанныеКартинки) Тогда
    ДанныеКартинки = ДанныеКартинки.ДвоичныеДанные;
    КонецЕсли;
    Иначе
    ДанныеКартинки = Неопределено;
    КонецЕсли;
    
    Если ЗначениеЗаполнено(ДанныеКартинки)
    И ЗначениеЗаполнено(Макет.Области.Найти("ПодвалСчетаСФаксимильнойПечатью")) Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("ПодвалСчетаСФаксимильнойПечатью");
    ОбластьМакета.Рисунки.ФаксимильнаяПечать.Картинка = Новый Картинка(ДанныеКартинки);
    Иначе
    Если ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Шапка.Получатель, "ЮридическоеФизическоеЛицо")
    = Перечисления.ЮридическоеФизическоеЛицо.ЮридическоеЛицо Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("ПодвалСчета");
    
    ПодразделениеОтветственныхЛиц = Шапка.ПодразделениеОрганизации;
    
    Руководители = ОтветственныеЛицаБП.ОтветственныеЛица(Шапка.Организация, Шапка.Дата, ПодразделениеОтветственныхЛиц);
    Руководитель = Руководители.РуководительПредставление;
    Бухгалтер	= Руководители.ГлавныйБухгалтерПредставление;
    
    ОбластьМакета.Параметры.ФИОРуководителя = Руководитель;
    ОбластьМакета.Параметры.ФИОБухгалтера   = Бухгалтер;
    
    Иначе
    ОбластьМакета = Макет.ПолучитьОбласть("ПодвалСчетаПредприниматель");
    
    ФЛ = ОбщегоНазначения.ЗначениеРеквизитаОбъекта(Шапка.Получатель, "ИндивидуальныйПредприниматель");
    ДанныеФЛ = РегистрыСведений.ФИОФизическихЛиц.СрезПоследних(Шапка.Дата, Новый Структура("ФизическоеЛицо",ФЛ));
    Если ДанныеФЛ.Количество() > 0 Тогда
    Предприниматель = СокрЛП(ДанныеФЛ[0].Фамилия) + " " + Лев(СокрЛП(ДанныеФЛ[0].Имя),1) + ". " + Лев(СокрЛП(ДанныеФЛ[0].Отчество),1) + ".";
    Иначе
    Предприниматель = "";
    КонецЕсли;
    
    ОбластьМакета.Параметры.ФИОПредпринимателя = Предприниматель;
    
    КонецЕсли;
    КонецЕсли;
    ОбластьМакета.Параметры.Заполнить(Шапка);
    ТабличныйДокумент.Вывести(ОбластьМакета);
    
    // В табличном документе зададим имя области, в которую был
    // выведен объект. Нужно для возможности печати покомплектно.
    УправлениеПечатью.ЗадатьОбластьПечатиДокумента(ТабличныйДокумент,
    НомерСтрокиНачало, ОбъектыПечати, Шапка.Ссылка);
    КонецЦикла;
    Возврат ТабличныйДокумент;
    КонецФункции
    
    // Интерфейс для выполнения команд обработки.
    Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
    
    ПараметрыВывода.ДоступнаПечатьПоКомплектно = Истина;
    
    Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "СчетЗаказВн") Тогда
    
    ТабличныйДокумент = ПечатьДокумента(МассивОбъектов, ОбъектыПечати);
    
    УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
    КоллекцияПечатныхФорм,
    "СчетЗаказВн",
    НСтр("ru = 'Счет на оплату'"),
    ТабличныйДокумент,
    ,
    "ПФ_MXL_СчетЗаказВн"
    );
    КонецЕсли;
    
    
    КонецПроцедуры
    ////////////////////////////////////////////////////////////////////////////////
    // СЛУЖЕБНЫЕ ПРОЦЕДУРЫ И ФУНКЦИИ
    
    и форма, которая получилась

    Вложения:

    • 4.JPG
      4.JPG
      Размер файла:
      216,9 КБ
      Просмотров:
      52
  17. rshakiro
    Offline

    rshakiro Профессионал в 1С Команда форума

    Регистрация:
    17 мар 2011
    Сообщения:
    2.236
    Симпатии:
    144
    Баллы:
    104
    Вы "потеряли" строку(вывод области "Покупатель"):
    Код:
    ТабличныйДокумент.Вывести(ОбластьМакета);
    перед строкой:
    Код:
    ОбластьМакета = Макет.ПолучитьОбласть("Комментарий");
  18. TopicStarter Overlay
    Irbison
    Offline

    Irbison

    Регистрация:
    24 сен 2013
    Сообщения:
    18
    Симпатии:
    0
    Баллы:
    1
    СПАСИБО, Вы абсолютны правы

Поделиться этой страницей