8.х Вывести 2 и более печатных форм сразу.

Тема в разделе "Отчеты и обработки для "1С:Предприятие 8"", создана пользователем desintegrer, 28 авг 2013.

  1. TopicStarter Overlay
    desintegrer
    Offline

    desintegrer Опытный в 1С

    Регистрация:
    11 май 2011
    Сообщения:
    377
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте .
    Разбираюсь со следующим вопросом вывожу внешпеч форму торг12 и с ней вместе 2ую форму .
    Когда запускаю обработку через файл открыть всё работает - когда запускаю через печать (т.е. впф добавлена в доп возможности)
    открывается только первая форма .
    Помогите пожалуйста разобраться .

    Процедура печати в модуле формы:

    Код:
    Процедура ОсновныеДействияФормыПечатьСВыводомНаЭкран(Кнопка)
    
    ТабДокумент = Печать("ТОРГ12");
    
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДокумент, 1, Ложь, ОбщегоНазначения.СформироватьЗаголовокДокумента(СсылкаНаОбъект));
    //Печать СверкаДАЛ
    ТабДок = ПечатьАктДАЛ();
    
    Если ТабДок <> Неопределено Тогда
    Если Проверка =1 Тогда
    ТабДок.ОриентацияСтраницы=ОриентацияСтраницы.Ландшафт;
    ТабДок.АвтоМасштаб=Истина;
    ТабДок.ИмяПараметровПечати="ПАРАМЕТРЫ_ПЕЧАТИ_РеестрОбъемыЗакупкиПродукции";
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДок, 1, Ложь, Строка(СсылкаНаОбъект),СсылкаНаОбъект);
    КонецЕсли;
    КонецЕсли;
    
    КонецПроцедуры
    
  2. Yuriy_Alexandrovich
    Offline

    Yuriy_Alexandrovich Профессионал в 1С Команда форума

    Регистрация:
    15 сен 2011
    Сообщения:
    1.275
    Симпатии:
    76
    Баллы:
    54
    У вас переменная "проверка" не будет равна "1" поскольку не инициализирована, поэтому не отрабатывает условие
  3. TopicStarter Overlay
    desintegrer
    Offline

    desintegrer Опытный в 1С

    Регистрация:
    11 май 2011
    Сообщения:
    377
    Симпатии:
    0
    Баллы:
    26
    Переменная проверка у меня в модуле объекта со словом экспорт объявлена и инициализируется в процедуре ПечатьАктДАЛ()

    когда нет когда через файл то она равна 1.
    Когда использую доп возможности код до неё не доходит похоже что после первого выводжа печатного документа прерывается .
  4. TopicStarter Overlay
    desintegrer
    Offline

    desintegrer Опытный в 1С

    Регистрация:
    11 май 2011
    Сообщения:
    377
    Симпатии:
    0
    Баллы:
    26
    Тему можно закрывать !

    Разобрался - при добавлении в доп возможности в обработке исполняется модуль объекта - процедура печать .

    Код:
    Функция Печать(ИмяМакета = "", КоличествоЭкземпляров = 1, НаПринтер = Ложь, НепосредственнаяПечать = Ложь) Экспорт
    
    //Получить экземпляр документа на печать
    ТабДокумент = ПечатьТОРГ12();
    
    
    ТабДок = ПечатьАктДАЛ();
    Если ТабДок <> Неопределено Тогда
    Если Проверка =1 Тогда
    ТабДок.ОриентацияСтраницы=ОриентацияСтраницы.Ландшафт;
    ТабДок.АвтоМасштаб=Истина;
    ТабДок.ИмяПараметровПечати="ПАРАМЕТРЫ_ПЕЧАТИ_РеестрОбъемыЗакупкиПродукции";
    УниверсальныеМеханизмы.НапечататьДокумент(ТабДок, 1, Ложь, Строка(СсылкаНаОбъект),СсылкаНаОбъект);
    КонецЕсли;
    КонецЕсли;
    ////
    Возврат ТабДокумент;
    
    
    
    КонецФункции // Печать
    
Похожие темы
  1. andryscha92
    Ответов:
    4
    Просмотров:
    314
  2. ulterior
    Ответов:
    2
    Просмотров:
    1.249
Загрузка...

Поделиться этой страницей