7.7 Выташить реквезит из документа

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем kible, 21 май 2010.

  1. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Работает. Только это не совсем то что нужно.

    Вложения:

    • 1235.JPG
      1235.JPG
      Размер файла:
      76 КБ
      Просмотров:
      21
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Значит все правильно...Фобец вам уже дал ответ на вопрос. Вы его не увидели.
    1) Вы должны добавить текстовую колонку в таблицу (меню-вставить-текст и указываете курсором на т.ч.)
    2) 2 раза кликаем по столбцу который появился чтобы вызвать свойства
    3) Закладка дополнительно. Поле вормула пишем:Спецификация.Наименование
    ВСЕ. Столбец можете перемещать по своему усмотрению
  3. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Помогите с проводкой
    Код:
    Процедура ОбработкаПроведения()
    СчетДебета = СчетДТ;
    СчетКредита = СчетКТ;
    МестоХранения = Склад;
    
    глПроводка(Операция,
    СчетДебета,	 глСубконто(ТМЦ,МестоХранения),
    СчетКредита, глСубконто(Подразделение, ВидДеятельности, ВидЗатрат));    
    
    КонецПроцедуры
    
    Ту проблему решил.
    Номеру поставил тип строка. Пускай в номере пишут.

    С проводкой ошибка такая "Недостаточно фактических параметров"
  4. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    ищите в глобальном модуле процедуру глПроводка перед ней есть описание параметров
  5. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Я не знаю как теперь выбрать сроки из Документа СпецификацияНоменклатуры. Подскажите пожалуйста.
  6. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Спецификация.ВыбратьСтроки()
  7. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    цикл выбор строк я приводил вам выше
  8. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура Номен() 
    Сообщить(Спецификация.Наименование);//Вот так работает
    
    
    Спецификация.ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    Сообщить(Спецификация.Номенклатура);// Вот так нет 
    КонецЦикла;
    
    КонецПроцедуры
    
    
    В чем причина?
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Вы выбираете сторки специвикации. Реквизит Наименование находится в шапке... Если хотите видеть наименование из ТЧ надо обращаться к реквизиту НоменклатураТаб.

    Итак:
    Код:
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл  
    Сообщить(Спецификация.Номенклатура);
    КонецЦикла;
    
    
    
    
    покажет все наименования из документа спецификации ТЕКУЩЕЙ ТЧ

    Код:
    Спецификация.ВыбратьСтроки();
    Пока Спецификация.ПолучитьСтроку()=1 Цикл     
    Сообщить(Спецификация.НоменклатураТаб);
    КонецЦикла;
    
    
    
    
    покажет т.ч. ТЕКУЩЕЙ спецификации в т.ч.

    Код:
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл     
    Сообщить(Спецификация.Номенклатура);
    Спецификация.ВыбратьСтроки();
    Пока Спецификация.ПолучитьСтроку()=1 Цикл     
    Сообщить(Спецификация.НоменклатураТаб);
    КонецЦикла;
    КонецЦикла;
    
    
    
    покажет ВСЕ
  10. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26

    Спасибо! Работает.
  11. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Как выбрать группу, а не элемент справочника?
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Что подразумевается? Куда выбрать?
  13. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Зделал.
    Код:
    Форма.СпецификацияИзделия.ВыборГруппы(1);
    
  14. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    А как перебрать элементы группы справочника?
  15. dianofob
    Offline

    dianofob (-_-)y-.o0O

    Регистрация:
    3 июл 2009
    Сообщения:
    711
    Симпатии:
    0
    Баллы:
    26
    Почитать ЖКК
  16. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Спр.ИспользоватьРодителя(НужнаяГруппа);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    //твои действия
    КонецЦикла;
    
    
  17. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ВыборкаНоменклатуры()
    Спр = СоздатьОбъект("Справочник.СпецификацияНоменклатуры");
    Спр.ИспользоватьРодителя(СпецификацияИзделия);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Сообщить(Спр.Номенклатура+"Кол-Во"+Спр.Количество);
    КонецЦикла;
    КонецПроцедуры
    
    
    А почему количество не выводит?
  18. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Потому что нужно приводить к определенному типу. Вы складывали объект и число.
    Нужно вот так:
    Код:
    Сообщить(""+Спр.Номенклатура+"   Кол-Во"+Спр.Количество);
    
    
    
    
  19. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Код:
    Процедура ВыборкаНоменклатуры()
    Спр = СоздатьОбъект("Справочник.СпецификацияНоменклатуры");
    Спр.ИспользоватьРодителя(СпецификацияИзделия);
    Спр.ВыбратьЭлементы();
    Пока Спр.ПолучитьЭлемент()=1 Цикл
    //Сообщить(""+Спр.Номенклатура+"   Кол-Во"+Спр.Количество);
    
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    ОбщКолВо=Спр.Количество*Количество;
    Сообщить(""+Спр.Номенклатура+"   Кол-Во"+Спр.Количество*Количество);
    КонецЦикла;
    КонецЦикла; 
    КонецПроцедуры
    
    
    Как передать Спр.Номенклатура и Спр.Количество*Количество в Процедуру ОбработкаПроведения?
  20. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    1)Перенесите саму процедуру в глобальный модуль и вызывайте ее используя контекст
    2) Просто перенесите процедуру в модуль проведения и вызывайте
    3) Используйте код в модуле проведения без написания процедуры
    4) Используйте список значений и метод Провести из модуля формы

    Код:
    Провести(,СписПараметров)
    
    
    

Поделиться этой страницей