8.х БП Выствить префикс в счет-фактуре

Тема в разделе ""1С:Бухгалтерия БП"", создана пользователем sin_ner, 24 май 2012.

  1. TopicStarter Overlay
    sin_ner
    Offline

    sin_ner

    Регистрация:
    24 май 2012
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Добрый день.
    По законодательству если у организации есть обособленные подразделения, в счет-фактуре должны выставляться через дробь, к этому в учетной политики указано ведений номеров счет-фактур в формате ММ/ДД/ХХХХХ где XXXXX – номер счет фактуры в периодичности день.
    Если используется обособленное подразделение то номер должен иметь формат ММ/ДД/ХХХ-П где П – номер подразделения.
    Девать не куда добавляю реквизит подразделение в Счет-фактуру делаю и дописываю в код.

    Код:
    Процедура ПриУстановкеНовогоНомера(СтандартнаяОбработка, Префикс)
    
    //		ОбщегоНазначения.ДобавитьПрефиксОрганизации(ЭтотОбъект, Префикс);
    //		Если Исправление Тогда
    //					   Префикс = "И" + Префикс;
    //		Иначе				
    //					   Префикс = ?(ВидСчетаФактуры = Перечисления.ВидСчетаФактурыВыставленного.НаАванс,"А","")+Префикс;
    //		КонецЕсли;
    //		ОбщегоНазначения.ДобавитьПрефиксУзла(Префикс);
    
    Если Подразделение.Пустая() = Истина  Тогда			  
    Префикс = Строка(Формат(Месяц(ЭтотОбъект.Дата),"ЧЦ=2; ЧВН=")) + "/"+ Строка(День(ЭтотОбъект.Дата));
    Иначе
    Префикс = Строка(Формат(Месяц(ЭтотОбъект.Дата),"ЧЦ=2; ЧВН=")) + "/"+ Строка(День(ЭтотОбъект.Дата)) + "/" +Лев(Подразделение.Код,2);
    КонецЕсли
    
    КонецПроцедуры
    Отрабатывает нормально, доставляя номера
    05/24/00001
    05/24/00002
    05/24/00003
    05/24/00004
    Делаем счет фактуру с подразделение получаем номер
    05/24/005-1
    И дальше идет ошибка, а именно следующий номер:
    05/24/005-2
    Хотя должен бы быть
    05/24/00006.

    Прошу помощи в сложившейся проблеме
  2. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Может не стоит менять номер документа, а стоит подумать об изменении номера в печатной форме ?

    Вы походу и так уже накуралесили, зачем вам в документах менять нумерацию?
  3. TopicStarter Overlay
    sin_ner
    Offline

    sin_ner

    Регистрация:
    24 май 2012
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    В печатной форме поменть не проблема, но а как быть дальше в книгах покупок и продаж. да и номерация отпечатанных документов с базой будет расходится.
  4. alexburn
    Offline

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.735
    Симпатии:
    508
    Баллы:
    204
    Вот вы наковыряете сейчас нумерацию, потом 100% проблем не оберетесь.
    У вас обособленное подразделение - Организация ?

    Мне кажется вам нужно пересмотреть ведение учета в своей организации:)))
    Кстати, напишите версию конфы.
  5. TopicStarter Overlay
    sin_ner
    Offline

    sin_ner

    Регистрация:
    24 май 2012
    Сообщения:
    3
    Симпатии:
    0
    Баллы:
    1
    Обособленные подразделения - это подразделение организации а не отдельная организация, у них отличаеться только КПП.
    Конфа БП 35.

Поделиться этой страницей