7.7 Выпуск готовой продукции

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем kible, 23 апр 2010.

  1. TopicStarter Overlay
    kible
    Offline

    kible Опытный в 1С

    Регистрация:
    14 апр 2010
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте! Задача. Нужно в документе Выпуск готовой продукции сделать запрос по Счет фактурам за указанный период и заполнить табличную часть документа. Я написал запрос, но этот запрос выгружает только одно наименование ТМЦ, а количество не суммирует. Подскажите пожалуйста как сделать так чтобы запрос выгружал все ТМЦ т.е повторял строки ТМЦ с количеством либо выгружал одно название ТМЦ, а количество суммировал. Посмотреть вложение 4032

    Вложения:

    • Текст1.txt
      Размер файла:
      863 байт
      Просмотров:
      40
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.523
    Симпатии:
    407
    Баллы:
    104
    Код:
    Процедура Сформировать() 
    Перем Запрос, ТекстЗапроса; 
    //Создание объекта типа Запрос 
    Запрос = СоздатьОбъект("Запрос"); 
    ТекстЗапроса = "//{{ЗАПРОС(Сформировать) 
    |Период с ВыбНачПериода по ВыбКонПериода; 
    |ТМЦ = Документ.СчетФактура.ТМЦ; 
    |СуммаБезНалогов = Документ.СчетФактура.СуммаБезНалогов; 
    |Количество = Документ.СчетФактура.Количество; 
    //
    //здесь у вас не хватает функций суммирования
    //
    |Группировка ТМЦ все; 
    |"//}}ЗАПРОС; 
    // Если ошибка в запросе, то выход из процедуры 
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда 
    Возврат; 
    КонецЕсли; 
    ТЗ = СоздатьОбъект("ТаблицаЗначений"); 
    Запрос.Выгрузить(ТЗ); //зачем выгружаем? непонятно.... Нигде не применяете...
    Пока Запрос.Группировка(1) = 1 Цикл 
    НоваяСтрока(); 
    ПриРедактированииНовойСтроки(); 
    ТМЦ = Запрос.ТМЦ; 
    Количество = Запрос.Количество; 
    Сумма = Запрос.СуммаБезНалогов; 
    КонецЦикла; 
    КонецПроцедуры 
    
    
    
    

    Функция <ИмяФункции> = <ТипФункции>(<Параметр>|<УточненныйПараметр>) [Когда(<Условие>)];
    Англоязычный синоним:
    Function <ИмяФункции> = <ТипФункции>(<Параметр>|<УточненныйПараметр>) [When(<Условие>)];
    Назначение:
    Вычислить функцию и включить ее результат в запрос.
    Параметры:
    <ИмяФункции> - имя, присваиваемое функции;
    <ТипФункции> - ключевое слово одной из встроенных функций языка;
    <Параметр> - имя внутренней переменной, параметр вызова функции;
    <УточненныйПараметр> - конкретизация внутренней переменной, параметр вызова функции.
    <Условие> - условие вычисления функции (необязательно).
    Замечание:
    Типы встроенных функций:
    Сумма (Sum) - сумма значений параметра;
    Среднее (Avg) - среднее значений параметра;
    Минимум (Min) - минимум значений параметра;
    Максимум (Max) - максимум значений параметра;
    НачОст (BegRest) - начальный остаток значений параметра-ресурса Регистра;
    КонОст (EndRest) - конечный остаток значений параметра-ресурса Регистра;
    Приход (Debit) - приход значений параметра-ресурса Регистра;
    Расход (Credit) - расход значений параметра-ресурса Регистра;
    Счётчик (Counter) - количество записей, вошедших в выборку, <Параметр> - не нужен;
    СНД, СКД, СНК, СКК (IDB, FDB, ICD, FCD) - сальдо начальное или конечное по дебету или кредиту;
    ДО, КО, КорДо, КорКо (TD, TC, CorTD, CorTC) - обороты по дебету или кредиту счета или корсчета;
    В функциях: Сумма, Среднее, Максимум, Минимум в качестве аргумента возможно использование арифметического выражения в терминах встроенного языка.
    К параметрам, указывающим на ресурсы Регистров, могут применяться только оговоренные функции.

Поделиться этой страницей