7.7 Выполниение бух запроса.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем alp, 5 мар 2010.

  1. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Добрый День , есть код:


    Код:
    Процедура РазложитьПоГруппам(Таблица,НачалоОтчета,КонецОтчета,Группа)
    БухИт=СоздатьОбъект("БухгалтерскиеИтоги");
    //БухИт.ВключатьСубСчета(0,0);
    Если ВыбКонтрагент.Выбран()=1 Тогда
    БухИт.ИспользоватьСубконто(ВидыСубконто.Контрагенты,ВыбКонтрагент);
    Иначе
    БухИт.ИспользоватьСубконто(ВидыСубконто.Контрагенты);
    КонецЕсли;
    Если БухИт.ВыполнитьЗапрос(НачалоОтчета,КонецОтчета,"62.1,62.6","90",,,,"С")=0 Тогда
    Возврат;
    КонецЕсли;
    БухИт.ВыбратьСубконто(1);
    Пока БухИт.ПолучитьСубконто(1)=1 Цикл
    НомерСтроки="";
    Если Таблица.НайтиЗначение(БухИт.Субконто(1),НомерСтроки,"Контрагент")=1 Тогда
    Сообщить(БухИт.КО());
    Если БухИт.ДО()=0 Тогда
    //Если БухИт.КорКО("С")=0 ТОгда
    Таблица.УстановитьЗначение(НомерСтроки,"Группа",Группа);
    КонецЕсли;
    Иначе
    Таблица.НоваяСтрока();
    Таблица.Контрагент=БухИт.Субконто(1);
    Таблица.Группа=Группа;
    КонецЕсли;
    КонецЦикла;
    КонецПроцедуры
    
    
    Проблема в следующем , Если убрать Корсчет в параметре , то обороты считаются правильно, но если я ставлю 90 счет в кор счете выдает такую Ерись!!.
    у мена по "анализу счета по субконто" оборотов за период по 90 счету нет вообще!! НО БухИтоги выдают положительную сумму, откуда он её берет ? , помогите плиз.
  2. WaRDeR
    Offline

    WaRDeR Модераторы Команда форума Модератор

    Регистрация:
    23 ноя 2006
    Сообщения:
    3.263
    Симпатии:
    14
    Баллы:
    29
    Так сложно сказать по куску кода без ИБ.

    Как вариант попробуй в запросе не указывать корсчет, а в цикле перебери все корсчета, посмотришь, какие составляют общую сумму.

    Возможно тестирование и исправление поможет.
  3. TopicStarter Overlay
    alp
    Offline

    alp Опытный в 1С

    Регистрация:
    8 янв 2009
    Сообщения:
    432
    Симпатии:
    0
    Баллы:
    26
    Спасибо попробую.

Поделиться этой страницей