8.х Выгрузка.

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 8"", создана пользователем ифкпфт009, 12 сен 2016.

  1. TopicStarter Overlay
    ифкпфт009
    Offline

    ифкпфт009 Опытный в 1С

    Регистрация:
    23 апр 2014
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте, подскажите как лучше сделать, к нам приходит файл в dbf с данными о человеке(снилс, адрес и т.д), пользователь начисляет какие-либо услуги и мы эти суммы выгружаем.
    Проблема в том, что у меня выгружает, но всех, а нужно только тех которые указаны в файле, тобишь сопоставить их надо, или сделать что-то удаления строки, если значение NULL.
    Что посоветуете?
  2. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.552
    Симпатии:
    716
    Баллы:
    204
    Производить поиск(запросом или поиском по ТЗ) по загруженной информации из файла.
  3. TopicStarter Overlay
    ифкпфт009
    Offline

    ифкпфт009 Опытный в 1С

    Регистрация:
    23 апр 2014
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    А можно сделать такую штучку, (что-то типа группы), тобишь отображается 1 строка физлица, нажимаем на + и появляются все его записи.
    Скрин приложил.
    Почитал что есть такое свойство как "Свернуть"

    Код:
    //Заполнение таблицы значений
            ТЗХ = Новый ТаблицаЗначений;
            ДопТаблица = Новый ТаблицаЗначений;
            ТЗХ.Колонки.Добавить("лс");
            Для Индекс = 0 По МассивИменаПолей.Количество() - 1 Цикл
                //Сообщить(МассивИменаПолей[Индекс]);
                ТЗХ.Колонки.Добавить(МассивИменаПолей[Индекс], ОписаниеТипаВыбора);
               
                ДопТаблица.Колонки.Добавить(МассивИменаПолей[Индекс], ОписаниеТипаВыбора);
            КонецЦикла;   
            ИксБейс.Первая();
            Пока Не ИксБейс.ВКонце() Цикл
                Стр = ТЗХ.Добавить();
                Для н = 0 По МассивИменаПолей.Количество() - 1 Цикл
                    //        ПЛ = ИксБейс.ПолучитьЗначениеПоля(МассивСтарыхИменПолей[н]);
                    ПЛ = ИксБейс.ПолучитьЗначениеПоля(МассивИменаПолей[н]);
                    Стр[МассивИменаПолей[н]] = СокрЛП(ПЛ);
                КонецЦикла;
                ПоискПоТЗ(ИксБейс);
                ИксБейс.Записать();
                ИксБейс.Следующая();
            КонецЦикла;
            //тзх.Свернуть("FAM, NAME, PAT и т.д"); сворачивает то он как нужно, но собственно и вопрос - а как развернуть?))
            ИксБейс.ЗакрытьФайл();
        КонецЕсли;
    

    Вложения:

    • тз.JPG
      тз.JPG
      Размер файла:
      165,1 КБ
      Просмотров:
      4
  4. TopicStarter Overlay
    ифкпфт009
    Offline

    ифкпфт009 Опытный в 1С

    Регистрация:
    23 апр 2014
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    или с тз нельзя такое сделать?
  5. nomad_irk
    Online

    nomad_irk Гуру в 1С

    Регистрация:
    20 окт 2008
    Сообщения:
    7.552
    Симпатии:
    716
    Баллы:
    204
    Так понимаю, нужно ДеревоЗначений вместо ТаблицыЗначений.
  6. TopicStarter Overlay
    ифкпфт009
    Offline

    ифкпфт009 Опытный в 1С

    Регистрация:
    23 апр 2014
    Сообщения:
    81
    Симпатии:
    0
    Баллы:
    26
    с древом также работать можно как с тз?
    --- Объединение сообщений, 23 сен 2016 ---
    или всетаки можно как-то через ТЗ сделать, там половину кода переписывать....)
    Последнее редактирование: 23 сен 2016

Поделиться этой страницей