8.х ОБМЕН Выгрузка/Загрузка в XML

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем cobra77777, 16 сен 2013.

  1. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Здравствуйте!

    Подскажите каким образом выгрузить/загрузить документ файл в формате XML ? Пример.
  2. nbIpKuH_BaH9I
    Online

    nbIpKuH_BaH9I Модераторы Команда форума Модератор

    Регистрация:
    16 сен 2009
    Сообщения:
    6.980
    Симпатии:
    398
    Баллы:
    104
    Подробнее можно? Воспользуйтесь конвертацией данных. Подобную выгрузку можно написать за считанные минуты.
  3. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    Выгрузка сделана.Теперь вопрос по загрузке. Вот что выгрузилось. Файл след.формата получился:

    <?xml version="1.0" encoding="UTF-8"?>
    <Выгрузка>
    <Выгрузка Номер="000000001" Дата="05.02.2013 12:51:14" СотрудникГруппы="Иванов И.Т." СотрудникОтдела="Никулин Н.В." Деталь="Подшпиник" Склад="Основной" Описание="аввыафыа"/>
    <Выгрузка Номер="000000002" Дата="10.02.2013 10:52:14" СотрудникГруппы="Сидоров А.А." СотрудникОтдела="Ахметов А.П." Деталь="Подшпиник" Склад="Основной" Описание="ппара"/>
    ......................................
    </Выгрузка>

    Вот код который неработает :( :

    Где то накосячил. Выдает ошибку: Значение поля "Дата" не может быть пустой датой.

    //////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
    Чтение = Новый ЧтениеXML;
    Чтение.ОткрытьФайл("C:\downloads\itog.xml");
    Док="";
    // чтение осуществляется по одному тегу
    Пока Чтение.Прочитать() Цикл
    // анализируем тип элемента и его имя
    Если Чтение.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
    Если Чтение.Имя="Выгрузка" Тогда
    // создаем новый элемент документа
    Док = Документы.АктПриемаКартриджа.СоздатьДокумент();
    // читаем атрибуты
    Пока Чтение.ПрочитатьАтрибут() Цикл
    Если Чтение.Имя="Номер" Тогда
    Док.Номер = Число (Чтение.Значение);

    КонецЕсли;

    КонецЦикла;
    КонецЕсли;
    ИначеЕсли Чтение.ТипУзла = ТипУзлаXML.Текст Тогда
    // заполняем наименование созданного ранее элемента
    Док.Номер = Чтение.Значение;
    ИначеЕсли Чтение.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда
    // требуется записать информацию про клиента
    Док.Записать();
    КонецЕсли;
    КонецЦикла;

    //////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////////
  4. TopicStarter Overlay
    cobra77777
    Offline

    cobra77777 Опытный в 1С

    Регистрация:
    20 апр 2012
    Сообщения:
    154
    Симпатии:
    0
    Баллы:
    26
    у меня другой вопрос: Преобразование значения к типу Дата не может быть выполнено. Код ниже: Не пойму где копать :(

    Пока Чтение.ПрочитатьАтрибут() Цикл

    Если Чтение.Имя="Номер" Тогда

    Док.Дата = Дата(Чтение.Значение);

    КонецЕсли;

Поделиться этой страницей