7.7 Выгрузка в txt без групп и их содержимого

Тема в разделе "Конфигурирование на платформе "1С:Предприятие 7.7"", создана пользователем shtorm512, 20 фев 2012.

  1. TopicStarter Overlay
    shtorm512
    Offline

    shtorm512 Опытный в 1С

    Регистрация:
    12 мар 2011
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Собственно из темы уже многое понятно, хочу выгрузить в текстовый файл из справочника "Клиенты" всех клиентов по реквизиту Полное наименование, но не хочу трогать группы и содержимое в них, а так же помеченный на удаление. Помогите с кодом?

    вот мой



    Код:
    Процедура Выполнить()
    Текст = СоздатьОбъект("Текст");
    СпрКлиенты = СоздатьОбъект("Справочник.Клиенты");
    СпрКлиенты.ВыбратьЭлементы();
    Пока СпрКлиенты.ПолучитьЭлемент() = 1 Цикл
    Если СпрКлиенты.ЭтоГруппа() = 1 Тогда
    Продолжить;
    ИначеЕсли СпрКлиенты.ПометкаУдаления() = 1 Тогда
    Продолжить;
    КонецЕсли;
    Текст.ДобавитьСтроку(СпрКлиенты.ПолноеИмя);
    КонецЦикла;
    Текст.Записать("D:\Клиенты.txt");
    КонецПроцедуры
  2. Максим
    Offline

    Максим Опытный в 1С

    Регистрация:
    28 фев 2008
    Сообщения:
    686
    Симпатии:
    8
    Баллы:
    29
    Похоже на правду. А что не так?
  3. TopicStarter Overlay
    shtorm512
    Offline

    shtorm512 Опытный в 1С

    Регистрация:
    12 мар 2011
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    не так заключается в том что сейчас выгружаются все группы и все в них содержимое
  4. Максим
    Offline

    Максим Опытный в 1С

    Регистрация:
    28 фев 2008
    Сообщения:
    686
    Симпатии:
    8
    Баллы:
    29
    Кажется понял - тебе нужны только те контрагенты, которые на на нулевом уровне, т.е. не лежат в группах.

    Код:
    Процедура Выполнить()
    Текст = СоздатьОбъект("Текст");
    СпрКлиенты = СоздатьОбъект("Справочник.Клиенты");
    СпрКлиенты.ВыбратьЭлементы();
    Пока СпрКлиенты.ПолучитьЭлемент() = 1 Цикл
    Если СпрКлиенты.ЭтоГруппа() = 1 Тогда
    Продолжить;
    ИначеЕсли СпрКлиенты.ПометкаУдаления() = 1 или СпрКлиенты.Уровень()<>0 Тогда
    Продолжить;
    КонецЕсли;
    Текст.ДобавитьСтроку(СпрКлиенты.ПолноеИмя);
    КонецЦикла;
    Текст.Записать("D:\Клиенты.txt");
    КонецПроцедуры
  5. TopicStarter Overlay
    shtorm512
    Offline

    shtorm512 Опытный в 1С

    Регистрация:
    12 мар 2011
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26
    Так вообще ничего не выгружает, но почва для размышления появилась
  6. Максим
    Offline

    Максим Опытный в 1С

    Регистрация:
    28 фев 2008
    Сообщения:
    686
    Симпатии:
    8
    Баллы:
    29
    Не помню точно, может нумерация уровней в 7.7 начинается не с 0, а с 1 попробуй:

    СпрКлиенты.Уровень()<>1
  7. TopicStarter Overlay
    shtorm512
    Offline

    shtorm512 Опытный в 1С

    Регистрация:
    12 мар 2011
    Сообщения:
    87
    Симпатии:
    0
    Баллы:
    26

    точно, с 1 начинается...Спасибо:)

Поделиться этой страницей