8.х ОБМЕН Выгрузка в Сбербанк в формате DBF

Тема в разделе "Обмен данными в "1С:Предприятие 8"", создана пользователем trolja, 13 дек 2010.

  1. TopicStarter Overlay
    trolja
    Offline

    trolja

    Регистрация:
    13 дек 2010
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Кто-нибудь переделывал выгрузку/загрузку в сбербанк в DBF? Поделитесь, пожалуйста. Собираемся переходить с семерки на 8.2, но без работающей выгрузки о переходе не может быть и речи.
  2. TODD22
    Offline

    TODD22 Профессионал в 1С Команда форума

    Регистрация:
    23 фев 2009
    Сообщения:
    4.755
    Симпатии:
    146
    Баллы:
    104
    Это что вы выгружать собрались? Просто из любопытства.
    У меня только клиент банк и он нормально выгружает/загружает в *.txt.
  3. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Скорее всего не клиент-банк, а выгрузка зарплаты работников для зачисления на зарплатные карты Сбербанка.

    В УПП 1.2 и 1.3 есть обработка "Импорт / экспорт операций по лицевым счетам сотрудников" с выгрузкой в XML.
    Думаю, что допилить ее до DBF не так уж и дорого будет.
  4. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    я с нуля писал обработину для зарплаты и управления персоналом.. выгрузка зарплаты в сбербанк в XML.. ничего сложного, надо знать только формат XML файла.
  5. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    А зачем с нуля? В ЗУП есть такая же обработка "Импорт / экспорт операций по лицевым счетам сотрудников"

    И наше отделение Сбербанка у нас только в DBF принимает... Даже софтину какую-то свою досовскую давали, для конвертации XML в DBF.
  6. TopicStarter Overlay
    trolja
    Offline

    trolja

    Регистрация:
    13 дек 2010
    Сообщения:
    10
    Симпатии:
    0
    Баллы:
    1
    Прошу прощения, не написала какие базы: сейчас работаем в Зарплате и кадрах 7.7, собираемся переходить на Зарплату и кадры бюджетного учреждения 8.2. Выгрузка нужна для перечисления зарплаты на Сбербанковске карты сотрудников, как правильно заметил Диего. В конфе есть Операции с лицевым счетами, в которые входит заявки на открытие лиц.счетов, экспорт и импорт зачисления зарплаты, но выгружается в xml, а у нас Сбербанк принимает только в dbf.


    Может поделишься софтиной? Вдруг и нам подойдет.
  7. GlebHappy
    Offline

    GlebHappy Опытный в 1С

    Регистрация:
    31 июл 2009
    Сообщения:
    113
    Симпатии:
    0
    Баллы:
    26
    Троля, проблемы нет, была на инфостарте обработка именно по выгрузке в DBF для ЗБУ, после небольшого тюнинга идеально пригодна для использования
    [warn='Ссылка удалена']Ссылки на данный сайт не приемлимы, ибо это платный ресурс[/warn]
  8. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Отправил по почте.
  9. vartanet
    Offline

    vartanet Опытный в 1С Команда форума

    Регистрация:
    16 ноя 2010
    Сообщения:
    2.698
    Симпатии:
    15
    Баллы:
    29
    может кому пригодится..
    добавил 4 строковых реквизита в физлицо и 1 реквизит в организацию..

    Функция ЧислоВСтроку(ТекЧисло)

    возврат Формат(ТекЧисло, "ЧРД=.; ЧГ=0");

    КонецФункции // ЧислоВСтроку()


    Процедура КнопкаВыполнитьНажатие(Кнопка)

    ЗаписьXML = Новый ЗаписьXML;

    ЗаписьXML.ОткрытьФайл(ИмяФайла, "windows-1251");

    ЗаписьXML.ЗаписатьОбъявлениеXML();

    ЗаписьXML.ЗаписатьНачалоЭлемента("СчетаПК");
    ЗаписьXML.ЗаписатьАтрибут("ДатаФормирования", Формат(ЗарплатаКВыплатеОрганизаций.Дата, "ДФ=yyyy")+"-"+Формат(ЗарплатаКВыплатеОрганизаций.Дата, "ДФ=MM")+"-"+Формат(ЗарплатаКВыплатеОрганизаций.Дата, "ДФ=dd"));
    ЗаписьXML.ЗаписатьАтрибут("НомерДоговора", ЗарплатаКВыплатеОрганизаций.Организация.НомерДоговораСбербанкЗарплата);
    ЗаписьXML.ЗаписатьАтрибут("НаименованиеОрганизации", ЗарплатаКВыплатеОрганизаций.Организация.Наименование);
    ЗаписьXML.ЗаписатьАтрибут("ИНН", ЗарплатаКВыплатеОрганизаций.Организация.ИНН);
    ЗаписьXML.ЗаписатьАтрибут("РасчетныйСчетОрганизации", ЗарплатаКВыплатеОрганизаций.Организация.РасчетныйСчетСбербанкЗарплата);

    ЗаписьXML.ЗаписатьНачалоЭлемента("ЗачислениеЗарплаты");
    Для каждого СтрокаТаблЧасти Из ЗарплатаКВыплатеОрганизаций.Зарплата Цикл

    ЗаписьXML.ЗаписатьНачалоЭлемента("Сотрудник");
    ЗаписьXML.ЗаписатьАтрибут("Нпп", Строка(СтрокаТаблЧасти.НомерСтроки));

    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ФИОФизЛицСрезПоследних.Период,
    | ФИОФизЛицСрезПоследних.ФизЛицо,
    | ФИОФизЛицСрезПоследних.Фамилия,
    | ФИОФизЛицСрезПоследних.Имя,
    | ФИОФизЛицСрезПоследних.Отчество
    |ИЗ
    | РегистрСведений.ФИОФизЛиц.СрезПоследних КАК ФИОФизЛицСрезПоследних
    |ГДЕ
    | ФИОФизЛицСрезПоследних.ФизЛицо = &ФизЛицо";
    Запрос.УстановитьПараметр("ФизЛицо", СтрокаТаблЧасти.Физлицо);
    Таблица = Запрос.Выполнить().Выгрузить();

    ЗаписьXML.ЗаписатьНачалоЭлемента("Фамилия"); ЗаписьXML.ЗаписатьТекст(Таблица[0].Фамилия); ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.ЗаписатьНачалоЭлемента("Имя"); ЗаписьXML.ЗаписатьТекст(Таблица[0].Имя); ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.ЗаписатьНачалоЭлемента("Отчество"); ЗаписьXML.ЗаписатьТекст(Таблица[0].Отчество); ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.ЗаписатьНачалоЭлемента("ФилиалОтделенияБанка"); ЗаписьXML.ЗаписатьТекст(ЗарплатаКВыплатеОрганизаций.Организация.ФилиалОтделенияБанкаСбербанкЗарплата); ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.ЗаписатьНачалоЭлемента("ОтделениеБанка"); ЗаписьXML.ЗаписатьТекст(ЗарплатаКВыплатеОрганизаций.Организация.ОтделениеБанкаСбербанкЗарплата); ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.ЗаписатьНачалоЭлемента("ЛицевойСчет"); ЗаписьXML.ЗаписатьТекст(СтрокаТаблЧасти.Физлицо.ЛицевойСчетСбербанкЗарплата); ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.ЗаписатьНачалоЭлемента("Сумма"); ЗаписьXML.ЗаписатьТекст(ЧислоВСтроку(СтрокаТаблЧасти.Сумма)); ЗаписьXML.ЗаписатьКонецЭлемента();

    ЗаписьXML.ЗаписатьКонецЭлемента(); // Сотрудник

    КонецЦикла;
    ЗаписьXML.ЗаписатьКонецЭлемента();

    ЗаписьXML.ЗаписатьНачалоЭлемента("КонтрольныеСуммы");
    ЗаписьXML.ЗаписатьНачалоЭлемента("КоличествоЗаписей"); ЗаписьXML.ЗаписатьТекст(Строка(ЗарплатаКВыплатеОрганизаций.Зарплата.Количество())); ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.ЗаписатьНачалоЭлемента("СуммаИтого"); ЗаписьXML.ЗаписатьТекст(ЧислоВСтроку(ЗарплатаКВыплатеОрганизаций.Зарплата.Итог("Сумма"))); ЗаписьXML.ЗаписатьКонецЭлемента();
    ЗаписьXML.ЗаписатьКонецЭлемента(); // КонтрольныеСуммы

    ЗаписьXML.ЗаписатьКонецЭлемента(); // ЗачислениеЗарплаты
    ЗаписьXML.Закрыть();

    КонецПроцедуры
  10. redmonkey
    Offline

    redmonkey Опытный в 1С

    Регистрация:
    4 сен 2008
    Сообщения:
    133
    Симпатии:
    0
    Баллы:
    26
    Та же проблема со сбербанковским DBF, у меня 8.2 и ЗУП 2.5.34.2
    может поделится кто-нибуть? буду очень признателен
  11. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Чем поделиться?
    XML в DBF?
  12. redmonkey
    Offline

    redmonkey Опытный в 1С

    Регистрация:
    4 сен 2008
    Сообщения:
    133
    Симпатии:
    0
    Баллы:
    26
    да. обработкой

    я так понял это обработка для отправки, на инфостаре нет подписки.
  13. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Это не обработка, это прога от Сбербанка
    Выложил тут: http://zalil.ru/30977171

    А так лучше самому написать обработку.
  14. redmonkey
    Offline

    redmonkey Опытный в 1С

    Регистрация:
    4 сен 2008
    Сообщения:
    133
    Симпатии:
    0
    Баллы:
    26
    спасибо, а то что на инфостаре годно? сегодня качал уже от туда. завтра скачаю посмотрю еще..
  15. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    Не смотрел...
    У меня в Бухгалтерии 7.7 обработка допилена.
  16. redmonkey
    Offline

    redmonkey Опытный в 1С

    Регистрация:
    4 сен 2008
    Сообщения:
    133
    Симпатии:
    0
    Баллы:
    26
    посмотрел эту программу от сбербанка, это пздц... для кого они это делают...
  17. Touh_of_soul
    Offline

    Touh_of_soul

    Регистрация:
    6 май 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    а мне можешь прислать этот софт плиз..
  18. Touh_of_soul
    Offline

    Touh_of_soul

    Регистрация:
    6 май 2011
    Сообщения:
    2
    Симпатии:
    0
    Баллы:
    1
    ты написал обработку для 1с 7.7 бух дай мне её плиз..
  19. for_maricat
    Offline

    for_maricat Опытный в 1С

    Регистрация:
    11 ноя 2010
    Сообщения:
    236
    Симпатии:
    0
    Баллы:
    26
    Да, лучше самим написать - это недолго и несложно, на самом деле (у нас эквивалентно 1 часу работы). Даже в пределах одного города требования к формату файлов от одного и того же сбербанка могут отличаться, как это ни странно. Сталкивались. Опять же, есть разница у разных организаций.
  20. Diego
    Offline

    Diego Любитель 1С Команда форума

    Регистрация:
    3 апр 2009
    Сообщения:
    966
    Симпатии:
    2
    Баллы:
    29
    В теме есть ссылка: http://zalil.ru/30977171

Поделиться этой страницей