7.7 Выгрузка товаров на сайт, помогите с остатками

Тема в разделе "Обмен данными в "1С:Предприятие 7.7"", создана пользователем GoodLucks777, 31 мар 2017.

  1. TopicStarter Overlay
    GoodLucks777
    Offline

    GoodLucks777

    Регистрация:
    31 мар 2017
    Сообщения:
    1
    Симпатии:
    0
    Баллы:
    1
    Есть обработка, формирует csv файл, я смог сделать почти все что требуется кроме остатков товара на складе, подскажите, как их правильно вывести? Изучил другие выгрузки, везде указывается ОстаткиТМЦ - но у меня на это ругается 1С, нигде я не вижу подобного отчета. Через 1С смотрю остатки так: "Отчеты - Остатки товаров" и там все выводится нормально.

    1С 7.7 Торговля+Склад, редакция 8.7!

    Если есть время, помогите по скайпу! Готов оплатить помощь сразу на карточку, мой скайп: artemstl

    Вот моя обработка:

    //*******************************************

    Процедура Сформировать()



    Т=СоздатьОбъект ("Текст");

    НОМ=СоздатьОбъект ("Справочник.Номенклатура");
    //НОМ.ИспользоватьДату(ТекущаяДата());

    НОМ.НайтиПоНаименованию("НЕ ИСПОЛЬЗ", 0);
    //Если НОМ.ТекущийЭлемент().ЭтоГруппа = 1 тогда
    Если НОМ.Выбран() > 0 Тогда
    НеИспГруппа = НОМ.ТекущийЭлемент();
    КонецЕсли;
    //КонецЕсли;
    НОМ.ПорядокКодов();

    НОМ.ВыбратьЭлементы();
    Пока НОМ.ПолучитьЭлемент() > 0 Цикл

    Статус = 1; // 1 = Активен 0 = Помечен на удаление 2 = В группе "Не используется"

    Если НОМ.ПометкаУдаления() = 1 Тогда
    Статус = 0;
    КонецЕсли;

    Если НОМ.ЭтоГруппа() = 1 Тогда
    Продолжить;
    КонецЕсли;

    Если НОМ.ПринадлежитГруппе(НеИспГруппа)=1 Тогда
    Статус = 2;
    КонецЕсли;

    Категория = НОМ.Родитель.Наименование;

    ЦЕН=СоздатьОбъект("Справочник.Цены");
    ЦЕН.ИспользоватьВладельца(НОМ.ТекущийЭлемент());

    ТИПЦЕН = СоздатьОбъект("Справочник.КатегорииЦен");
    ТИПЦЕН.НайтиПоНаименованию("Розничная", 1);
    ТипЦены = ТИПЦЕН.ТекущийЭлемент();

    ЦЕН.НайтиПоРеквизиту("КатегорияЦены",ТипЦены,0);

    Цена = ЦЕН.Цена.Получить(ТекущаяДата());

    Т.ДобавитьСтроку(НОМ.Код+"^"+НОМ.Наименование+"^"+Цена+"^"+Статус+"^"+Категория);

    КонецЦикла;


    Файл="export.csv";

    Т.Записать (Файл);
    Сообщить ("Файл с данными "+Файл+" сохранен в каталоге пользователя");



    КонецПроцедуры
    Последнее редактирование: 1 апр 2017
  2. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    22.612
    Симпатии:
    541
    Баллы:
    204
    Для ТиС 9.2
    Остаток=ВремОстаткиТМЦ.Остаток(Фирма,Номенклатура,Склад,,"Количество");

    где ВремОстаткиТМЦ объект типа регистра остатков. До обращения нужно рассчитать