7.7 Выгрузка табличной части в файл xls

Тема в разделе "Отчеты и обработки для "1С:Предприятие 7.7"", создана пользователем MyNameNoName, 26 фев 2014.

  1. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Прошу помочь. Не могу разобраться как выгрузить данные из табличной части документа.
    Код:
    Объект = СоздатьОбъект("Документ.МойДокумент");
    Объект.ВыбратьДокументы();
    НомерСтроки = 1;
    Пока Объект.ПолучитьДокумент() = 1 Цикл 
    Лист.Cells(НомерСтроки, 1).NumberFormat = "@";
    Лист.Cells(НомерСтроки, 1).Value = Объект.НомерДок;
    НомерСтроки=НомерСтроки+1;
    КонецЦикла;
    
    Как я понимаю нужно еще создать Объект Таблица но не пойму как:
    Объект = СоздатьОбъект("Документ.МойДокумент.МояТаблица");
    или
    Объект = СоздатьОбъект("Таблица");
    ???
    И как потом перебрать значения в таблице?
    Объект.???
  2. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Написал код вот так:
    Код:
    ТабЧасть=Объект.ОсновноеСредство;
    Для Каждого Элемент Из ТабЧасть Цикл
    
    Ошибка:
    Для Каждого <<?>>Элемент Из ТабЧасть Цикл
    Ожидается символ '='
  3. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Зачем вы так усложняете? Выводите данные в объект Таблица и сохраняйте в формате XLS

    Записать(<ИмяФайла>,<ТипФайла>)
    Назначение:
    Записать таблицу в файл.
    Параметры:
    <ИмяФайла> - имя файла.
    <ТипФайла> - необязательный параметр. Числовое или строковое выражение, определяющее тип файла:
    · отсутствует, 0 или ''MXL'' - формат 1C;
    · 1 или ''XLS'' - формат Ms Excel;
    · 2 или ''HTM'' или ''HTML'' - формат HTML;
    · 3 или ''TXT'' - формат TXT.


    Только более 5500 строк не сохраняйте... Повиснет. "Особенность" 7ки
    MyNameNoName нравится это.
  4. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Мне нужно именно так выводить данные так как будут подтягиваться и стыковаться данные из нескольких документов. Я с 7-ой практически не работал, что не так в коде почему ошибка?
  5. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Конкретизируйте задачу.
    MyNameNoName нравится это.
  6. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Необходимо выгрузить данные из всех документ МодернизацияОС. Выгрузить необходимые данные из самого документа получается, а вот с табличными частями в 7.7 никогда не работал не могу разобряться как. Вот код:
    Код:
    Объект = СоздатьОбъект("Документ.МодернизацияОС");
    Объект.ВыбратьДокументы();
    Таблица=СоздатьОбъект("Документ.МодернизацияОС.ОсновноеСредство");
    НомерСтроки = 1;
    Пока Объект.ПолучитьДокумент() = 1 Цикл
    ТабЧасть=Объект.ОсновноеСредство;
    Для Каждого Элемент Из ТабЧасть Цикл
    Лист.Cells(НомерСтроки, 1).NumberFormat = "@";
    Лист.Cells(НомерСтроки, 1).Value = Элемент.ОсновноеСредство.Код;
    Лист.Cells(НомерСтроки, 2).NumberFormat = "@";
    Лист.Cells(НомерСтроки, 2).Value = Объект.НомерДок;
    //далее код
    НомерСтроки=НомерСтроки+1;
    КонецЦикла;
    КонецЦикла;
    
    Выскакивает ошибка:
    Для Каждого <<?>>Элемент Из ТабЧасть Цикл
    Ожидается символ '='
  7. alexburn
    Online

    alexburn Модераторы Команда форума Модератор

    Регистрация:
    5 янв 2009
    Сообщения:
    14.756
    Симпатии:
    509
    Баллы:
    204
    Что-то смущает синтаксис, в СП по этому вопросу что написано ?
    MyNameNoName нравится это.
  8. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Для Каждого
    заменяем на

    Объект.ВыбратьСтроки();
    Пока Объект.ПолучитьСтроку()=1 Цикл
    ....
    MyNameNoName нравится это.
  9. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    +
    Элемент.ОсновноеСредство.Код;
    тоже не годится... нужна ссылка через объект. Типа: Объект.ОС.Код
    MyNameNoName нравится это.
  10. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Код:
    Объект = СоздатьОбъект("Документ.МодернизацияОС");
            Объект.ВыбратьДокументы();
            //Таблица=СоздатьОбъект("Документ.МодернизацияОС.ОсновноеСредство");
           
            НомерСтроки = 1;
            Пока Объект.ПолучитьДокумент() = 1 Цикл 
                //Лист.Cells(НомерСтроки, 1).NumberFormat = "@";
                //Лист.Cells(НомерСтроки, 1).Value = Объект.НомерДок;
                Объект.ВыбратьСтроки();
                Пока Объект.ПолучитьСтроки()=1 Цикл
                ТабЧасть=Объект.ОсновноеСредство;
                    Лист.Cells(НомерСтроки, 2).NumberFormat = "@";
                    Лист.Cells(НомерСтроки, 2).Value = Объект.ОсновноеСредство.ОсновноеСредство.Код;
                    НомерСтроки=НомерСтроки+1;
                КонецЦикла;
            КонецЦикла;
    говорить поле объект не обнаружено ПолучитьСтроки()
  11. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Будьте внимательны...
    ПолучитьСтрокУ
    MyNameNoName нравится это.
  12. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    +
    Объект.ОсновноеСредство.ОсновноеСредство.Код;
    кажется масло маслянное...
    наверное
    Объект.ОсновноеСредство.Код;

    Какая конфа 7.7?
    MyNameNoName нравится это.
  13. TopicStarter Overlay
    MyNameNoName
    Offline

    MyNameNoName Опытный в 1С

    Регистрация:
    17 май 2013
    Сообщения:
    931
    Симпатии:
    0
    Баллы:
    26
    Большое спасибо, помогло!!!
  14. Бухгалтерский угодник
    Offline

    Бухгалтерский угодник Администраторы Команда форума Администратор

    Регистрация:
    29 дек 2008
    Сообщения:
    21.520
    Симпатии:
    407
    Баллы:
    104
    Не за что. Обращайтесь
    MyNameNoName нравится это.

Поделиться этой страницей